regression: volume scrolling is too slow

Bug #551725 reported by Alejandro J. Cura on 2010-03-30
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Medium
Conor Curran

Bug Description

Changing the volume by scrolling in the indicator icon is way too slow. It takes over a dozen scroll gestures on a standard mouse to get from full volume to mute. I believe it should take no more that 3 scroll gestures for a pleasant user experience, like the volume applet does: https://bugzilla.gnome.org/show_bug.cgi?id=607681

Related branches

affects: indicator-applet → indicator-sound
Conor Curran (cjcurran) on 2010-03-30
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) on 2010-03-30
Changed in indicator-sound:
status: New → In Progress
Conor Curran (cjcurran) on 2010-03-30
Changed in indicator-sound:
importance: Undecided → Medium

I found Karmic's progression to be excellent.

And though I agree it is too slow, I would like to add my personal voice that three scrolls is way too fast. I scroll using the icon for minute changes that my keyboard buttons can't do, and do drastic volume changes with the scroller from the menu.

Conor Curran (cjcurran) on 2010-03-30
Changed in indicator-sound:
milestone: none → 0.2.2
marmuta (marmuta) wrote :

I always felt Karmic's wheel volume control was too slow. All releases I remember before that took only two or three pushes of the wheel for full range. Adjusting volume became a bit of a chore since Karmic. I'm with Alejandro that gnome-volume-control-applet currently has it right, but since there are different opinions could the rate of change be made configurable?

There used to be this gconf key /apps/gnome_settings_daemon/volume_step for I believe both keyboard shortcuts and wheel volume, the latter stopped working at some point after Hardy though. Could it perhaps be reactivated for indicator-sound?

Conor Curran (cjcurran) wrote :

For now I have changed the step size so as 6 spins of the wheel should traverse the range. This should be merged in today.
Good idea about making it configurable. I think though due to work load this should be set to wishlist. Should hopefully have time to make this happen in the next iteration.
thx for the helpful feedback.
c

Conor Curran (cjcurran) on 2010-03-31
Changed in indicator-sound:
status: In Progress → Fix Committed
marmuta (marmuta) wrote :

Thanks Conor, I've filed the user configurability suggestion as Bug #553073. I can't mark it wishlist myself, so please feel free to do so.

Also looking at my comment #3 from launchpad, apparently half of the second part got lost. No idea what I did there, but for the record the gist was the same as in the above bug report: IMO currently gnome-volume-control-applet has it right with 5% per wheel step but please consider using a gconf key like "/apps/gnome_settings_daemon/volume_step" for the step size.

madbiologist (me-again) wrote :

This bug is fixed in indicator-sound 0.2.2-0ubuntu1
From the changelog:

* New upstream version
    - Animation for mute-blocking state greatly improved
    - Handles sink removal far better
    - improves scrolling action icon on panel
 -- Sebastien Bacher Wed, 31 Mar 2010 18:12:47 +0200

I have tested and can confirm the fix.

Changed in indicator-sound:
status: Fix Committed → Fix Released
Josh Burghandy (kid1000002000) wrote :

This is broken again in 11.10 and is a duplicate of bug https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/871133.

Marco (marcodefreitas) wrote :

The volume steps must be logarithmic, like real knobs on actual analog volume controls.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers