ubuntu wont log out/shut down

Bug #891083 reported by alex_osborn on 2011-11-16
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Session Menu
Confirmed
Undecided
Unassigned
indicator-session (Ubuntu)
Undecided
Unassigned
lightdm (Ubuntu)
Undecided
Unassigned

Bug Description

logout:
$ /usr/lib/indicator-session/gtk-logout-helper --logout

** (gtk-logout-helper:31585): DEBUG: Dialog type: logout
** (gtk-logout-helper:31585): DEBUG: Showing dialog to ask for user confirmation
** (gtk-logout-helper:31585): DEBUG: Dialog return response: 'okay'
** (gtk-logout-helper:31585): DEBUG: Asking Session manager to 'Logout'

** (gtk-logout-helper:31585): WARNING **: SessionManager action failed: Logout has been locked down
** (gtk-logout-helper:31585): DEBUG: Falling back to using ConsoleKit for action

** (gtk-logout-helper:31585): WARNING **: Unable to fallback to ConsoleKit for logout as it's a session issue. We need some sort of session handler.
** (gtk-logout-helper:31585): DEBUG: Finished action, quiting

shutdown:
$ /usr/lib/indicator-session/gtk-logout-helper --shutdown
** (gtk-logout-helper:5226): DEBUG: Dialog type: shutdown
** (gtk-logout-helper:5226): DEBUG: Showing dialog to ask for user confirmation
** (gtk-logout-helper:5226): DEBUG: Dialog return response: 'okay'
** (gtk-logout-helper:5226): DEBUG: Asking Session manager to 'RequestShutdown'
** (gtk-logout-helper:5226): DEBUG: Finished action, quiting

release:11.10
indicator-session 0.3.7.1-0ubuntu1.1
what i expected: to be able to log out/shut down from unity bar
what happened instead:nothing

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-session 0.3.7.1-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Wed Nov 16 18:34:08 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-session
UpgradeStatus: Upgraded to oneiric on 2011-11-13 (3 days ago)

alex_osborn (alex-osborn0) wrote :
Teo (teo1978) wrote :

Same problem here, slightly different output for --logout:

$ /usr/lib/indicator-session/gtk-logout-helper --logout
** (gtk-logout-helper:6291): DEBUG: Dialog type: logout
** (gtk-logout-helper:6291): DEBUG: Showing dialog to ask for user confirmation
** (gtk-logout-helper:6291): DEBUG: Dialog return response: 'okay'
** (gtk-logout-helper:6291): DEBUG: Asking Session manager to 'Logout'
** (gtk-logout-helper:6291): DEBUG: Finished action, quiting

$ /usr/lib/indicator-session/gtk-logout-helper --shutdown
** (gtk-logout-helper:6327): DEBUG: Dialog type: shutdown
** (gtk-logout-helper:6327): DEBUG: Showing dialog to ask for user confirmation
** (gtk-logout-helper:6327): DEBUG: Dialog return response: 'help'
** (gtk-logout-helper:6327): DEBUG: Asking Session manager to 'RequestReboot'
** (gtk-logout-helper:6327): DEBUG: Finished action, quiting

Nothing happens in both cases.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
alex_osborn (alex-osborn0) wrote :

bump

Hanine HAMZIOUI (hanynowsky) wrote :

The bug is still in 12.04 Beta.
It does not occur when using other desktop managers like KDE, XFCE....
Only affects Unity (Lightdm) and Gnome-Shell.

Forced to use command lines to logout/shutdown:

sudo shutdown -h 0

sudo restart lightdm

alex_osborn (alex-osborn0) wrote :

ok, maybe this but is under lightdm instead of indicator-session ?

Hanine HAMZIOUI (hanynowsky) wrote :

the file xsession-errors in home directory does not help :

This is what I get instantly when I click on shutdown or logout button

-------------------------
encoding error : output conversion failed due to conv error, bytes 0xB4 0x75 0x62 0x75
I/O error : encoder error
WARN 2012-03-04 19:35:46 unity <unknown>:0 Unable to fetch children: No such interface `org.ayatana.bamf.view' on object at path /org/ayatana/bamf/application1003059470

WARN 2012-03-04 19:35:46 unity <unknown>:0 Unable to fetch children: No such interface `org.ayatana.bamf.view' on object at path /org/ayatana/bamf/application1003059470
---------------------------------

In 11.10 the bug occured 80% of time. Now in 12.04 100%.
Some believe that this is the USB 3 controller bug that causes this but I can't decipher how.

It is probably related to Unity and Lightdm rather.

Hanine HAMZIOUI (hanynowsky) wrote :

Just to add that the issue seems to be fixed since before yesterday. 12.04 Beta 1.
Now normal shutdown and logout work.
Please check if it's fixed for you and mark it as fixed.

Hanine HAMZIOUI (hanynowsky) wrote :

For the logout :
/usr/lib/indicator-session/gtk-logout-helper --logout prompts the logout applet and clicking on Logout ends the sessions and gets you back to the Lightdm greeter.

Same behavior when you click on Logout button from the user system button.

andrea de cesarei (andrea-dece) wrote :

In my case the bug disappeared after unchecking the "enable systray quickstarter" in libreoffice. if it is ckecked again, the problem returns

Hanine HAMZIOUI (hanynowsky) wrote :

Yeah maybe the soffice daemon was causing this. (Now even with the systray starter enabled shutdown/logout works fine).
Actually in 12.04 as for today, the logout process kills the sffoice daemon before shutting down or loging out.

Waiting for ubuntu team to confirm the status of this bug.

Olli Ries (ories) wrote :

please reopen if problem still exists in 12.04

Changed in indicator-session:
status: New → Incomplete
Gaston la Gaffe (i-komorowski) wrote :

I have same problem in 12.04.
Problem appeared first after updating 11.10. (in june 2012) and still exists after upgrade to 12.04.

Anders Sandblad (arune) wrote :

Same issue here after upgrading from 10.04 to 12.04:
arune@srv1:~$ /usr/lib/indicator-session/gtk-logout-helper
** (gtk-logout-helper:26406): WARNING **: SessionManager action failed: Logout has been locked down
** (gtk-logout-helper:26406): WARNING **: Unable to fallback to ConsoleKit for logout as it's a session issue. We need some sort of session handler.

I found a gconf entry named /apps/panel/global/disable_log_out (see more http://library.gnome.org/admin/deployment-guide/ ) which was enabled, disabling did not help, neither deleting the entry.

I also tried the following:
arune@srv1:~$ dbus-send --session --type=method_call --print-reply --dest=org.gnome.SessionManager /org/gnome/SessionManager org.gnome.SessionManager.Logout uint32:0
Error org.gnome.SessionManager.LockedDown: Logout has been locked down

Please help me debug this futher.

Changed in indicator-session:
status: Incomplete → Confirmed
Marius B. Kotsbak (mariusko) wrote :

Is anybody able to reproduce this in Ubuntu 12.10?

Changed in indicator-session (Ubuntu):
status: Confirmed → Incomplete
Hanine HAMZIOUI (hanynowsky) wrote :

I cannot reproduce this bug neither in 12.10 nor in 12.04.

Anders Sandblad (arune) wrote :

Do you really want me to upgrade from LTS version on my server to be able to log out a user?

Marius B. Kotsbak (mariusko) wrote :

Okay, then it seems like it is a workaround to upgrade.

Anders: which LTS do you use? You should be able to upgrade to 12.04 LTS easily, but it is sufficient to test a live CD/USB image.

And I am a bit curious about your server. Do you run a GUI on it, or what is the use case of logging out a user here?

Anders Sandblad (arune) wrote :

I use 12.04 (as stated 2012-10-15).

I'm running a small company with two workstations (one with Ubuntu Desktop and one with Windows 7), we also have a server for file- and webservices etc. This server is also used as a workstation with GUI.

I'm generally a bit cautious when it comes to upgrades at work, at least the first few month of a new release.

Anyway, why is this bugged marked as incomplete? What is missing?
Olli Ries set it to incomplete with the comment "please reopen if problem still exists in 12.04" which I confirmed.

Marius B. Kotsbak (mariusko) wrote :

I was not able to reproduce this in 12.10. There are some different comments here about 12.04. Are you running gdm or lightdm? I wonder if this is a duplicate of bug #1064388?

The bug is in incomplete state now because there are unanswered questions. Anders, are you able to boot up a 12.04 live CD/USB stick and try to reproduce this on the server?

Anders Sandblad (arune) wrote :

Greeter looks like this, I guess it's lightdm, and that is default in Ubuntu right?
http://www.tuxtree.com/wp-content/uploads/2012/05/image31.png

Marius B. Kotsbak (mariusko) wrote :

Yes, think so.

m038 (m-gorinskat) wrote :

I'm still experiencing this bug on Ubuntu 12.04 LTS. I'm using LightDM and run Gnome Classic.

The 'Log out' and 'Shutdown' functionality does not work from the gnome menu. In my logs following appears (only when i select the option 'Shutdown'):

"gnome-session[2533]: WARNING: Unable to logout: Logout has been locked down"

What have i tried:
- I've inserted the LiveCD, when i try Ubuntu, then the shutdown / logout menu works fine.
- When I'm in LightDM the menu works fine (so i don't think it's a duplcate of https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/1064388)
- I've installed GDM, to check if it was related to LightDM, bug still occured

My workaround for shutting down / restarting. Restart X (ctrl + alt + backspace), then select shutdown from the menu in LightDM.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

Closing assumed fixed.

Changed in lightdm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers