Installs in Mint 17.3 LXDE but does not run

Bug #1551737 reported by Barry Morgan on 2016-03-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Indicator Remindor
Undecided
Brian Douglass

Bug Description

No errors during installation but no response from launch icon

Running from command line gives the following:

/usr/lib/python2.7/dist-packages/gi/types.py:259: RuntimeWarning: Mixin class remindor_common.scheduler.GenericScheduler is an old style class, please update this to derive from "object".
  RuntimeWarning)

Then nothing happens at all with no prompt return in terminal.

Brian Douglass (bhdouglass) wrote :

Is that all the output from the app? Can you send me the log file from ~/.config/indicator-remindor/ ? (FYI I got your email as well, figured here was a better place to respond)

Changed in indicator-remindor:
assignee: nobody → Brian Douglass (bhdouglass)
Barry Morgan (k-burry-x) wrote :

Found the bug report link after the e-mail :-)

When 'run' nothing at all happens, either from command line or launcher.

Contents of log:

2016-03-01 13:28:28,400 DEBUG:indicator_remindor: set_up_logging() 'indicator-remindor version 15.09'
2016-03-01 13:28:28,400 DEBUG:indicator_remindor: set_up_logging() 'remindor-common version 15.06.2'
2016-03-01 13:28:29,085 DEBUG:indicator_remindor: finish_initializing() 'Initializing Manage window'
2016-03-01 13:28:29,095 DEBUG:indicator_remindor: __init__() 'consider using a pythonic name instead of design name 'treeview-selection''
2016-03-01 13:28:29,284 DEBUG:indicator_remindor: finish_initializing() 'creating popup menu'
2016-03-01 13:28:29,289 DEBUG:indicator_remindor: finish_initializing() 'done creating popup menu'
2016-03-01 13:28:29,289 DEBUG:indicator_remindor: finish_initializing() 'setting up treeview cells'
2016-03-01 13:28:29,298 DEBUG:indicator_remindor: finish_initializing() 'done setting up cells'
2016-03-01 13:28:29,317 DEBUG:indicator_remindor: finish_initializing() 'indicator --> icon: indicator-remindor-active, theme: None, order: 2154393188'
2016-03-01 13:28:29,317 DEBUG:indicator_remindor: finish_initializing() 'indicator --> status: active'
2016-03-01 13:28:29,318 DEBUG:indicator_remindor: finish_initializing() 'initializing scheduler and updating reminder list'
2016-03-01 13:28:29,318 DEBUG:remindor_common: __init__() 'initializing genericscheduler'
2016-03-01 13:28:29,337 DEBUG:indicator_remindor: update_alarms() 'update_alarms'
2016-03-01 13:28:29,348 DEBUG:indicator_remindor: update_alarms() 'update_alarms: setting up headers'
2016-03-01 13:28:29,352 DEBUG:indicator_remindor: update_alarms() 'update_alarms: done setting up tree'
2016-03-01 13:28:29,354 DEBUG:indicator_remindor: finish_initializing() 'Manage window done initializing'
2016-03-01 13:28:29,375 DEBUG:remindor_common: run() 'checking for news'
2016-03-01 13:28:29,452 DEBUG:indicator_remindor: clear_indicator() 'clear_indicator'
2016-03-01 13:28:29,453 DEBUG:indicator_remindor: clear_indicator() 'widget: <Menu object at 0xb51bef7c (GtkMenu at 0x9fd2b28)>'
2016-03-01 13:28:29,453 DEBUG:indicator_remindor: clear_indicator() 'data: None'
2016-03-01 13:28:29,454 DEBUG:indicator_remindor: clear_indicator() 'clear_indicator done'
2016-03-01 13:28:29,454 DEBUG:indicator_remindor: clear_indicator() 'emmiting dbus active signal'
2016-03-01 13:28:29,467 DEBUG:indicator_remindor: dbus_receiver() 'received active signal from dbus'
2016-03-01 13:28:31,060 DEBUG:remindor_common: run() 'done checking for news'

Barry Morgan (k-burry-x) wrote :

Have to go out on a job so catch up with this later... Thanks for the fast response!!

Brian Douglass (bhdouglass) wrote :

That log isn't giving me any clues. I'll have to see if I can setup a Mint VM to test his myself.

Barry Morgan (k-burry-x) wrote :

Just tried in on Mint 17.3 KDE and got same result, also same error message opening by command line.

Barry Morgan (k-burry-x) wrote :

Update on the last comment - after a reboot it worked on the KDE version but still no go on the LXDE one.

Barry Morgan (k-burry-x) wrote :

Not nagging, just adding more info that may help :-)

Tried running Indicator Remindor on KDE from command line and got the same error message as in the LXDE version but the program did run so the hiccup appears to be after that.

Also on LXDE I started System Monitor and the program executable pops up but disappears after a couple of seconds so something it terminating the program without giving any errors. When tried via command line the same thing happens but the terminal window does not get the prompt back after the program is terminated. CPU load isn't affected so it's not like an orphaned process looping.

On KDE if started by command line the terminal window gets the prompt back if the program is manually closed from the tray icon.

Will await your investigation now I've given all I can currently.

Brian Douglass (bhdouglass) wrote :

I unfortunately didn't run into any trouble when I installed Linux Mint 17.3 and LXDE. Can you link me to the version you are using, maybe I've got something different.

Barry Morgan (k-burry-x) wrote :

So when you tried it the program ran OK and produced the tray icon?

Curious - got the download from the Mint web site, which has been up and down recently due to their recent hack, and running in Virtual Box on Mint 17.3 KDE (I assist a long time friend in Bhopal who has switched from Windows to Linux so like to have a virtual version of what he has to guide him with screen shots etc that will match what he sees).

In the meantime he's tried to boot the KDE DVD and his quite old motherboard won't take it, hence the suggestion to use LXDE in the first place. I'll get him to try Indicator Remindor on his current LXDE install and see how it goes then get back to you.

Brian Douglass (bhdouglass) wrote :

Yes, it ran fine with the tray icon. Let me know if that works or not!

Brian Douglass (bhdouglass) wrote :

I had an idea: Try running "indicator-remindor -p", that will pop up the preferences window (if it works). Then try to change the Interface > Indicator Icon setting to something like "App Icon", then try launching it again normally. Let me know if that works.

Barry Morgan (k-burry-x) wrote :

Still working with my friend in Bhopal getting this sorted, he's not the most technical and in the course of copying the commands has corrupted the help document I had made for him <sigh> Might need another Team Viewer session with him at some point, time difference makes that something we have to pre-arrange (I'm in UK).

I had successfully installed onto a fresh install of Mint on a laptop here so once the command line issue is sorted I'm sure it will work for him too.

Just a curiosity I picked up. On Mint 17.3 KDE (the system I use) the icon needs a right click to bring up the management pop-up but on the Mint my friend has to use it's a left click to get the same pop-up. Still works the same.

I still have the virtual Mint here so will try the -p command to see what happens. Any other command line options that may be useful?

Brian Douglass (bhdouglass) wrote :

I believe the right click/left click is a function of the desktop environment, so it may be different depending on your setup.

If you run "indicator-remindor --help" it will list all the available commands.

I'm going to close this bug, but feel free to open another if you run into other issues.

Changed in indicator-remindor:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers