Time to charge may be hard to distinguish from time to discharge

Bug #824629 reported by Matthew Paul Thomas on 2011-08-11
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
Matthew Paul Thomas
indicator-power
Confirmed
Undecided
Unassigned
indicator-power (Ubuntu)
Undecided
Unassigned

Bug Description

indicator-power 0.5-0ubuntu1, Ubuntu Ocelot

1. From the battery menu, turn on "Show Time in Menu Bar".
2. Unplug AC power.
3. Reconnect AC power.

What happens: The time left to use, and time left to charge, are shown in exactly the same way.

If this is bad, it is a design mistake on my part. <https://wiki.ubuntu.com/Power#Battery_menu>

Possible solutions:

a. Do nothing -- rely on the icon to convey the difference between charging and discharging.
    - Pro: Status quo, requires no work.
    - Con: The text may lead people to think they do not need to look at the icon.

b. Show time left to use without brackets, time left to charge with brackets.
    - Pro: Correctly implies that time left to charge is not as important.
    - Con: Whenever there's nothing between the battery and clock menus, the two bits of text could be confused.

c. Continue to show both in brackets, but add a minus sign for time left to charge.
    - Pro: Compact.
    - Con: Obscure.

Any other ideas?

Matthew Paul Thomas (mpt) wrote :
Steve Alexander (stevea) wrote :

How about this:
Show time left to use with brackets, time left to charge without brackets but followed by U+26A1, ⚡.

Dave Morley (davmor2) wrote :

mpt how about adding an E one end an F the other like a fuel gauge and then put the time at the relevant side. E side for how long is left of use and the F side for on charge

Idea B is the best.

Jay S (topdownjimmy) wrote :

The clock confusion of (b) could be solved by changing the notation to "1h51m".

Also, maybe an up arrow for charging, a down arrow for discharging, and no brackets? This could be confusing though, since when the up arrow is displayed (charging), the time goes down.

Javier Jardón (jjardon) wrote :

I went ahead and implemented the option b for the 0.6 release. I keep open this bug to get more feedback or suggestions

Changed in indicator-power:
status: New → In Progress
Matthew Paul Thomas (mpt) wrote :

Thanks for those suggestions. I find it particularly interesting that Steve, Dave, and Jay all suggested adding a symbol of some sort — ⚡, E/F, or ↑/↓ — to distinguish between charging and discharging.

It's interesting because that's what the battery icon is supposed to be in the first place: a symbol for distinguishing between discharging and charging. Redundancy that is different in mode (e.g. color as well as sound, or icon as well as text) is good, but redundancy in the same mode is usually bad. The battery icon already contains a ⚡ symbol. If we feel the desire to add a second symbol, that suggests not that we *should* add a second one, but that there is a problem with the position or style of the existing one. (See bug 772237 for an example of this principle in Launchpad itself.)

So I conclude that the problem is not with the text, but just with the icon. We could move the lightning bolt out of the icon entirely, leaving the icon to concentrate only on showing charge level, while charge/discharge is shown in the text. But as I discussed in bug 811777, the charge level is of secondary importance to the time remaining, so it would be unfortunate for the menu to widen just for the sake of showing charge level.

Instead, I think the shading inside the battery when charging is obscuring the lightning bolt, and also giving the icon a visual style that is obviously different from the text and discourages "reading" it together with the text. So, I suggest leaving the brackets in place, but removing the shading from the icon.

Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Low
status: New → Fix Released
Javier Jardón (jjardon) wrote :

> So, I suggest leaving the brackets in place, but removing the shading from the icon.

So you suggest use the same icon for all the charge levels if we are in the charging status?
Rigth now the icon depends on the charge level of the battery (as reported by g-s-d), but I guess I can use always the same icon when charging if you want.

Changed in indicator-power:
status: In Progress → Incomplete
Matthew Paul Thomas (mpt) wrote :

Yes -- unless/until someone finds a way to draw the charging icons such that they don't use shading, I think it would be better to just use a single charging icon regardless of level. Thanks Javier.

Changed in indicator-power:
status: Incomplete → Confirmed
Paul Sladen (sladen) wrote :

I don't think the brackets are a gainly solution. They add clutter and visual noise without adding value (we're heading back to GNOME 2 Panel levels of inconsistency). To step back:

  1. Menus are textual.
  2. Visual indicator menu items are *stand-ins* for textual menus.

The logical way to solve this (IMHO) is to ensure that the "full textual menu" makes sense; this to replace a subset of that with an appropriate icon in a graphical environment.

mpt: If indicator-menu was purely textual (which is needed anyway for a11y), what would you expect it to show in various situations?

Matthew Paul Thomas (mpt) wrote :

I have already specified the accessible name for the menu title. <https://wiki.ubuntu.com/Power#Title> GUIs are made of many small navigable elements, and therefore accessible names can give more detail and explanation at the end, secure in the knowledge that if you didn't want to hear it you would have navigated somewhere else by now. And unless you're a Victor Borge fan, punctuation is not that audible. For those two reasons, I specified accessible names of the form "Mouse (27 minutes to charge)", not "Mouse (0:27)". And for those two reasons, the accessible name is not relevant to this bug.

The Gnome 2 comparison is hyperbole. As described in the original report, if the presentation of battery time remaining was perfectly consistent with the clock, that would be a bad thing.

Javier Jardón (jjardon) wrote :
Changed in indicator-power:
status: Confirmed → Fix Committed
Javier Jardón (jjardon) on 2011-09-12
Changed in indicator-power:
status: Fix Committed → Fix Released
James Hunt (jamesodhunt) wrote :

Just had a chat with Javier (see bug 861300) and it seems I've just got bitten by this change . The new default behaviour (where "show time in menu bar" is not enabled) is that:

  - if the battery is charging, you see a battery *outline* with a zig-zag within it.
  - when the battery is charging/charged, you see a partially/fully filled battery icon with *no* zig-zag.

The problem here is that if the battery is fully charged it is (now) impossible to distinguish visually if the system is on AC power or not, which I find confusing.

My preference would be to:

- *Always* show a "filled" icon (partially filled or fully filled).
- If on AC power, just overlay the zig-zag onto the filled icon.

This way there is no ambiguity and no visual information about where my system is sucking power from is lost.

Matthew Paul Thomas (mpt) wrote :

James, this bug report is about the icon while charging. I've reported the incorrect icon when fully charged as bug 865342.

Charles Kerr (charlesk) wrote :

I'm reopening this ticket because the fix that was committed has side-effects described in bug #1215520, so I'm reverting that change.

Changed in indicator-power:
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+13.10.20131004-0ubuntu1

---------------
indicator-power (12.10.6+13.10.20131004-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * Revert bug #824629 code -- use the correct charge % when deciding
    what icon to use. (LP: #1215520, #824629)
  * Listen for the "Resuming" signal from upower to refresh devices when
    resuming from suspend/hibernate. (LP: #1224931)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 204
 -- Ubuntu daily release <email address hidden> Fri, 04 Oct 2013 02:28:43 +0000

Changed in indicator-power (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers