As deivce comes back from lock, the back-light level becomes max instead of the last set value

Bug #1287599 reported by Yuan-Chen Cheng on 2014-03-04
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
indicator-power
Fix Released
High
Yuan-Chen Cheng
indicator-power (Ubuntu)
Undecided
Unassigned
powerd (Ubuntu)
High
Yuan-Chen Cheng

Bug Description

Currently powerd is control the backlight on/off, and indicator-power is control how bright is should be.

The backlight brightness level should be consistent within those two process. (Currently not)

To reproduce:

On n4 with dev channl rel 194
1. open power indicator (or app "System Settings", choose battery and set the brightness)
2. set the brightness level to certain point (make it lower so that you can see it more clearly)
3. press power button to lock the device
4. press power button to unlock the device

Expected result:
Brightness level is the one we set in the indicator

Current result:
Brightness level is always in a value that's relative high.

Related branches

Changed in indicator-power:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
Yuan-Chen Cheng (ycheng-twn) wrote :

Analysis:

- powerd control backlight by using android library through hybris.
- powerd currently have dbus method that can adjust brightness, and it will remember the value of brightness if the value is set via dbus method. currently the dbus method only allow process with root account to use.
- indicator-power control backlight by find the backlight device throught udev matching rule.

Proposed solution:

- modify the powerd to allow method call from non-root process (indicator-power run by account phablet)
- modify indicator-power to check whether the bus name that powerd use is claimed. If yes, it use dbus method to control backlight. Or else it fall back to udev matching rule to find backlight device node.

Jamie Strandboge (jdstrand) wrote :

This is probably a duplicate of 1260986.

Changed in indicator-power:
status: New → In Progress
Yuan-Chen Cheng (ycheng-twn) wrote :

Hi Jamie,

I confirm that bug #1260986 can be reproduce on n4 with firmware in dev channel rel 194.

From my test, it seems that my current design in my branch can also fix that bug. I'll mark it there.

Changed in indicator-power:
importance: Undecided → High
Changed in powerd (Ubuntu):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powerd - 0.13+14.04.20140327-0ubuntu1

---------------
powerd (0.13+14.04.20140327-0ubuntu1) trusty; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Ricardo Salveti de Araujo ]
  * Aborting in case it can't find the android input compat stack
  * Requesting default display and system state when running in the
    emulator.

  [ Colin King ]
  * Minor tidy up and corrections to powerd cli help (LP: #1231455) (LP:
    #1231455)

  [ Y.C cheng ]
  * Allow non-root to talk to powerd. (LP: #1287599)
 -- Ubuntu daily release <email address hidden> Thu, 27 Mar 2014 21:01:04 +0000

Changed in powerd (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+14.04.20140326-0ubuntu1

---------------
indicator-power (12.10.6+14.04.20140326-0ubuntu1) trusty; urgency=low

  [ Y.C cheng ]
  * Set brightness via powerd if it exist (using dbus) (LP: #1287599)
 -- Ubuntu daily release <email address hidden> Wed, 26 Mar 2014 18:50:46 +0000

Changed in indicator-power (Ubuntu):
status: New → Fix Released
Changed in indicator-power:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers