Weirdly-located label for battery "Brightness"

Bug #1240756 reported by Allan LeSage on 2013-10-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-power
Fix Committed
Undecided
Nick Dedekind
indicator-power (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Nick Dedekind

Bug Description

Possibly this is related to lp:1227250 , which I see is freshly fixed; I'm on build 99 (20131015.2), and I've seen this in earlier builds although I haven't been able to reproduce it (and am not confident of these conditions now :( ). With these caveats, I'll attach a screenshot.

The label for the brightness indicator appears (unreliably) inside the slider--is this intentional?

Will verify in released image tomw.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: indicator-power 12.10.6+13.10.20131008-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.5-0ubuntu2
Architecture: armhf
Date: Thu Oct 17 01:07:24 2013
InstallationDate: Installed on 2013-10-15 (1 days ago)
InstallationMedia: Ubuntu 13.10 - armhf (20131015.2)
MarkForUpload: True
SourcePackage: indicator-power
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Allan LeSage (allanlesage) wrote :
Changed in indicator-power (Ubuntu):
milestone: none → ubuntu-13.10
Changed in indicator-power (Ubuntu):
milestone: ubuntu-13.10 → saucy-updates
Lars Karlitski (larsu) wrote :

This is more likely to be a bug in unity8.

affects: indicator-power → unity8
no longer affects: indicator-power (Ubuntu)
Michał Sawicz (saviq) wrote :

No, it's not intentional. Please make Confirmed if you can find a way to and reproduce.

Changed in unity8:
status: New → Incomplete
Nick Dedekind (nick-dedekind) wrote :

This is both unity8 and indicator-power issue.

indicator-power shouldn't be setting a "Brightness" label for the items it doesn't want to have a label.
There is also a bug in unity8 slider item which isn't giving the correct width for the sliders which have a label.

Changed in indicator-power:
assignee: nobody → Charles Kerr (charlesk)
Changed in unity8:
assignee: nobody → Nick Dedekind (nick-dedekind)
status: Incomplete → Confirmed
status: Confirmed → In Progress
Changed in indicator-power:
assignee: Charles Kerr (charlesk) → Nick Dedekind (nick-dedekind)
Changed in indicator-power:
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-power at revision 212, scheduled for release in indicator-power, milestone Unknown

Changed in indicator-power:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision 497, scheduled for release in unity8, milestone phone-v1-freeze

Changed in unity8:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.83+14.04.20131106-0ubuntu1

---------------
unity8 (7.83+14.04.20131106-0ubuntu1) trusty; urgency=low

  [ Andrea Cimitan ]
  * Place ShaderEffectSource of UbuntuShapeForItem under the Shape Item.
    (LP: #1239317)

  [ Omer Akram ]
  * test: make sure the search indicator hides when an app has focus.

  [ Nick Dedekind ]
  * Fixed indicator slider menu item alignment to label field and icon.
    (LP: #1240756)

  [ chris.gagnon ]
  * Update to autopilot 1.4.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 500
 -- Ubuntu daily release <email address hidden> Wed, 06 Nov 2013 03:37:02 +0000

Changed in unity8 (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq) on 2013-11-07
Changed in unity8:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+14.04.20131125-0ubuntu1

---------------
indicator-power (12.10.6+14.04.20131125-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * We really only need to keep a handful of properties up-to-date for
    each upower device. Given that upower requires us to refetch all
    properties with GetAll whenever it signals that it's changed, we
    really don't need to keep bus proxies alive for each device.
    Removing the autogenerated proxy code and just using a couple of the
    direct GDBusConnection API calls cuts out some unnecessary overhead
    according to health-check. See the before & after profile logs
    attached to the ticket. (LP: #1221871)
  * fix a minor memory leak that was caused by treating the variant
    returned by g_icon_serialize() as floating.

  [ Ted Gould ]
  * Switching DBus service to an Upstart Job. (LP: #1185565)

  [ Nick Dedekind ]
  * Removed Label from brightness slider. (LP: #1240756)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 215
 -- Ubuntu daily release <email address hidden> Mon, 25 Nov 2013 03:55:08 +0000

Changed in indicator-power (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers