indicator-multiload does not autostart

Bug #836893 reported by Alexander Torstling on 2011-08-29
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
System Load Indicator
High
Michael Hofmann
indicator-multiload (Ubuntu)
Undecided
Unassigned

Bug Description

Indicator-multiload does not start up automatically on startup although i have ticked 'Autostart' (which remains ticked even after system reboot). How can i debug this? Logs, debug options?

Michael Hofmann (mh21) wrote :

Hi Alexander,

thanks for your bug report.

What desktop environment (Unity/gnome2) and Ubuntu version are you using?

Could you post the output of:
  dpkg -s indicator-multiload
  gsettings list-recursively de.mh21.indicator.multiload
  cat .config/autostart/indicator-multiload.desktop

Could you also check whether it is listed and checked correctly in System->Settings->Autostart?

Michael Hofmann (mh21) on 2011-08-31
Changed in indicator-multiload:
status: New → Incomplete

Hi Michael,

I have attached the output of the requested commands. The ".config/autostart"-directory seems to be missing. I could not find any permission problems. Am I missing the autostart-component of Unity somehow perhaps? Is there any package I should install?

Best regards

Alexander

Oh and I couldn't find System->Settings->Autostart. I looked in 'Power menu (top right)'->System Settings->Startup Applications, and indicator-multiload is not listed there. Anywhere else I should look?

Michael Hofmann (mh21) wrote :

Hi Alexander,

Could you check whether the new version at ppa:indicator-multiload/stable-daily fixes your problem (indicator-multiload - 0.2-0+33~11~15~natty1)?

Should now create the .config/autostart directory if not found... :-)

Changed in indicator-multiload:
status: Incomplete → Fix Committed
status: Fix Committed → Fix Released
importance: Undecided → High
assignee: nobody → Michael Hofmann (mh21)

Hi Michael!

It all seems to work fine now, I have the config file and the app starts automatically as expected. I haven't checked if the autostart dir autocreates, since I coincidentally started to fiddle with some other program which also had autostart, and offered to create the directory for me. I beleive that it was compiz settings (screenlets) or so.

Thanks for the quick fix.

useResa (rdrijsen) wrote :

I just installed the indicator-multiload applet on a clean installation of Ubuntu 11.04 however, it did not autostart.
The version I installed was:
$ dpkg -s indicator-multiload
Package: indicator-multiload
Status: install ok installed
Priority: extra
Section: utils
Installed-Size: 1664
Maintainer: Michael Hofmann <email address hidden>
Architecture: i386
Version: 0.2-0+33~14~15~natty1
Depends: libappindicator1 (>= 0.2.91), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.4), libcairo2 (>= 1.2.4), libdbusmenu-glib3 (>= 0.4.2), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.28.0), libgtk2.0-0 (>= 2.18.0), libgtop2-7 (>= 2.23.2), libpango1.0-0 (>= 1.14.0)
Description: Graphical system load indicator for CPU, ram, etc.
 A system load indicator capable of displaying graphs for CPU, ram, and swap
 space use, plus network traffic.
Homepage: https://launchpad.net/indicator-multiload

What I did to work around this is:
1. Create the autostart directory in ~/.config
2. Copied the multiload-indicator.desktop file from /usr/share/applications to ~/.config/autostart
3. Logged out and logged back in
Now the indicator showed.

Bruno Medeiros (brunojcm) wrote :

I had a similar problem, My indicator doesn't started automatically before I first launched the indicator manually. Is it normal??

Michael Hofmann (mh21) wrote :

Yeah, the idea is that you have to manually start it once (kind of an opt-in).

Paul Whittaker (launchpad-pdw) wrote :

Still seeing this on Ubuntu 12.04 (64-bit) with version 0.2-0ubuntu1 from the standard repositories. Starting the indicator manually works fine, but the autostart directory isn't created.

Toggling the 'autostart' preference when directory ~/config/autostart/ doesn't exist produces this error:

Could not create autostart desktop file: Failed to create file '/home/me/.config/autostart/indicator-multiload.desktop.R0UYIW': No such file or directory

As soon as I manually create a ~/config/autostart/ directory, the indicator-multiload.desktop file is created there as expected and no error is reported.

Is version 0.2-0ubuntu1 expected to contain the fix for this?

Chris Carlin (crcarlin) wrote :

Just want to highlight Paul's solution:

mkdir ~/config/autostart/
then launch the application and toggle autostart in the prefs

andrew667 (andrei-yurevich) wrote :

This bug is reproducable in fresh install of 12.04.2 (64bit). When I start applet the output from terminal:

Candrew667@andrew667-desktop:~$ indicator-multiload
/usr/share/indicator-multiload/preferences.ui

(indicator-multiload:4485): GLib-GIO-CRITICAL **: GApplication subclass 'Main' failed to chain up on ::startup (from start of override function)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers