network not indicating mobile broadband

Reported by thomas on 2011-06-17
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
System Load Indicator
Medium
Michael Hofmann

Bug Description

This applet doesn't recognize network-traffic coming in or going out via mobile broadband connection (using UMTS).

Michael Hofmann (mh21) on 2011-08-15
Changed in indicator-multiload:
milestone: none → 0.3
Michael Hofmann (mh21) wrote :

Could you try to install the beta version from http://mh21.de/temp/indicator-multiload_0.3-0~43~15_amd64.deb?

I don't think this version will solve your problems (yet), but you can start it with "indicator-multiload -v" to get some information on the processing that is going on behind the scenes.

This should give you a dump of all recognized network devices. Could you post an example of the resulting output?

Michael Hofmann (mh21) on 2011-08-20
Changed in indicator-multiload:
importance: Undecided → Medium
assignee: nobody → Michael Hofmann (mh21)
Michael Hofmann (mh21) wrote :

Thomas, could you post the output of "indicator-multiload -v" for UMTS?

Changed in indicator-multiload:
status: New → Incomplete
thomas (thomas-heuer) wrote :

There is not much output:

--
$ indicator-multiload -v
/usr/share/indicator-multiload/preferences.ui

(indicator-multiload:746): GLib-GIO-CRITICAL **: This application can not open files.
--

Michael Hofmann (mh21) wrote :

Hi Thomas, could you try to install the beta version from ppa:indicator-multiload/daily and try again?

thomas (thomas-heuer) wrote :

Here is the output for the UMTS-stick (ppp0). I can see the up-/down-loaded bytes counting in the console, but still no graph for network load on the indicator. (But network on other adapters is showing fine, e.g. eth0.)

** (indicator-multiload:2083): DEBUG: netprovider.vala:38: Netload: ppp0
** (indicator-multiload:2083): DEBUG: netprovider.vala:39: flags: 23fff
** (indicator-multiload:2083): DEBUG: netprovider.vala:40: if flags: 100e2
** (indicator-multiload:2083): DEBUG: netprovider.vala:41: mtu: 1500
** (indicator-multiload:2083): DEBUG: netprovider.vala:42: subnet: 4294967295
** (indicator-multiload:2083): DEBUG: netprovider.vala:43: address: 2382731530
** (indicator-multiload:2083): DEBUG: netprovider.vala:44: packets in: 57127
** (indicator-multiload:2083): DEBUG: netprovider.vala:45: packets out: 45812
** (indicator-multiload:2083): DEBUG: netprovider.vala:46: packets total: 102939
** (indicator-multiload:2083): DEBUG: netprovider.vala:47: bytes in: 68477086
** (indicator-multiload:2083): DEBUG: netprovider.vala:48: bytes out: 3552868
** (indicator-multiload:2083): DEBUG: netprovider.vala:49: bytes total: 72029954
** (indicator-multiload:2083): DEBUG: netprovider.vala:50: errors in: 0
** (indicator-multiload:2083): DEBUG: netprovider.vala:51: errors out: 0
** (indicator-multiload:2083): DEBUG: netprovider.vala:52: errors total: 0
** (indicator-multiload:2083): DEBUG: netprovider.vala:53: collisions: 0
** (indicator-multiload:2083): DEBUG: netprovider.vala:66: unknown

Michael Hofmann (mh21) on 2011-09-04
Changed in indicator-multiload:
status: Incomplete → Confirmed
Michael Hofmann (mh21) wrote :

Ok, the interface is not used as it is an interface without a device link in sysfs (/sys/class/net/*/device).

This prevents the traffic on vpn connections to show up twice, but also ignores the traffic on the umts stick.

Maybe there is a way to distinguish both, as my real devices link to /sys/devices/pci... and all the virtual ones to /sys/devices/virtual...

Could you attach the output of "ls -lR /sys | gzip > /tmp/sysfs.gz" and "ifconfig"?

Martin Pitt (pitti) wrote :

This is the state with a Huawei E620 USB 3G stick:

$ ifconfig ppp0
ppp0 Link encap:Punkt-zu-Punkt-Verbindung
          inet Adresse:10.249.158.154 P-z-P:10.64.64.64 Maske:255.255.255.255
          UP PUNKTZUPUNKT RUNNING NOARP MULTICAST MTU:1500 Metrik:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:3
          RX bytes:102 (102.0 B) TX bytes:141 (141.0 B)

$ ls -l /sys/class/net/ppp0
lrwxrwxrwx 1 root root 0 2011-09-14 13:49 /sys/class/net/ppp0 -> ../../devices/virtual/net/ppp0

Martin Pitt (pitti) wrote :
Michael Hofmann (mh21) on 2012-01-26
Changed in indicator-multiload:
milestone: 0.3 → none
Matt Jones (workhorsy) wrote :

It looks like the reason this is not working is because it is only checking for devices at /sys/class/net/blah/device.

The problem is that PPP devices(modems, and mobile broadband) will not show up as this type of device. I think the best thing here would be to not check what type of devices it is. But instead to just check if it can do IPV4 or IPV6. This is what Gnome System Monitor does (load-graph.cpp line 558), and it works with PPP devices.

Here is a branch for trunk that fixes this:
http://bazaar.launchpad.net/~workhorsy/+junk/indicator-multiload/revision/63

Matt Jones (workhorsy) wrote :

I've tested my above changes and they work on eth, loopback, wifi, and ppp connections. I have no idea how vpn connections work. So I have no way to tell if this will make the connection show twice as mh21 mentioned. Can someone with a vpn test that please?

And is there any chance of this bug getting fixed in 12.04?

palimmo (palimmo) wrote :

Same problem with LG GT540 used as mobile broadband.

harpreet bhatia (bluepicaso) wrote :

any chances of this being fixed?

Michael Hofmann (mh21) wrote :

Could you check the version at ppa:indicator-multiload/daily and see if that fixes it for you?

Michael Hofmann (mh21) wrote :

Thanks Matt for the patch, I didn't see it before I tried to fix it myself.

I implemented it so that it will now detect point-to-point devices and expose them as net.pup and net.pdown in addition to net.up and net.down. The menu and icons are changed to show $(net.up+net.pup) and $(net.down+net.pdown).

Matt Jones (workhorsy) wrote :

Nice.

I just tried PPA 0.3-0~80~4~18 on 12.04, and it works fine with cellular internet. Hopefully the other users can confirm if it works for them too.

Michael Hofmann (mh21) wrote :

should be available shortly in ppa:indicator-multiload/daily and ppa:indicator-multiload/stable-daily

Changed in indicator-multiload:
status: Confirmed → Fix Released
Ryo Onodera (ryoqun) wrote :

I added ppa:indicator-multiload/stable-daily to my quantal ubuntu. And it fixed this bug. Thank you very much!

Hopefully, I wish this fix would be avaiblable in the official ubuntu archives too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments