Status on messaging indicator is greyed out if Empathy is added to the "Startup Applications" list

Reported by GonzO on 2011-10-18
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Messaging Menu
Medium
Lars Uebernickel
indicator-messages (Ubuntu)
Medium
Unassigned

Bug Description

Like the title says.

I'm on the laptop I use for work, and I always want Empathy to load on startup. So I added it to the list of Startup Applications. Now, when I login, Empathy starts, but indicator-messages displays my status as "offline" and all of the status options are grey. I have to change status in the Empathy app itself in order to make available those options in the messaging indicator.

If I start Empathy via the messaging indicator, I do not have this problem.

It is small, but annoying. I think it is simply a case of Unity loading after Empathy. There used to be a way to prioritize what loaded first in the startup applicaiton pile, but I haven't seen that available in quite a while. I think it'd probably be best to make sure unity loads *first* before anything on that list, but that's a guess on my part.

Omer Akram (om26er) on 2011-12-09
no longer affects: unity
affects: unity (Ubuntu) → telepathy-indicator (Ubuntu)
Bilal Shahid (s9iper1) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Please answer these questions:

* Is this reproducible now?

Changed in telepathy-indicator (Ubuntu):
status: New → Incomplete
Joe Mooring (toomanypets) wrote :

This affects me as well. Running 12.04 (fully up to date) 64bit. Empathy is in my list of startup applications (/usr/bin/empathy -h).

Changed in telepathy-indicator (Ubuntu):
status: Incomplete → New
Joe Mooring (toomanypets) wrote :

See attached screen capture when /usr/bin/empathy -h is called at startup.

Joe Mooring (toomanypets) wrote :

Additional information:
1) The same problem occurs when the startup application is /usr/bin/empathy (no -h hidden switch)
2) If empathy is removed from the list of startup applications, and I start empathy from the indicator, the problem does not occur.
3) If empathy is removed from the list of startup applications, and I start empathy from the dash, the problem does not occur.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Ken VanDine (ken-vandine) wrote :

This would actually be a problem with indicator-messages, I suspect that service doesn't check to see if there are any telepathy accounts already online at startup, it just connects to the service and waits for a signal for changes.

affects: telepathy-indicator (Ubuntu) → indicator-messages (Ubuntu)
Changed in indicator-messages (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Changed in indicator-messages:
status: New → Confirmed
importance: Undecided → Medium
Changed in indicator-messages (Ubuntu):
importance: Wishlist → Medium
Lars Uebernickel (larsu) on 2012-09-04
Changed in indicator-messages:
assignee: nobody → Lars Uebernickel (larsu)
milestone: none → 12.10.3
Lars Uebernickel (larsu) on 2012-09-06
Changed in indicator-messages:
status: Confirmed → Fix Committed
Lars Uebernickel (larsu) on 2012-09-19
Changed in indicator-messages:
status: Fix Committed → Fix Released
Changed in indicator-messages (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers