Messaging menu does not change icon when a new message appears

Bug #1215644 reported by Omer Akram on 2013-08-22
64
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Messaging Menu
Fix Released
Undecided
Lars Karlitski
indicator-messages (Ubuntu)
High
Lars Karlitski
Saucy
High
Lars Karlitski
unity8 (Ubuntu)
High
Nick Dedekind
Saucy
High
Nick Dedekind

Bug Description

I just pulled indicator-messages from trunk (bzr360) and installed it on the phone and rebooted. Now when a new message appears, I get the OSD notification and when I open the messaging menu there is indeed a pending sms there but The color of the messaging menu did not change. See the attached screenshot.

Related branches

Omer Akram (om26er) wrote :
Lars Karlitski (larsu) wrote :

This is really a bug in telephony-service, which didn't call messaging_menu_message_set_draws_attention(). We probably didn't notice this bug before because chewie-client turned the messaging menu icon blue by itself.

However, I'm attaching a fix for libmessaging-menu anyway: "draws-attention" should really default to TRUE. The phone app doesn't need any updates.

no longer affects: ubuntu
Changed in indicator-messages:
status: New → In Progress
Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Changed in indicator-messages:
assignee: nobody → Lars Uebernickel (larsu)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-messages at revision 372, scheduled for release in indicator-messages, milestone 13.10.0

Changed in indicator-messages:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 13.10.1+13.10.20130830.2-0ubuntu1

---------------
indicator-messages (13.10.1+13.10.20130830.2-0ubuntu1) saucy; urgency=low

  [ Lars Uebernickel ]
  * libmessaging-menu: default MessagingMenuMessage::draws-attention to
    TRUE In most cases, apps will want to draw the user's attention when
    they add a message to the menu. (LP: #1215644)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 372
 -- Ubuntu daily release <email address hidden> Fri, 30 Aug 2013 10:07:39 +0000

Changed in indicator-messages (Ubuntu):
status: Confirmed → Fix Released
Lars Karlitski (larsu) wrote :

Note: the right icon probably still doesn't show up on the phone until lp:~nick-dedekind/unity8/unitymenumodel.messages lands. indicator-messages uses a new way of serializing GIcons that the current unity8 doesn't understand.

Lars Karlitski (larsu) on 2013-09-10
Changed in indicator-messages:
status: Fix Committed → Fix Released
Jamie Strandboge (jdstrand) wrote :

This bug says it the issue is fixed in 13.10.1+13.10.20130830.2-0ubuntu1, but I have 13.10.1+13.10.20130903-0ubuntu1 installed and it is not fixed. There is a comment about unity8 needing to also be fixed. Adding unity8 task.

Changed in unity8 (Ubuntu Saucy):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2013-09-18
Changed in unity8 (Ubuntu Saucy):
assignee: nobody → Nick Dedekind (nick-dedekind)
tags: added: avengers qa-touch
Nick Dedekind (nick-dedekind) wrote :

unity8 fix has been released, but I think there's still an issue in indicator-messages.

Changed in unity8 (Ubuntu Saucy):
status: Confirmed → Fix Released
Bill Filler (bfiller) wrote :

This is still an issue with image 89
unity8: 7.82+13.10.20131007-0ubuntu1
indicator-messages: 13.10.1+13.10.20131004-0ubuntu1

To reproduce:
- send text message to the phone
- the message indicator does not turn blue, yet the message is there

Changed in unity8 (Ubuntu Saucy):
status: Fix Released → Confirmed
Changed in indicator-messages (Ubuntu Saucy):
status: Fix Released → Confirmed
importance: Undecided → High
Bill Filler (bfiller) on 2013-10-09
Changed in indicator-messages (Ubuntu Saucy):
assignee: nobody → Lars Uebernickel (larsu)
Nick Dedekind (nick-dedekind) wrote :

I looked into this a bit last week.

There seems to be a bug somewhere between the indicator clearing/adding a message and the registered application (eg. message app) telling us that it wants to draw attention (blue icon).
I've told larsu about it.

Lars Karlitski (larsu) on 2013-10-16
Changed in indicator-messages (Ubuntu Saucy):
status: Confirmed → Fix Released

It works on Utopic #87, closing.

Changed in unity8 (Ubuntu):
status: Confirmed → Fix Released
Changed in unity8 (Ubuntu Saucy):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers