No separators in Messaging Menu

Bug #1048245 reported by Ian Higginson on 2012-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Messaging Menu
Fix Released
High
Lars Karlitski
indicator-messages (Ubuntu)
Undecided
Unassigned

Bug Description

I'm currently running Ubuntu 12.10 (Beta 1) and I've noticed that the Messaging Menu is missing the separators it used to have, which makes it look out-of-place compared to the other menus. I'm not a UI design expert but I would think that they would be needed between the online statuses (Available, Busy, etc.) and applications, and between the applications and the 'Clear' option.

Upon viewing previous versions of the menu, they also seemed to appear between the different applications, too.

Related branches

Ian Higginson (xeriouxi) on 2012-09-09
description: updated
description: updated
Lars Karlitski (larsu) wrote :

You're right, the messaging menu should definitely show separators again (in exactly the positions you described).

This regression happened because we've changed the way the menu is created. A fix in the messaging menu depends on a patch to gtk [1], but we're not entirely sure that's the approach we want to take.

Thanks for taking the time to report this.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=682831

Changed in indicator-messages:
assignee: nobody → Lars Uebernickel (larsu)
status: New → In Progress
milestone: none → 12.10.3
importance: Undecided → High
Lars Karlitski (larsu) on 2012-09-18
Changed in indicator-messages:
status: In Progress → Fix Committed
Lars Karlitski (larsu) on 2012-09-19
Changed in indicator-messages:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 12.10.3-0ubuntu1

---------------
indicator-messages (12.10.3-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - hide indicator when no application shows in the menu (lp: #661059)
    - remove apps as soon as they are uninstalled (lp: #864545)
    - make generated .gir compatible with vala (lp: #104496)
    - draw counts as lozenges (lp: #1046331)
    - show separators (lp: #1048245)
    - show chat presence in the panel (lp: #859905)
    - improve documentation
  * debian/control:
    - build-dep on latest libgtk-3-dev
 -- Didier Roche <email address hidden> Wed, 19 Sep 2012 10:23:43 +0200

Changed in indicator-messages (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.