links to non-existent Location settings causes crash

Bug #1234975 reported by Jamie Strandboge on 2013-10-03
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Indicator Location
Fix Released
Critical
Charles Kerr
13.10
Fix Released
Critical
Charles Kerr
indicator-location (Ubuntu)
Critical
Unassigned

Bug Description

Open the location-indicator-- it says 'Location settings'. Pressing it does nothing -- there is a flash but then back to whatever you were looking at. Seems this is because there is no location settings in System Settings?

$ adb shell system-image-cli -i
current build number: 78
device name: mako
channel: stable
last update: 2013-10-03 13:05:32
version version: 78
version ubuntu: 20131003
version device: 20131002.1

Related branches

Charles Kerr (charlesk) on 2013-10-04
Changed in indicator-location:
status: New → Confirmed
tags: added: qa-touch rls-s-incoming
Allan LeSage (allanlesage) wrote :

Actually this has the effect of crashing ubuntu-system-settings, and a second actuation crashes unity8, so I'm upping importance.

Changed in indicator-location:
importance: Undecided → High
no longer affects: ubuntu
Julien Funk (jaboing) on 2013-10-08
summary: - links to non-existent Location settings
+ links to non-existent Location settings causes crash
Allan LeSage (allanlesage) wrote :

Upping the importance to critical b/c crasher!

Note that this occurs both under mir and under surfaceflinger, I'll attach a crashfile from the mir occurrence here.

Allan LeSage (allanlesage) wrote :
Julien Funk (jaboing) wrote :

Note that similar behaviour is exhibited in Surfaceflinger, however in Mir it is much more severe.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-location at revision 51, scheduled for release in indicator-location, milestone Unknown

Changed in indicator-location:
status: In Progress → Fix Committed
Changed in indicator-location (Ubuntu):
status: New → Confirmed
Allan LeSage (allanlesage) wrote :

Forgive the superfluous data, just trying to get this off our internal tracker.

Changed in indicator-location (Ubuntu):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-location - 13.10.0+13.10.20131011-0ubuntu1

---------------
indicator-location (13.10.0+13.10.20131011-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * Since the "Location Settings" panel is disabled in system-settings
    for 13.10, hide the indicator's menuitem that activates that panel.
    (LP: #1234975)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 51
 -- Ubuntu daily release <email address hidden> Fri, 11 Oct 2013 04:26:58 +0000

Changed in indicator-location (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers