Move Title to Backend

Bug #1223635 reported by Ted Gould on 2013-09-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bluetooth Menu
Fix Released
High
Charles Kerr
Indicator Date and Time
Fix Released
High
Charles Kerr
Indicator Location
Fix Released
High
Ted Gould
Messaging Menu
Fix Released
High
Lars Karlitski
Network Menu
Fix Released
High
Ted Gould
The Sevilerow project
Undecided
Unassigned
The Sound Menu
Fix Released
High
Lars Karlitski
indicator-power
Fix Released
High
Charles Kerr
indicator-bluetooth (Ubuntu)
Undecided
Unassigned
indicator-datetime (Ubuntu)
Undecided
Unassigned
indicator-location (Ubuntu)
Undecided
Unassigned
indicator-messages (Ubuntu)
Undecided
Unassigned
indicator-network (Ubuntu)
Undecided
Unassigned
indicator-power (Ubuntu)
Undecided
Unassigned
indicator-sound (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
High
Nick Dedekind

Bug Description

We should have the titles in the root action state for the indicators.

Related branches

Ted Gould (ted) wrote :
Changed in unity8:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in indicator-network:
assignee: nobody → Ted Gould (ted)
Changed in indicator-messages:
assignee: nobody → Lars Uebernickel (larsu)
Changed in indicator-datetime:
assignee: nobody → Charles Kerr (charlesk)
Changed in indicator-bluetooth:
assignee: nobody → Charles Kerr (charlesk)
Changed in indicator-location:
assignee: nobody → Ted Gould (ted)
Changed in indicator-bluetooth:
status: New → Confirmed
Changed in indicator-datetime:
status: New → Confirmed
Changed in indicator-location:
status: New → Confirmed
Changed in indicator-messages:
status: New → Confirmed
Changed in indicator-network:
status: New → Confirmed
Changed in unity8:
status: New → Confirmed
Changed in indicator-bluetooth:
importance: Undecided → High
Changed in indicator-location:
importance: Undecided → High
Changed in indicator-datetime:
importance: Undecided → High
Changed in unity8:
importance: Undecided → High
Changed in indicator-network:
importance: Undecided → High
Changed in indicator-messages:
importance: Undecided → High
Ted Gould (ted) on 2013-09-11
Changed in indicator-network:
status: Confirmed → In Progress
Ted Gould (ted) on 2013-09-11
Changed in indicator-location:
status: Confirmed → In Progress
Changed in indicator-sound:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Lars Uebernickel (larsu)
Charles Kerr (charlesk) on 2013-09-11
Changed in indicator-bluetooth:
status: Confirmed → In Progress
Changed in indicator-datetime:
status: Confirmed → In Progress
Charles Kerr (charlesk) on 2013-09-11
Changed in indicator-power:
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-location at revision 44, scheduled for release in indicator-location, milestone Unknown

Changed in indicator-location:
status: In Progress → Fix Committed
Changed in indicator-network:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-network at revision 281, scheduled for release in indicator-network, milestone Unknown

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-bluetooth at revision 58, scheduled for release in indicator-bluetooth, milestone Unknown

Changed in indicator-bluetooth:
status: In Progress → Fix Committed
Changed in indicator-power:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-power at revision 196, scheduled for release in indicator-power, milestone Unknown

Changed in indicator-datetime:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-datetime at revision 256, scheduled for release in indicator-datetime, milestone Unknown

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-messages at revision 378, scheduled for release in indicator-messages, milestone 13.10.0

Changed in indicator-messages:
status: Confirmed → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-sound at revision 375, scheduled for release in indicator-sound, milestone Unknown

Changed in indicator-sound:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-bluetooth - 0.0.6+13.10.20130913-0ubuntu1

---------------
indicator-bluetooth (0.0.6+13.10.20130913-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * Adds a title in the header's action state. (LP: #1223635)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 58
 -- Ubuntu daily release <email address hidden> Fri, 13 Sep 2013 15:15:49 +0000

Changed in indicator-bluetooth (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+13.10.20130913-0ubuntu1

---------------
indicator-datetime (13.10.0+13.10.20130913-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * Make the EDS planner nonblocking. (LP: #1204532)
  * Minor changes that eliminate unnecessary temporary strings.
  * This change adds a GSettings* arg to the utils functions so that
    they don't have to churn through temporary GSettings objects. These
    functions are usually called in a loop, causing a lot of GSettings
    temporaries, even though the calling code already has an instance
    for that GSettings schema.
  * name says it all; this branch is for improving indicator-datetime
    test coverage.
  * Remove code duplication between timezone-file and timezone-geoclue.
  * Adds a title in the header's action state. (LP: #1223635)

  [ Ted Gould ]
  * Fix GeoClue signal handler to have proper prototype. (LP: #1195874)
  * Protect against invalid begin or end dates. (LP: #1216263)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 256
 -- Ubuntu daily release <email address hidden> Fri, 13 Sep 2013 15:16:38 +0000

Changed in indicator-datetime (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-location - 13.10.0+13.10.20130913-0ubuntu1

---------------
indicator-location (13.10.0+13.10.20130913-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * Add a title to the root action state. (LP: #1223635)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 44
 -- Ubuntu daily release <email address hidden> Fri, 13 Sep 2013 15:15:27 +0000

Changed in indicator-location (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 13.10.1+13.10.20130913-0ubuntu1

---------------
indicator-messages (13.10.1+13.10.20130913-0ubuntu1) saucy; urgency=low

  [ Lars Uebernickel ]
  * Install into /usr/lib/$arch, to be consistent with the other
    indicators.
  * Use g_icon_serialize() instead of g_icon_to_string().
  * Add "title" to the root action state dictionary. (LP: #1223635)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 378
 -- Ubuntu daily release <email address hidden> Fri, 13 Sep 2013 15:15:38 +0000

Changed in indicator-messages (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-network - 0.5.0+13.10.20130913-0ubuntu1

---------------
indicator-network (0.5.0+13.10.20130913-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * Adding in temporary gsm icons as well.
  * Adding title to the base action state. (LP: #1223635)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 281
 -- Ubuntu daily release <email address hidden> Fri, 13 Sep 2013 15:16:35 +0000

Changed in indicator-network (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+13.10.20130913-0ubuntu1

---------------
indicator-power (12.10.6+13.10.20130913-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * Adds a title in the header's action state. (LP: #1223635)

  [ Ted Gould ]
  * Use URL Dispatcher for settings on the phone.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 196
 -- Ubuntu daily release <email address hidden> Fri, 13 Sep 2013 15:15:31 +0000

Changed in indicator-power (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+13.10.20130913-0ubuntu1

---------------
indicator-sound (12.10.2+13.10.20130913-0ubuntu1) saucy; urgency=low

  [ Lars Uebernickel ]
  * Fixes bug #1221242 and #1204036 (make scrolling and middle clicking
    work on the sound indicator) It soft-depends on
    lp:~larsu/libindicator/ng-add-scrolling. That means, this branch can
    be merged without problems, as it only adds an action and a few
    attributes on the root item. The bugs won't be fixed until both
    branches land, though. Please the other merge request for a
    description of the new attributes. (LP: #1221242, #1204036)
  * Update POTFILES.in and mark remaining strings as translatable. (LP:
    #1223500)
  * Add "title" to the root action state dictionary . (LP: #1223635)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 375
 -- Ubuntu daily release <email address hidden> Fri, 13 Sep 2013 15:16:35 +0000

Changed in indicator-sound (Ubuntu):
status: New → Fix Released
Ted Gould (ted) on 2013-09-15
Changed in indicator-bluetooth:
status: Fix Committed → Fix Released
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Changed in indicator-location:
status: Fix Committed → Fix Released
Changed in indicator-messages:
status: Fix Committed → Fix Released
Changed in indicator-network:
status: Fix Committed → Fix Released
Changed in indicator-sound:
status: Fix Committed → Fix Released
Changed in indicator-power:
status: Fix Committed → Fix Released
Changed in unity8:
status: Confirmed → In Progress
Michał Sawicz (saviq) on 2013-09-19
Changed in unity8:
milestone: none → ubuntu-13.09
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision 378, scheduled for release in unity8, milestone ubuntu-13.09

Changed in unity8:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package unity8 - 7.82+13.10.20131004.1-0ubuntu1

---------------
unity8 (7.82+13.10.20131004.1-0ubuntu1) saucy; urgency=low

  [ Michał Sawicz ]
  * Bump to indicate support for extended snap decisions.
  * Make Tile themeable, add renderers for Dash Plugins and weather.
    (LP: #1231948)
  * Drop network agents now that they're in indicator-network instead.

  [ Michal Hruby ]
  * Differentiate generic and music carousels.
  * Use the thumbnailer image provider for scope results that don't
    specify icon as well as for previews.
  * Added an indicator which is displayed in the search bar whenever a
    search is in progress. Added accompanying test in tst_PageHeader.
  * Expose rendererHint to shell.

  [ Albert Astals ]
  * Update pot file. (LP: #1232374)
  * Only enable the animation when the item is on screen (i.e. !culled)
    . (LP: #1200374)
  * Do not crash on positionAtBeginning if the list is empty .
  * Enable/disable running apps height animation in a less error prone
    way.

  [ Michael Terry ]
  * Use a chevron after 'Skip intro' and drop the underlining.
  * Load testability driver when QT_LOAD_TESTABILITY is set. (LP:
    #1226234)
  * Listen to the system setting StatsWelcomeScreen, which tells us
    whether to show user-specific infographic data in the greeter. (LP:
    #1207857)

  [ Gerry Boland ]
  * WM: ensure focusedApplicationWhenUsingScreenshots reset when unused,
    and only used when set. Fixes window focus conflict between shell
    and ApplicationManager.

  [ Nick Dedekind ]
  * Removed deprecated Unity.IndicatorsLegacy plugin.
  * Added actionState parser to the indicators-client text printer so
    that we get the icon.
  * Moved indicator page titles to the root action state of menu model.
    (LP: #1223635)

  [ Mirco Müller ]
  * Added rendering- and interaction-support for the first three
    extended snap-decision dialog-cases password-entry, user-
    authentication and simunlock.

  [ Daniel d'Andrada ]
  * Revert the reversion of r304 since it doesn't seem to crash anymore
    Original commit was Reset apps scope when returning from app to dash
    (LP #1193419) If an app is on foreground and you perform a long
    left-edge swipe to minimize it, and therefore return to the dash,
    the dash should be in the Applications scope and showing the
    running/recents applications. (LP: #1193419)

  [ Andrea Cimitan ]
  * Add behaviours to the hud reveal. (LP: #1224480, #1224633)
  * Make Tile themeable, add renderers for Dash Plugins and weather.
    (LP: #1231948)

  [ Michael Zanetti ]
  * fix inserting into quicklistmodel.
  * Drop useStorage argument and use exising LAUNCHER_TESTING define for
    this decision.

  [ Omer Akram ]
  * Make the volume/brightness slider changes realtime. (LP: #1227595)

  [ Nicolas d'Offay ]
  * Fixed black colour on the first of the month due to division. (LP:
    #1233657)
  * Added an indicator which is displayed in the search bar whenever a
    search is in progress. Added accompanying test in tst_PageHeader.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 390
 -- Ubuntu daily release <email address hidden> ...

Read more...

Changed in unity8 (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq) on 2013-10-05
Changed in unity8:
status: Fix Committed → Fix Released
tags: added: has-test
Chris Wayne (cwayne18) on 2013-11-29
Changed in sevilerow:
status: New → Fix Released
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
importance: Undecided → High
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers