icon & preferences gone

Bug #1780525 reported by Garry Trethewey on 2018-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
indicator-keylock
Undecided
Unassigned

Bug Description

Hi Thea

I guess this isn't a bug, but I can't find a solution and I suspect other people will have the same question.

xubuntu 18.04

The 10 second notification comes & goes appropriately with caps-lock on or off.

But the permanent icon that lives in indicator plugin or the status notifier plugin (can't remember which) didn't change from black to grey as it should.
I fiddled with 'preferences', and after IIRC unticking the top left box, the icon has gone.
The only way I know to re-activate the icon is via 'preferences' which I can't access because the icon isn't there.
garry@piano:~$ indicator-keylock --help-all
doesn't give me any useful option.

I've uninstalled it a couple of times, deleted config files, can't see anything else to do.

Any ideas?

regards Garry

Garry Trethewey (garrytreth) wrote :

Well that's funny. After a couple of weeks, and dozens of boots, I've suddenly got the icon back in the status notifier plugin. So I can click Preferences.

The icon still doesn't go grey / black with capslock on / off, but a reasonable workaround is unticking Show indicator while capslock is inactive. That lets the icon appear / disappear appropriately.

So I guess, Solved, kind of.

Either way, thanks for this neat little utility.

Elizabeth Thompson (caltrop-3) wrote :

I ran the program and the notification works.

But should there be an icon in the notification panel?

Icon finally showed up but...
Can only do one keylock.
It is either CAP, NUM, or SCR.
All three should be indicated.

kernel: Linux
release: 4.13.0-45-generic
version: #50~16.04.1-Ubuntu SMP Wed May 30 11:18:27 UTC 2018
distribution: Linux Mint 18.2 Sonya
desktop: MATE Desktop Environment 1.18.0
Architecture: x86_64

ldmpub (ldmpub) wrote :

Hi,

I'm running Xubuntu 18.04 => notification bubbles are ok (with notifyd) but I haven't any icon displayed in notification panel to permanently indicate current keyboard keys status.

Can someone tell me how it should work or direct me to a more appropriate place to ask (like a dedicated forum?).

Thanks,

I had the same problem. A workaround is to install dconf-editor (sudo apt install dconf-tools), and navigate to app/indicators/keylock to change the options.

soab (soabmfs) wrote :

This program is odd. I removed the alert icon from taskbar and can no longer get into settings to put it back on. When I tried uninstalling and reinstalling there was no change. In fact its even stranger. I completely removed the program and even tried purging it but it is always there. It always notifies me if something is pressed whether the program is there or not??! I tried the above suggestion of changing the settings in dconf, but it seems to totally ignore that too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers