indicator-keylock should not use deprecated libunique3

Bug #1701940 reported by Jeremy Bicha on 2017-07-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-keylock
Undecided
Unassigned
indicator-keylock (Ubuntu)
High
Unassigned

Bug Description

libunique3 will soon be removed from Debian and Ubuntu 17.10. If indicator-keylock still depends on libunique3 at that time, indicator-keylock will be removed from Ubuntu.

The libunique3 library is in maintenance mode and its usage is strongly
discouraged [1].

Applications should use the GtkApplication class provided by GTK+ 3.0. Under
[2] you will find a porting guide for migrating from using Unique to
GApplication or GtkApplication.

[1] https://wiki.gnome.org/Attic/LibUnique
[2] https://developer.gnome.org/gtk3/3.20/gtk-migrating-unique-GtkApplication.html

Jeremy Bicha (jbicha) on 2017-07-02
Changed in indicator-keylock (Ubuntu):
importance: Undecided → High
Jeremy Bicha (jbicha) on 2017-08-11
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-keylock (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers