The Date and Time Indicator

Calendar days should not be clickable when no calendar app is installed

Reported by Matthew Paul Thomas on 2011-12-18
64
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Indicator Date and Time
Low
Unassigned
indicator-datetime (Ubuntu)
Low
Unassigned

Bug Description

indicator-datetime 0.3.1-0ubuntu1, Ubuntu 11.10

When Evolution is not installed (as it isn't by default), the dates in the clock menu's calendar do nothing, but highlight as if they are clickable.

<https://wiki.ubuntu.com/TimeAndDate#settings>: The “Coming events from” menu should default to “Evolution” if it is installed, otherwise “Lightning” if it is installed, otherwise “Subscribed Calendars”.

<https://wiki.ubuntu.com/TimeAndDate#menu-calendar>: "The dates shown in the calendar should behave, and look, as normal grid-layout menu items. Each date should be sensitive only if it is in the current month and the calendar application selected (if any) in settings is installed. Activating an item should open that date in the calendar application."

[Originally reported as part of <https://blueprints.launchpad.net/ubuntu/+spec/ps-p-indicator-refinements>.]

description: updated
Changed in indicator-datetime:
importance: Undecided → High
Matthew Paul Thomas (mpt) wrote :

I've reviewed the specification here and left it as it is. When Evolution is not installed, the monthly calendar should still be present (dependent on the checkbox in Time & Date settings), but should be insensitive.

description: updated
Changed in indicator-datetime:
status: New → Triaged
assignee: Matthew Paul Thomas (mpt) → nobody
Hunter VanHorn (guitarhunter92) wrote :

I think it would be nice if the applet would show events from other calendars. Maybe ship Thunderbird (which is already default) with Lightning already installed, and let the indicator read Lightning events? From what I understand, it is currently hard-coded to only use evolution-data-server. A couple more choices in what the indicator could read, and problem solved. Of course, that takes a lot more work. Had I more experience with such things, I would help, but alas, that is not the case. Just my 2 cents.

Charles Kerr (charlesk) wrote :

GtkCalendar doesn't have a mechanism for making individual days unclickable. We can set the entire widget to be insensitive, which allows month/year navigation but makes all the days unclickable. We could use this when evolution isn't available and/or when the user doesn't have the current month selected.

Please make it work with Thunderbird/Lightning as mentioned in post #2!

Charles Kerr (charlesk) wrote :

Hunter and Alexander, thanks for this suggestion, but it belongs in its own ticket where it can be handled separately from this bug. This bug is about what the indicators should do when $SUPPORTED_MUA isn't installed, not what the value of $SUPPORTED_MUA should be. Thanks!

Charles Kerr (charlesk) on 2012-03-26
Changed in indicator-datetime:
assignee: nobody → Charles Kerr (charlesk)
status: Triaged → In Progress
Charles Kerr (charlesk) wrote :

My notes in comment #3 were just plain wrong, you can't continue to navigate a GtkCalendar widget when it's insenstive.

There doesn't appear to be any way to achieve this with a stock GtkCalendar -- let's defer this until after 12.04.

Changed in indicator-datetime:
status: In Progress → Triaged
tags: added: backlog
Charles Kerr (charlesk) wrote :

Adding Ayatana-Design to make sure everyone's aware of the previous comment

John Lea (johnlea) wrote :

Hi MPT, could you take a look at this bug, thx!

Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Incomplete
Changed in ayatana-design:
status: Incomplete → New
description: updated
Changed in ayatana-design:
status: New → Fix Committed
Charles Kerr (charlesk) on 2012-10-04
Changed in indicator-datetime:
status: Triaged → Fix Released
milestone: none → 12.10.2
milestone: 12.10.2 → none
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Changed in ayatana-design:
assignee: Matthew Paul Thomas (mpt) → nobody
Ted Gould (ted) wrote :

Clearly this isn't "high" as it hasn't been worked on.

Changed in indicator-datetime:
importance: High → Low
Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
Charles Kerr (charlesk) on 2014-03-07
summary: - Calendar does nothing useful when Evolution isn't installed
+ Calendar days should not be clickable when no calendar app is installed
Charles Kerr (charlesk) on 2014-03-13
Changed in indicator-datetime:
assignee: Charles Kerr (charlesk) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers