Use GnomeWallClock api to implement wall clocks

Bug #837440 reported by Javier Jardón on 2011-08-30
114
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Invalid
Low
Javier Jardón
Unity Foundations
Low
Javier Jardón

Bug Description

See https://bugzilla.gnome.org/show_bug.cgi?id=655129 for details.

This will solve 2 problems:

- Update without delays the date when changing it manually
- Update without delays the date after suspend/resume cycles

As we do not depend on hardcoded timers to update the displayed date

Related branches

Javier Jardón (jjardon) on 2011-08-30
description: updated
Javier Jardón (jjardon) on 2011-08-31
Changed in indicator-datetime:
status: New → In Progress
Ted Gould (ted) on 2011-08-31
Changed in indicator-datetime:
assignee: nobody → Javier Jardón (jjardon)
importance: Undecided → Low
Changed in unity-foundations:
importance: Undecided → Low
status: New → In Progress
assignee: nobody → Javier Jardón (jjardon)
milestone: none → oneiric-beta-2
Javier Jardón (jjardon) wrote :

Ok, seems the new api was removed from glib and moved to gnome-desktop instead.
I will update the branch to use the new class

summary: - Use new Glib api to implement wall clocks
+ Use GnomeWallClock api to implement wall clocks
Ted Gould (ted) on 2011-09-15
Changed in indicator-datetime:
status: In Progress → Fix Committed
Changed in unity-foundations:
status: In Progress → Fix Committed
Changed in indicator-datetime:
milestone: none → 0.2.94
Ted Gould (ted) on 2011-09-15
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Javier Jardón (jjardon) on 2011-09-16
Changed in indicator-datetime:
status: Fix Released → In Progress
Michael Nelson (michael.nelson) wrote :

I would have attached this to bug 750992, but it's listed as a dupe of this one. Anyway, fwiw, I'm seeing the incorrect date, as per the attached screenshot, on an up-to-date oneiric.

Marius B. Kotsbak (mariusko) wrote :

Michael: the bug seems to have status "In Progress" so it is not supposed to be fixed yet.

Marius B. Kotsbak (mariusko) wrote :

Still there in the latest updates to Precise.

tags: added: precise
Gao Shichao (xgdgsc) wrote :

Still bug in 13.10, are you planning to keep it in 14.04?

Charles Kerr (charlesk) wrote :

If anyone's still seeing delays in updates after changing the date or after suspend/resume cycles, please report it in another ticket. The 14.04 code seems to be handling these cases correctly already, such as listening for these things already (such as watching org.freedesktop.login1.Manager for sleep notification, so I'm not sure I see the point of adding a new dependency to the code.

Closing this ticket as Invalid, no plans to move to GnomeWallClock for now.

I've heard talk of a GWallClock, and if that comes around in glib I'd likely want to use that.

Changed in indicator-datetime:
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments