Timezones not in time order

Bug #833325 reported by James Haigh on 2011-08-24
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
Matthew Paul Thomas
Indicator Date and Time
Fix Released
Medium
Charles Kerr
indicator-datetime (Ubuntu)
Medium
Unassigned

Bug Description

They used to be but not anymore.

Related branches

James Haigh (james.r.haigh) wrote :
James Haigh (james.r.haigh) wrote :

Subtask of bug #823181.

tags: added: regression-release
Ted Gould (ted) on 2011-08-31
Changed in indicator-datetime:
status: New → Confirmed
importance: Undecided → Medium
Javier Jardón (jjardon) on 2011-10-05
Changed in indicator-datetime:
status: Confirmed → In Progress
Charles Kerr (charlesk) wrote :

James, just to make sure I'm understanding this ticket correctly -- you're referring to the order of the times shown inbetween "Add Event..." and "Time & Date Settings..." in your screenshot, is that correct?

Charles Kerr (charlesk) on 2012-02-16
Changed in indicator-datetime:
status: In Progress → Incomplete
Raphaël Badin (rvb) wrote :

Same pb here (Precise), I think James was indeed referring to the order of the times shown inbetween "Add Event..." and "Time & Date Settings...".

It is:
- UTC 19:54
- Paris 21:54
- London 20:54

and it should be (and it used to be):
- UTC 19:54
- London 20:54
- Paris 21:54

Charles Kerr (charlesk) on 2012-03-02
Changed in indicator-datetime:
status: Incomplete → In Progress
Charles Kerr (charlesk) on 2012-03-03
Changed in indicator-datetime:
status: In Progress → Fix Committed
Olli Ries (ories) on 2012-03-05
Changed in ayatana-design:
status: New → Incomplete
Matthew Paul Thomas (mpt) wrote :

The design is not Incomplete; it has been specified since July 2010. "The order of locations in the menu should always match the order of locations in the window ... Clicking the “Location” header cell should sort the locations alphabetically, and clicking it again should sort them reverse alphabetically. Clicking the “Time” header cell should sort the locations earliest first, and clicking it again should sort them latest first." <https://wiki.ubuntu.com/TimeAndDate#locations>

The first part works in indicator-datetime 0.3.90-0ubuntu1: the menu updates live to match whatever order you specify in the window. If the "/* sort the list by timezone offset */" code changes this, that's a regression. Sorting by timezone offset should happen only if you click the "Time" column header, which in 0.3.90-0ubuntu1 does nothing.

Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
status: Incomplete → Invalid
Charles Kerr (charlesk) wrote :

mpt: I think it was marked as incomplete this ticket is about sorting the locations inbetween "Add Event..." and "Time & Date Settings..." in the menu, not about the Locations window.

The design currently says the locations should be listed, but doesn't address order: "Whenever “Time in other locations” is checked, the times in the chosen locations should be present in the menu. Activating any of these items should change the time zone to that location (with the authorization dialog acting as a confirmation step). " <https://wiki.ubuntu.com/TimeAndDate#The_menu>

Changed in ayatana-design:
status: Invalid → Incomplete
Charles Kerr (charlesk) wrote :

Ah, I read through comment #6 too quickly.

Matthew Paul Thomas (mpt) wrote :

Following our discussion Tuesday and yesterday, I've updated the specification to include "Sort by Name" and "Sort by Time" buttons in the "Locations" window. <https://wiki.ubuntu.com/TimeAndDate?action=diff&rev2=41&rev1=40>

Changed in ayatana-design:
status: Incomplete → Triaged
Ted Gould (ted) on 2012-03-08
Changed in indicator-datetime:
milestone: none → 0.3.91
status: Fix Committed → Fix Released
Charles Kerr (charlesk) wrote :

Re-opening as per the refined spec

Changed in indicator-datetime:
assignee: nobody → charles (charlesk)
status: Fix Released → Triaged
Olli Ries (ories) wrote :

MPT, re comment #6, I meant to express that we'd need some input from Design - seems we have everything needed. Charles will attach a screenshot for design review.

John Lea (johnlea) on 2012-04-12
tags: added: udp
Changed in ayatana-design:
importance: Undecided → Medium
Matthew Paul Thomas (mpt) wrote :

Charles, that looks pretty good, thank you. Just two minor glitches:
(1) There should be as much padding to the left of the "+" button as there is above and below it.
(2) When sorted by time, Budapest should go before Paris, because they're the same time but Budapest is alphabetically earlier. I've added this to the spec. <https://wiki.ubuntu.com/TimeAndDate?action=diff&rev2=47&rev1=46>

Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in indicator-datetime (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Charles Kerr (charlesk) on 2012-09-20
Changed in indicator-datetime:
status: Triaged → Fix Released
Charles Kerr (charlesk) on 2012-10-05
Changed in indicator-datetime (Ubuntu):
status: Triaged → Fix Released
Matthew Paul Thomas (mpt) wrote :

Tested with indicator-datetime 12.10.2-0ubuntu1 in Ubuntu Q. This all seems to be working now.

Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-10-09
tags: removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints