Menu is too narrow with calendar hidden

Bug #762976 reported by Dylan McCall on 2011-04-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Undecided
Unassigned
indicator-datetime (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: indicator-datetime

With a recent update, the menu items for events in indicator-datetime have been changed so they don't force the menu to grow in width. This works with the calendar widget visible, because it is wide enough to reserve a comfortable amount of space for the events.

With the calendar disabled, the width of the menu seems to depend on something else. The result is there are about six characters visible for each event's description, which is simply not enough to be useful. Either the events or the menu itself should reserve a minimum width separate from the calendar.

Related branches

Rohit R (rr0hit) wrote :

reproduced in Ubuntu 11.04 beta 2.

The width of menu when calender is disabled should remain the same as when it is enabled.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Karl Lattimer (karl-qdh) wrote :

ah, this is caused by a one line fix for items with too large a width...

I think I need to set a minimum width on the appointment items.

Karl Lattimer (karl-qdh) on 2011-04-18
Changed in indicator-datetime (Ubuntu):
status: Confirmed → In Progress
Ted Gould (ted) on 2011-04-18
Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in indicator-datetime:
status: New → Fix Committed
milestone: none → 0.2.4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.2.3-0ubuntu3

---------------
indicator-datetime (0.2.3-0ubuntu3) natty; urgency=low

  * debian/patches/lp_762976.patch
    - Set minimum width for appointments to prevent continuous resizing
      when the calendar is hiden and ensure there is enough of the
      event description visible (LP: #762976)
 -- Ken VanDine <email address hidden> Mon, 18 Apr 2011 10:05:41 -0400

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
Ted Gould (ted) on 2011-08-31
Changed in indicator-datetime:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers