inicator-datetime dosen't show corretly the time when changing from 24 hours format to 12 hours

Bug #743394 reported by Jorge Luis Ramírez Orozco on 2011-03-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Undecided
Unassigned
indicator-datetime (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: indicator-datetime

When changing from the 24 hours format to the 12 hours format the indicator doesn't show the time correctly if the option "show seconds" isn't enabled. It still shows the time in 24 hours format until I enable the "show seconds" option.

Related branches

This is the screen shot with the 12 hours format without the "show seconds" option enabled.

This is the screen shot with the 12 hours format and the option "show seconds" enabled

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * What version of Ubuntu and indicator-datetime do you use?
 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Karl Lattimer (karl-qdh) wrote :

Will it change after the minute turns? I'm assuming it will and investigating the bug from there.

Karl Lattimer (karl-qdh) wrote :

I'm trying to reproduce this bug but can't seem to, however I have found a strange inconsistency in the switch statement used, I will try and remove the inconsistency and push. Maybe that will help.

Karl Lattimer (karl-qdh) wrote :

The switch inconsistency is as a result of this wonderful bug...

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=37231

Will fix it by making it consistently use braces for the cases

Ubuntu version --> Natty Alpha 3
indicator-weather version --> 11.03.20+repack-0ubuntu2

For me it happens every time that I change the hour format. I will make a video and upload it to show what happens with clarity.

The thing that I do for it to happen is change the hour format from 24 hours format to 12 hours format. It doesn't change after minutes, it stays in the 24 hours format, even after booting and login in and with the 12 hours format it will continue to show the time with the 24 hours format.

In this video is recorded what I reported in the bug. My local configuration is Spanish but is really is to understand, but if you want I'll do it in English too, just tell me.

If there something that I can do to help, please tell, I grateful to be able to help

Sebastien Bacher (seb128) wrote :

setting as new the video shows the issue but I can't confirm on a french desktop there, could be locale or config specific

Changed in indicator-datetime (Ubuntu):
status: Incomplete → New
Ted Gould (ted) wrote :

The fix here is a little bit odd, but I'm going to merge it (it's harmless if not) and mark this bug as fixed. It should be in the 0.2.1 release of indicator-datetime. Please verify when you get that release and mark this as Confirmed if it is not fixed. Thanks!

Changed in indicator-datetime:
milestone: none → 0.2.1
status: New → Fix Committed
Karl Lattimer (karl-qdh) wrote :

The language should not have any affect on the result here, the settings are being handled in the same way for both the show seconds changing and the format changing.

One of them appears not to be executed correctly otherwise the change would have occurred.

In the original code the show seconds was not braced and the show format was, so this may have caused confusion. I can't reproduce the bug so this is just a best guess.

Ted Gould (ted) on 2011-03-31
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.2.1-0ubuntu1

---------------
indicator-datetime (0.2.1-0ubuntu1) natty; urgency=low

  * New upstream release.
    * indicator-datetime-preferences crashed with SIGSEGV in
      g_utf8_normalize() (LP: #727089)
    * Uninstalling Evolution removes calendar from clock applet (LP: #691953)
    * clock doesn't update on timezone change (LP: #735445)
    * Cannot change main location (LP: #729029)
    * indicator-datetime-preferences crashed with SIGSEGV in
      g_simple_async_result_complete() (LP: #734951)
    * Time zone map looks identical when sensitive vs. insensitive (LP: #740846)
    * "Locations" window behaves like a modal dialog (LP: #740924)
    * Added location for clock menu isn't used or remembered (LP: #740930)
    * Time not displayed for added location in "Locations" window (LP: #740931)
    * "UTC" location can be removed but not re-added (LP: #740938)
    * "Locations" window bottom bar is missing a border (LP: #740941)
    * Add and Remove buttons in "Locations" window have unnecessary tooltips
      (LP: #740944)
    * No separator between "Add Event" and locations (LP: #740971)
    * indicator-datetime-preferences crashed with SIGSEGV in
      g_atomic_int_exchange_and_add() (LP: #740978)
    * inicator-datetime dosen't show corretly the time when changing from 24
      hours format to 12 hours (LP: #743394)
    * Add tooltips on the error icons
    * Fix marking to refresh as the calendar changes
    * Recycle old entries to make the refresh cleaner
    * Use day when timezone is set to 'locale'
    * Reset time when coming back from suspend (LP: #726053)
 -- Ted Gould <email address hidden> Thu, 31 Mar 2011 14:32:40 -0500

Changed in indicator-datetime (Ubuntu):
status: New → Fix Released

I continue to have this bug even after the fix was released, and now I think it is related to the language because yesterday after a fresh install of natty beta the language wasn't download during the install and after reboot and login with english as the language the 12 hours format worked fine but after I installed my local language package "spanish" it started to work in the same way that I reported in this bug.

Michael Terry (mterry) wrote :

I tried using a Spanish locale and couldn't reproduce this... How did you install the spanish language packs? Exactly what locale did you choose?

Well I'm sorry I opened an other bug today https://bugs.launchpad.net/bugs/754571 before recibing this email because I didn't recived an answer. I'll copy what I explained in the new bug.

"I reported this bug not too long ago https://bugs.launchpad.net/bugs/743394 and the fix was released in the package indicator-datetime - 0.2.1-0ubuntu1, but I continue to have the same bug in the indicator-datetime - 0.2.2-0ubuntu1, the actual version of the indicator. Now I'm certanlly that this bug is related to the language, because of a bug in the installation process of natty beta 1, the "spanish translation packages" weren't downloaded. When I booted ubuntu the language in use was english, I changed to the 12 hours format and it worked fine, but after installing the spanish packages, it worked in the same way of the bug that I repported first, showing with the 12 hours format like the 24 hours format."

The application that I used to install the local package was "Language Support", I just started it and after that the application checks if the local packages are installed and if they aren't installed the Laguage Support downloads the missing packages.

Ask me for more information.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.