date and time in the menu should be localized

Bug #737326 reported by Xhacker Liu on 2011-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Low
Unassigned
Ubuntu Translations
Low
Unassigned
indicator-datetime (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: indicator-datetime

In the datetime-service.c, there are

 /* Note: may require some localization tweaks */
 strftime(longstr, 128, "%A, %e %B %Y", ltime);

Yep it absolutely have to be localized.

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in indicator-datetime:
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

where does that show non translated in the ui?

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Xhacker Liu (xhacker) wrote :

Click the clock in the panel (I mean indicator-datetime), the first item in the menu shows date and time, and it should be translatable.

And it is in datetime-service.c.

Sebastien Bacher (seb128) wrote :

it's displayed translated there...

Xhacker Liu (xhacker) wrote :

You know, translation and localization are two different things.

Do you know something about strftime?
It's translated because each part of strftime is translated.
However the format is wrong.

The format string is now "%A, %d %B %Y", and it's not translatable.
So, it displayed as a translated string with wrong format.

Xhacker Liu (xhacker) wrote :

Sorry, it is "%A, %e %B %Y" now and it is fixed.

Xhacker Liu (xhacker) wrote :

Err...
I mean the string is fixed(not translatable)...

Gabor Kelemen (kelemeng) wrote :

It is not:

https://translations.launchpad.net/ubuntu/natty/+source/indicator-datetime/+pots/indicator-datetime/hu/+translate?batch=10&show=all&search=%25Y

So, no %Y there, but the label clearly contains the year. And there is no other similar, already translated or untranslated occurrence of %Y in the code:

gabor@gabor-laptop:~/src/ubuntu/indicator-datetime$ grep -r %Y *
libmap/data/bg.png bináris fájl illeszkedik
libmap/data/cc.png bináris fájl illeszkedik
libmap/data/timezone_-4.png bináris fájl illeszkedik
src/datetime-service.c: strftime(longstr, 128, "%A, %e %B %Y", ltime);
src/datetime-prefs.c: format = "%Y-%m-%d";

Marking the mentioned string as translatable solved the problem.

Gabor Kelemen (kelemeng) on 2011-03-21
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

thanks for the details, next time it might be easier to just give some clear description of the issue to make triaging work easier

Changed in indicator-datetime (Ubuntu):
status: Incomplete → Confirmed
Changed in indicator-datetime:
status: Incomplete → Confirmed
Ted Gould (ted) on 2011-03-22
Changed in indicator-datetime:
status: Confirmed → Fix Committed
Ted Gould (ted) on 2011-03-23
Changed in indicator-datetime:
milestone: none → 0.2.0
Ted Gould (ted) on 2011-03-23
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.2.0-0ubuntu1

---------------
indicator-datetime (0.2.0-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Remove unused liboobs
    ∘ Add translator comments and make strings translatable (LP: #737326)
    ∘ Remove password dialog for calendars not the keyring
    ∘ Use default matching when geonames aren't available (LP: #740870)
    ∘ UI Cleanups and naming fixes (LP: #740806, LP: #740819)
    ∘ Free JSON parser data
    ∘ Avoid duplicates in GeoNames data (LP: #740884)
    ∘ Make location completion more robust
  * debian/control: Dropping liboobs
 -- Ted Gould <email address hidden> Wed, 23 Mar 2011 16:22:50 -0500

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
David Planella (dpm) on 2011-04-05
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers