indicator-datetime-service crashed with SIGSEGV in g_main_context_dispatch()

Bug #733833 reported by Florian Boucault on 2011-03-12
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Undecided
Unassigned
Unity Foundations
High
Karl Lattimer
unity-2d
High
Unassigned
indicator-datetime (Ubuntu)
High
Karl Lattimer

Bug Description

Binary package hint: indicator-datetime

Crashed just after login.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-datetime 0.1.96-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
NonfreeKernelModules: nvidia wl
Architecture: amd64
CrashCounter: 1
Date: Sat Mar 12 14:32:03 2011
ExecutablePath: /usr/lib/indicator-datetime/indicator-datetime-service
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64+mac (20110307)
ProcCmdline: /usr/lib/indicator-datetime/indicator-datetime-service
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x4048fa: mov 0x0(%rbp,%rcx,1),%edx
 PC (0x004048fa) ok
 source "0x0(%rbp,%rcx,1)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: indicator-datetime
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 g_main_context_dispatch () from /lib/libglib-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
Title: indicator-datetime-service crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Florian Boucault (fboucault) wrote :
Changed in unity-2d:
importance: Undecided → High
milestone: none → 3.8
visibility: private → public
Karl Lattimer (karl-qdh) wrote :

@Florian, is this bug reproducible?

Can you install debug symbols and try to get a better stack trace (installing related -dbgsym packages should be enough)

Florian Boucault (fboucault) wrote :

Karl, I will try to get a better stack trace if it happens again. For now it is not happening reliably.

Florian Boucault (fboucault) wrote :

I reproduced it and attached a useful trace.

Changed in indicator-datetime (Ubuntu):
importance: Undecided → High
David Barth (dbarth) on 2011-03-15
Changed in unity-foundations:
importance: Undecided → High
assignee: nobody → Karl Lattimer (karl-qdh)
Changed in indicator-datetime (Ubuntu):
milestone: none → ubuntu-11.04-beta-1
Changed in unity-foundations:
milestone: none → unity-3.6.6
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
Karl Lattimer (karl-qdh) wrote :

This crash seems to have been caused by a gvariant problem I was having for a short while, this should be fixed in the attached branch.

The attached branch also requires ido from lp:~karl-qdh/ido/select-activate-set-date which has since been merged.

Ted Gould (ted) on 2011-03-16
Changed in indicator-datetime:
milestone: none → 0.1.98
status: New → Fix Released
Changed in unity-foundations:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.1.98-0ubuntu1

---------------
indicator-datetime (0.1.98-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Make appointments match calendar month
    ∘ Fix time format of appointments
    ∘ Get date change signals from calendar and adjust based on them.
    ∘ Crash fixes (LP: #733833, LP: #729444)
    ∘ Valgrind invalid read (LP: #729175)
    ∘ Translation fixes to date label (LP: #729632)
    * Fix handling of reoccruing events
    * Handle settings in the indicator
    * Allow for hiding the calendar and the clock
 -- Ted Gould <email address hidden> Wed, 16 Mar 2011 16:17:38 -0500

Changed in indicator-datetime (Ubuntu):
status: New → Fix Released
Changed in unity-2d:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers