OneTime alarms are not automatically dismissed or delete after they are triggered

Bug #1362341 reported by Nekhelesh Ramananthan on 2014-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Indicator Date and Time
Fix Released
High
Charles Kerr
Ubuntu Clock App
High
Nekhelesh Ramananthan
indicator-datetime (Ubuntu)
High
Charles Kerr
indicator-datetime (Ubuntu RTM)
Undecided
Unassigned
ubuntu-clock-app (Ubuntu)
Undecided
Nekhelesh Ramananthan

Bug Description

Steps to reproduce:
1. Create a one time alarm to ring in a few minutes
2. Let the alarm ring
3. Dismiss the alarm

What happens:
The OneTime alarm is still shown as enabled and as a result shows the wrong status in the clock app. The alarm is no longer shown in the indicator-datetime.

What should happen:
The OneTime alarm is either disabled or deleted from the alarm model.

The clock app cannot disable the alarm since most likely the clock app is not even open at the time the alarm is triggered. Since the alarm is no longer shown in the indicator-datetime, my intuition tells me that indicator-datetime and EDS did its job. Its now up to the SDK Alarms API to update the alarm model correctly.

Related branches

tags: added: rtm14
description: updated
Zsombor Egri (zsombi) wrote :

Alarm enabled state is built up based on Audible and Visual reminders. The Enabled state is never saved. On the other hand, alarm service is not running if the Clock app doesn't run, so it cannot do anything with the alarm.

And finally, a dismissed alarm should be only disabled, not removed.

Zsombor Egri (zsombi) on 2014-09-02
Changed in ubuntu-ui-toolkit:
status: New → Invalid
no longer affects: ubuntu-ui-toolkit
Changed in indicator-datetime:
status: New → Confirmed
Thomas Strehl (strehl-t) on 2014-09-04
Changed in indicator-datetime:
assignee: nobody → Charles Kerr (charlesk)
tags: added: touch-2014-09-25
Stephen M. Webb (bregma) on 2014-09-18
Changed in indicator-datetime:
importance: Undecided → High
Charles Kerr (charlesk) on 2014-09-23
tags: added: touch-2014-10-09
removed: touch-2014-09-25
Charles Kerr (charlesk) on 2014-10-08
tags: added: touch-2014-10-16
removed: touch-2014-10-09
Changed in indicator-datetime:
status: Confirmed → In Progress
Ted Gould (ted) on 2014-11-10
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
status: New → In Progress
Pat McGowan (pat-mcgowan) wrote :

Land with #1387231 and clean up alarms

Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww51-2014
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+15.04.20141208-0ubuntu1

---------------
indicator-datetime (13.10.0+15.04.20141208-0ubuntu1) vivid; urgency=low

  [ Charles Kerr ]
  * Don't log an error if powerd isn't available on the system. (LP:
    #1384714)
  * Add support for x-canonical-alarm and x-canonical-disabled tags in
    VTODO categories so that disabled alarms will not be displayed. (LP:
    #1387231)
  * Change notifications for calendar events s.t. the sound is
    nonrepeating and the notification is temporary, not requiring user
    interaction to disappear. (LP: #1320880)
  * After a one-time Ubuntu alarm's notification is displayed, disable
    the alarm. (LP: #1362341)
 -- Ubuntu daily release <email address hidden> Mon, 08 Dec 2014 23:09:20 +0000

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
Charles Kerr (charlesk) wrote :

lp:~charlesk/indicator-datetime/lp-1362341-disable-one-time-ubuntu-alarms-after-notification fixes this for indicator-datetime, but looks like there's still a minor refresh error in clock-app.

If you have clock-app's alarm page open when the alarm goes off, the visual appearance of the alarm doesn't switch to disabled even though the x-canonical-disabled tag is correctly being added to the alarm's categories in tasks.ics.

If you force a UI refresh by switching from the alarm page to the main page, then back to the alarm page again, the alarm is correctly shown as disabled.

Changed in ubuntu-clock-app (Ubuntu):
assignee: nobody → Nekhelesh Ramananthan (nik90)
Changed in ubuntu-clock-app:
assignee: nobody → Nekhelesh Ramananthan (nik90)
importance: Undecided → High
status: New → Confirmed
milestone: none → ota-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+15.04.20141210~rtm-0ubuntu1

---------------
indicator-datetime (13.10.0+15.04.20141210~rtm-0ubuntu1) 14.09; urgency=low

  [ Charles Kerr ]
  * Change notifications for calendar events s.t. the sound is
    nonrepeating and the notification is temporary, not requiring user
    interaction to disappear.
  * After a one-time Ubuntu alarm's notification is displayed, disable
    the alarm. (LP: #1362341)

indicator-datetime (13.10.0+15.04.20141103-0ubuntu1) vivid; urgency=low

  [ Ted Gould ]
  * Small tag typo in integration test
 -- Ubuntu daily release <email address hidden> Wed, 10 Dec 2014 04:16:19 +0000

Changed in indicator-datetime (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
milestone: ww51-2014 → ww03-2015
Charles Kerr (charlesk) on 2015-01-15
Changed in indicator-datetime:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in ubuntu-clock-app:
status: Confirmed → In Progress

Fix committed into lp:ubuntu-clock-app at revision 188, scheduled for release in ubuntu-clock-app, milestone ota-1

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
Changed in ubuntu-clock-app (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints