clock-app alarms need to be handled differently from other VTODO events

Bug #1361702 reported by Nekhelesh Ramananthan on 2014-08-26
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Canonical Devices Products
Indicator Date and Time
Fix Released
High
Charles Kerr
Ubuntu Calendar App
Medium
Unassigned
Ubuntu UI Toolkit
Fix Released
High
Zsombor Egri
indicator-datetime (Ubuntu)
High
Charles Kerr
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

When you disable an alarm in the new clock app (with white background), it causes the alarm to show up as a calendar event. The expected behaviour is to not show up at all.

Related branches

Nekhelesh Ramananthan (nik90) wrote :
Nekhelesh Ramananthan (nik90) wrote :
Charles Kerr (charlesk) on 2014-08-26
Changed in indicator-datetime:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Charles Kerr (charlesk)
description: updated
Charles Kerr (charlesk) wrote :

The fix for this bug, under the current assumptions: have datetime hide all VTODO items that don't have audio urls. That fix would come back to bite us once we start importing other VTODOs from external calendars.

IMO what we need is a way to flag this special treatment for our clock-app alarms without breaking third-party vtodo events.

I suggest we add an "x-canonical-disabled" tag to disabled alarms:

1. it gives datetime sufficient info to not process the alarms

2. qtorganizer5-eds seems to already support QOrganizer tag <--> ECalComponent category conversion,

3. This would let ubuntu-ui-toolkit clean up a wart of it deleting/restoring attachments as a proxy for an enabled/disabled flag

4. It doesn't break third-party VTODOs

5. It simplifies the fix for bug #1362341 (OneTime alarms are not automatically dismissed or delete after they are triggered)

Zsombor Egri (zsombi) wrote :

The problem is that alarms are still going to be stored as QtOrganizerTodo elements, so the alarms will still show up in the Calendar :/

We need a way in EDS backend to isolate the alarm Todos from the rest of the system...

Zsombor Egri (zsombi) wrote :

So, a workaround we agreed on would be needed to be coordinated with Calendar app.

The workaround would be to add a "x-canonical-alarm" (or whatever) tag to all alarms. These events should be filtered out in Calendar app, so those won't be shown up in Calendar then.

A proper fix we discussed about was to drop QtOrganizer from Alarm services, and use datetime indicator DBus API to save/delete/fetch alarms. That will be discussed in a separate thread and done post-RTM.

Charles Kerr (charlesk) wrote :

Right, we could add CRUD methods for alarms to the datetime.alarms DBus namespace post-RTM.

For this bug for now, I'd still prefer "x-canonical-disabled" to "x-canonical-alarm" since it still address points 3 and 5 in my comment above.

Zsombor Egri (zsombi) wrote :

We need two tags then: x-canonical-alarm will be set to all alarms, and x-canonical-disabled will be set in addition to disabled alarms.

Calendar app must filter out all todo events tagged with "x-canonical-alarm".

Charles Kerr (charlesk) on 2014-09-24
summary: - Disabled alarms show up as calendar events
+ clock-app alarms need to be handled differently from other VTODO events
Zsombor Egri (zsombi) on 2014-09-24
tags: added: rtm14
Changed in ubuntu-ui-toolkit:
assignee: nobody → Zsombor Egri (zsombi)
status: New → Triaged
Mihir Soni (mihirsoni) on 2014-09-24
Changed in ubuntu-calendar-app:
status: New → Confirmed
Charles Kerr (charlesk) wrote :

Summary of irc chat:

For RTM:

1. ubuntu-ui-toolkit will add two tags/categories: (1) "x-canonical-alarm" present in all alarms, and also (2) "x-canonical-disabled" in the disabled ones.

2. ubuntu-clock-app will ignore / not show anything with the "x-canonical-alarm" tag

3. indicator-datetime will ignore / not kick on alarms with the "x-canonical-disabled" tag

4. indicator-datetime will address High bug #1362341 with the tag context discussed here.

Post RTM:

Look for a non-ical solution for clock-app alarms so that these kind of magic flags aren't necessary, perhaps an alarm CRUD API in indicator-datetime's DBus API.

Mihir Soni (mihirsoni) on 2014-09-24
Changed in ubuntu-calendar-app:
importance: Undecided → Medium
Charles Kerr (charlesk) wrote :

- 2. ubuntu-clock-app will ignore / not show anything with the "x-canonical-alarm" tag
+ 2. ubuntu-calendar-app will ignore / not show anything with the "x-canonical-alarm" tag

Charles Kerr (charlesk) on 2014-09-24
tags: added: touch-2014-10-09
tags: added: touch-2014-10-02
removed: touch-2014-10-09

On Wed, Sep 24, 2014 at 4:23 PM, Charles Kerr <email address hidden>
wrote:

> Summary of irc chat:
>
> For RTM:
>
> 1. ubuntu-ui-toolkit will add two tags/categories: (1) "x-canonical-
> alarm" present in all alarms, and also (2) "x-canonical-disabled" in the
> disabled ones.
>
> 2. ubuntu-clock-app will ignore / not show anything with the "x
> -canonical-alarm" tag
>

I'm guessing this should read calendar-app instead? We definitely need to
show alarms in clock.

>
> 3. indicator-datetime will ignore / not kick on alarms with the "x
> -canonical-disabled" tag
>
> 4. indicator-datetime will address High bug #1362341 with the tag
> context discussed here.
>
> Post RTM:
>
> Look for a non-ical solution for clock-app alarms so that these kind of
> magic flags aren't necessary, perhaps an alarm CRUD API in indicator-
> datetime's DBus API.
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> UI Toolkit.
> https://bugs.launchpad.net/bugs/1361702
>
> Title:
> clock-app alarms need to be handled differently from other VTODO
> events
>
> Status in The Date and Time Indicator:
> Triaged
> Status in Calendar application for Ubuntu devices:
> Confirmed
> Status in Ubuntu UI Toolkit:
> Triaged
>
> Bug description:
> When you disable an alarm in the new clock app (with white
> background), it causes the alarm to show up as a calendar event. The
> expected behaviour is to not show up at all.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/indicator-datetime/+bug/1361702/+subscriptions
>

Changed in ubuntu-ui-toolkit:
importance: Undecided → High
Zsombor Egri (zsombi) wrote :

David, your assumption is right :)

Zsombor Egri (zsombi) on 2014-09-25
Changed in ubuntu-ui-toolkit:
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Charles Kerr (charlesk) wrote :

Matching datetime priority with ui-toolkit priority.

David, see comment #9 :-)

Changed in indicator-datetime:
importance: Medium → High
Charles Kerr (charlesk) wrote :

Tracking ticket for post-RTM: bug #1373987

tags: added: ota-1
removed: touch-2014-10-02
Kunal Parmar (pkunal-parmar) wrote :

As I understand, Alarm is stored as Todo in EDS and this new Tag will be added to Todo event type only.

In Calendar App, we show only event of type Event and EventOccurrence, We dont show Alarm/Todo in Calendar app, So I don't think we need to make any change in Calendar app for this defect.

I believe this bug does not affect calendar app.

Changed in ubuntu-calendar-app:
status: Confirmed → Invalid
Zoltan Balogh (bzoltan) on 2014-10-01
Changed in ubuntu-ui-toolkit:
milestone: none → 10.09
Zsombor Egri (zsombi) on 2014-10-07
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in indicator-datetime:
status: Triaged → In Progress
Ted Gould (ted) on 2014-11-10
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
status: New → In Progress
Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Charles Kerr (charlesk) on 2014-12-10
Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
Changed in indicator-datetime:
assignee: Charles Kerr (charlesk) → nobody
assignee: nobody → Charles Kerr (charlesk)
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu Vivid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints