Running the "click" command on the desktop greeter seems wrong

Bug #1255716 reported by Sebastien Bacher on 2013-11-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
High
Charles Kerr
indicator-datetime (Ubuntu)
High
Unassigned

Bug Description

Using current trusty, /var/lib/lightdm/.cache/upstart/indicator-datetime.log contains those warnings

"g_object_unref: assertion 'G_IS_OBJECT (object)' failed 'com.ubuntu.clock does not exist in any database for user lightdm'
[Errno 2] No such file or directory: 'com.ubuntu.clock'

 (process:4779): Indicator-Datetime-WARNING **: indicator-datetime cannot show EDS appointments:
Indicator-Datetime-Message: exiting: service couldn't acquire or lost ownership of busname"

Reading a bootchart confirms that the indicator runs the click command (it's installed on my desktop configuration for testing)

Related branches

Sebastien Bacher (seb128) wrote :

I guess the click command should be used on the phone only for now...

Btw the indicator logs have quite some weird warning like "exiting: service couldn't acquire or lost ownership of busname", not sure if there is a timing issue with the upstart jobs

Changed in indicator-datetime:
importance: Undecided → High
Changed in indicator-datetime (Ubuntu):
importance: Undecided → High
Changed in indicator-datetime:
assignee: nobody → Charles Kerr (charlesk)
Charles Kerr (charlesk) on 2014-01-29
Changed in indicator-datetime:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) on 2014-02-28
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Changed in indicator-datetime:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers