alarm / appointment times aren't displayed on touch

Bug #1237752 reported by Charles Kerr on 2013-10-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
High
Charles Kerr
Ubuntu Settings Components
High
Nick Dedekind
ubuntu-settings-components (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
High
Nick Dedekind

Bug Description

Times for alarms and appointments should be shown as displayed at <https://wiki.ubuntu.com/TimeAndDate?action=AttachFile&do=get&target=phone-indicator-clock.png>.

These appointment and alarm menuitems have an x-canonical-type set so that client UIs can display the information as per the spec.

> * Alarm
> - label s short summary of the appointment
> - x-canonical-type s "com.canonical.indicator.alarm"
> - x-canonical-time x the date of the appointment
> - x-canonical-time-format s strftime format string
>
> * Appointment
> - label s short summary of the appointment
> - x-canonical-type s "com.canonical.indicator.appointment"
> - x-canonical-color s color of the appt's type, to give a visual cue
> - x-canonical-time x the date of the appointment
> - x-canonical-time-format s strftime format string

Related branches

Charles Kerr (charlesk) on 2013-10-10
Changed in indicator-datetime:
status: New → Invalid
description: updated
Michał Sawicz (saviq) on 2013-10-11
Changed in unity8:
status: New → Triaged
importance: Undecided → High
Changed in ubuntu-settings-components:
status: New → Triaged
importance: Undecided → High
Mirco Müller (macslow) on 2013-10-15
Changed in unity8:
assignee: nobody → Mirco Müller (macslow)
Changed in ubuntu-settings-components:
assignee: nobody → Mirco Müller (macslow)
Mirco Müller (macslow) on 2013-10-16
Changed in unity8:
status: Triaged → In Progress
Changed in ubuntu-settings-components:
status: Triaged → In Progress
Mirco Müller (macslow) on 2013-10-16
Changed in ubuntu-settings-components:
assignee: Mirco Müller (macslow) → nobody
Changed in unity8:
assignee: Mirco Müller (macslow) → nobody
Changed in ubuntu-settings-components:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity8:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in ubuntu-settings-components:
status: In Progress → Triaged
Changed in unity8:
status: In Progress → Triaged
Mirco Müller (macslow) on 2013-10-16
Changed in ubuntu-settings-components:
status: Triaged → Confirmed
Changed in unity8:
status: Triaged → Confirmed
Changed in ubuntu-settings-components:
status: Confirmed → In Progress
Changed in unity8:
status: Confirmed → In Progress
Nick Dedekind (nick-dedekind) wrote :

@charlesk: Looks like this bug does exist in indicator-datetime.

I can reproduce this on desktop as well. If you add an event to evolution, it does not appear unless you restart the indicator, or disable/enable a calendar source. Looks like the "source-changed" signal does not get emitted for changes to events.
I've taken a look at evolution, and I think we need an ECalClientView here.

Changed in indicator-datetime:
status: Invalid → New
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in indicator-datetime:
assignee: Nick Dedekind (nick-dedekind) → Charles Kerr (charlesk)
importance: Undecided → High
status: New → Confirmed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-settings-components at revision 59, scheduled for release in ubuntu-settings-components, milestone Unknown

Changed in ubuntu-settings-components:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings-components - 0.1+14.04.20131217-0ubuntu1

---------------
ubuntu-settings-components (0.1+14.04.20131217-0ubuntu1) trusty; urgency=low

  [ Nick Dedekind ]
  * Fixed visual design of EventMenu. Simplified Checkbox/GroupMessage.
    (LP: #1237752)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 59
 -- Ubuntu daily release <email address hidden> Tue, 17 Dec 2013 12:49:47 +0000

Changed in ubuntu-settings-components (Ubuntu):
status: New → Fix Released
Charles Kerr (charlesk) wrote :

The error with alarms not appearing in the indicator is fixed in lp:~charlesk/indicator-datetime/alarms.

The rendering issue in unity8 still needs to be addressed.

Changed in indicator-datetime:
status: Confirmed → In Progress
Charles Kerr (charlesk) on 2014-03-28
Changed in indicator-datetime:
status: In Progress → Fix Released
Changed in ubuntu-settings-components:
status: Fix Committed → Fix Released
Changed in unity8:
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2017-03-13
affects: unity8 → unity8 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers