Crashes on Yakkety from official repos

Bug #1636325 reported by Jase Whipp on 2016-10-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
indicator-cpufreq
Undecided
Unassigned

Bug Description

Launching indicator-cpufreq from package version 0.2.2-0ubuntu2 results in a crash with the following output:

/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py:20: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py:21: PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.
  from gi.repository import AppIndicator3 as appindicator
Traceback (most recent call last):
  File "/usr/bin/indicator-cpufreq", line 79, in <module>
    ind = MyIndicator(options.show_frequency)
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py", line 99, in __init__
    self.update_ui()
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py", line 110, in update_ui
    fmin, fmax, governor = cpufreq.get_policy(self.cpus[0])
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/cpufreq.py", line 143, in get_policy
    policy = (p.contents.min, p.contents.max, p.contents.governor.decode())
ValueError: NULL pointer access

Version Information:

Package: indicator-cpufreq
Priority: extra
Section: universe/python
Installed-Size: 601
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Artem Popov <email address hidden>
Architecture: all
Version: 0.2.2-0ubuntu2
Depends: python3, python3:any (>= 3.3.2-2~), python3-dbus, python3-gi, gir1.2-appindicator3-0.1, libcpufreq0
Filename: pool/universe/i/indicator-cpufreq/indicator-cpufreq_0.2.2-0ubuntu2_all.deb
Size: 25758
MD5sum: eb60e05356a8e7e700a302bd0879869a
SHA1: 3e3be8431dda1b7b9b60f7e2e2800a6c4eadf1f4
SHA256: 4ef03f9ace4fdfeb0ed9dcf275e74e1f0a66a9ed69032490d8f398b88b33e7c1
Description-en: CPU frequency scaling indicator
 Indicator applet for displaying and changing CPU frequency on the fly. It
 provides the same functionality as the GNOME CPU frequency applet, but doesn't
 require GNOME panel and works under Unity.
Description-md5: 6f34a7c9948543b9eaec8fa9809f9c7e
Homepage: https://launchpad.net/indicator-cpufreq
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

Nazar Mokrynskyi (nazar-pc) wrote :

I've being using this indicator happily till today. Now it is crashing with message above.
What has changed in y system since it was working is gnome-settings-daemon was updated:
gnome-settings-daemon (3.22.1-0ubuntu2) to 3.23.3-0ubuntu1
gnome-settings-daemon-schemas (3.22.1-0ubuntu2) to 3.23.3-0ubuntu1

I've fixed first warnings as suggested in warning message manually, but still left with:
 nazar-pc  ~  indicator-cpufreq
Traceback (most recent call last):
  File "/usr/bin/indicator-cpufreq", line 79, in <module>
    ind = MyIndicator(options.show_frequency)
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py", line 102, in __init__
    self.update_ui()
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/indicator.py", line 113, in update_ui
    fmin, fmax, governor = cpufreq.get_policy(self.cpus[0])
  File "/usr/lib/python3/dist-packages/indicator_cpufreq/cpufreq.py", line 143, in get_policy
    policy = (p.contents.min, p.contents.max, p.contents.governor.decode())
ValueError: NULL pointer access

Nazar Mokrynskyi (nazar-pc) wrote :

I found a reason of this issue. There was indeed another change in my system: I've disabled EIST (Enhanced Intel Speedstep Technology) in UEFI. Enabling it back fixes this issue. Is this something that might be fixed?

Changed in indicator-cpufreq:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers