Port indicator-cpufreq to libcpupower

Bug #1177826 reported by lucian on 2013-05-08
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
indicator-cpufreq
Undecided
Unassigned

Bug Description

Kernel 3.9 onwards by replacing libcpufreq with the new libcpupower breaks the functionality of indicator-cpufreq. The broken indicator displays only two choices: 1.performance 2.powersave, which by the way do not work.

lucian (luciany) wrote :

double checked and worked OK with k 3.9.0

Artem Popov (artfwo) wrote :

I assume, "k" means the kernel? This looks like a problem with the kernel configuration then, not a bug in indicator-cpufreq. Check that your kernel supports CPU freqency scaling. The options to look for in the kernel config would be:

CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_GOV_COMMON=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y

Changed in indicator-cpufreq:
status: New → Invalid
Chris Glass (tribaal) wrote :

I have the same symptoms after upgrading to saucy (3.10.0) - before the upgrade the applet worked perfectly, now I only have a choice between "performance" and "powersave" (but it seems like they have no effect).

Artem Popov (artfwo) wrote :

Yep, it looks like cpufreq scaling is broken/incompatible in 3.9.0 and above. Can you provide the output of cpufreq-info for your system?

Heimen Stoffels (vistaus) wrote :

Same problem here. Just upgraded from kernel 3.8 to kernel 3.10.1 and this bug has come up :(

cpufreq-info says:

vistausss@bodhimbp:~$ cpufreq-info
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to <email address hidden>, please.
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.10 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 1.20 GHz and 3.10 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
analyzing CPU 1:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.10 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 1.20 GHz and 3.10 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
analyzing CPU 2:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 2
  CPUs which need to have their frequency coordinated by software: 2
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.10 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 1.20 GHz and 3.10 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
analyzing CPU 3:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 3
  CPUs which need to have their frequency coordinated by software: 3
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.10 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 1.20 GHz and 3.10 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
vistausss@bodhimbp:~$

Artem Popov (artfwo) wrote :

So, it appears that cpufrequtils no longer works with recent kernels. Hmm, actually it looks like cpufrequtils is obsolete and replaced by cpupowerutils (not yet packaged in Ubuntu?).

Changed in indicator-cpufreq:
status: Invalid → Triaged
Artem Popov (artfwo) wrote :

Recent kernel upload, https://launchpad.net/ubuntu/+source/linux/3.11.0-3.6 includes libcpupower (the replacement lib for libcpufreq), renaming the bug accordingly.

summary: - after installing k 3.9.1 i have only 2 choises on indicator
- 1.performance 2.powersave and it seems not working at all
+ Port indicator-cpufreq to libcpupower
aldebx (aldebx) on 2013-09-01
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers