double frequency option (1.2 ghz)

Bug #1008438 reported by Michael Tanner
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-cpufreq
Fix Released
Undecided
Unassigned
indicator-cpufreq (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Hi, first you don't have Precise packages but Oneiric packages work well.

My bug report:
I do have Intel(R) Core(TM) i5 CPU U 430 @ 1.20GHz and can choose between the governors and also several frequencies. At frequenzy 1.20 there are two options for that frequency. I don't know why and I thinks it's a bug parsing the cpu frequencies and both options provide the same result.

Revision history for this message
Artem Popov (artfwo) wrote :

Does this also happen if you install the Precise version from Universe?

Changed in indicator-cpufreq:
status: New → Incomplete
Revision history for this message
Michael Tanner (thonixx) wrote :

Yes, it even appears with the package from Universe. Thanks for the hint, I even didn't know about this.

Revision history for this message
Artem Popov (artfwo) wrote :

Hmmm, can you paste the output of cpufreq-info command from cpufrequtils package? (you can uninstall the package afterwards to avoid conflicts with indicator-cpufreq)

Changed in indicator-cpufreq:
status: Incomplete → New
Revision history for this message
Michael Tanner (thonixx) wrote :

Attached below

And this is weird:

"available frequency steps: 1.20 GHz, 1.20 GHz"
I think it's thought be so. And after I read this, I will close the bug because it's actually no bug.

Revision history for this message
Michael Tanner (thonixx) wrote :

It's not really a bug of indicator-cpufreq

Changed in indicator-cpufreq:
status: New → Invalid
Revision history for this message
Artem Popov (artfwo) wrote :

Yep, likely a kernel or libcpufreq problem. A workaround is totally doable though.

Revision history for this message
Michael Tanner (thonixx) wrote :

Will you do a workaround?

Revision history for this message
Artem Popov (artfwo) wrote :

Yes, hopefully I'll have time for that next week.

Revision history for this message
Michael Tanner (thonixx) wrote :

"Confirmed" because a fix could avoid double frequency options

Changed in indicator-cpufreq:
status: Invalid → Confirmed
Revision history for this message
Dac Chartrand (conner-bw) wrote :

I also have this bug.

Ubuntu 12.04 LTS, Lenovo X220.

See attached file.

Installe from the Ubuntu Software Center (indicator-cpufreq 0.1.4-0ubuntu2)

Revision history for this message
Michael Tanner (thonixx) wrote :

artfwo, got any updates?

Revision history for this message
Artem Popov (artfwo) wrote :

Yep, working on a python3 port, that will have this bug fixed too (and probably released with raring).

Revision history for this message
Artem Popov (artfwo) wrote :

Guys, while I'm preparing the new release, you can download this deb I'm attaching here. Please try it and check if the problem is solved. Thanks!

Revision history for this message
Artem Popov (artfwo) wrote :

Now in current bazaar branch too.

Changed in indicator-cpufreq:
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-cpufreq - 0.2-0ubuntu1

---------------
indicator-cpufreq (0.2-0ubuntu1) raring; urgency=low

  * New upstream release (LP: #1105609):
    - App ported to Python 3.
    - Fixes LP: #1008438.
    - Fixes LP: #1079864.
    - Translation updates.
  * debian/copyright format updated.
  * Manually build py3 binary in debian/rules.
  * Fix remaining lintian warnings (LP: #1082259).
 -- Artem Popov <email address hidden> Fri, 25 Jan 2013 21:47:41 +0700

Changed in indicator-cpufreq (Ubuntu):
status: New → Fix Released
Artem Popov (artfwo)
Changed in indicator-cpufreq:
status: Fix Committed → Won't Fix
status: Won't Fix → Fix Released
Revision history for this message
Artem Popov (artfwo) wrote :

Michael, can you also look at bug 1110429 and run the same test as in comment #4? Please post your results here or there. Thanks!

Revision history for this message
Michael Tanner (thonixx) wrote :

Unfortunately the double bug remains :/

Revision history for this message
Michael Tanner (thonixx) wrote :
Revision history for this message
Artem Popov (artfwo) wrote :

Yep, currently working on a solution in bug 1110429.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers