GtkRecentChooserMenu always selects first entry

Bug #752674 reported by Timo Kluck on 2011-04-06
452
This bug affects 84 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Invalid
Undecided
Unassigned
DBus Menu
Fix Committed
Medium
Unassigned
Inkscape
Undecided
Unassigned
OpenShot Video Editor
High
Unassigned
gitg (Ubuntu)
Undecided
Unassigned
indicator-appmenu (Ubuntu)
Undecided
Unassigned
inkscape (Ubuntu)
Low
Unassigned
libdbusmenu (Ubuntu)
Undecided
Unassigned

Bug Description

A GtkRecentChooserMenu is a submenu with recently used documents. It is used in Anjuta and I also use it in my own code (a patch to Xournal: http://sourceforge.net/tracker/?func=detail&aid=3249971&group_id=163434&atid=827735). It is probably being used by many more applications.

When using the global menu, it is always the first entry that is opened, no matter which one you click. Looking at the source, GtkRecentChooserMenu uses gtk_menu_get_active to select the item. I'm guessing that the active item is not updated when using the global menu. It probably should be.

Related branches

I think this bug is the crux of the issue in both Inkscape and Gitg: https://bugs.launchpad.net/ubuntu/+source/gitg/+bug/708185

ScislaC (scislac) wrote :

Why was an older bug with more activity marked as a duplicate of this newer bug which has less information? By definition, this bug is the duplicate.

Ricardo Graça (devius) wrote :

Because this is more accurate and the source of the actual problem for all the affected programs. Fixing this will cause all the duplicates to be fixed as well, so this is the "trunk" bug while the others are branches, even though they were reported earlier.

Alex Launi (alexlauni) on 2011-08-01
Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gitg (Ubuntu):
status: New → Confirmed
Changed in inkscape:
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in openshot:
status: New → Confirmed
importance: Undecided → High
Jonathan Thomas (jonoomph) wrote :

I have confirmed this bug still happens in the daily build of Ubuntu 12.04, as well as Ubuntu 11.10. I have also confirmed this bug *only* happens in Unity. Gnome Shell and Gnome Classic do not have any issues with selecting recent items from a GtkRecentChooserMenu.

OpenShot, Inkscape, and many other application are going to remain broken until this bug is fixed. Thanks!

Jonathan Thomas (jonoomph) wrote :

I am setting this bug status back to "Confirmed", because it still happens on 11.10 and 12.04 (daily) and only when using Unity. It happens with every GTK application that uses a GtkRecentChooserMenu, such as Inkscape, OpenShot, etc...

This bug affects lots of applications, and I would love to see it fixed. If someone feels this bug is not just related to Unity, please help guide me on how to correctly categorize it.

Easy step to reproduce the bug:
Step 1) Login with Unity
Step 2) Create 2 SVG files in Inkscape (blue_circle.svg and red_square.svg)
Step 3) Launch Inkscape and choose (File->Open Recent-> and choose the 2nd item)

That's it. It will always open the 1st item, and not the 2nd one. If you repeat these steps in Gnome Shell or Gnome classic it will work correctly. Thanks!

Changed in unity (Ubuntu):
status: Invalid → Confirmed
Timo Kluck (tkluck) on 2012-02-01
Changed in appmenu-gtk:
status: New → Confirmed
Changed in indicator-appmenu:
status: New → Confirmed
Changed in inkscape:
status: Confirmed → Invalid
Changed in openshot:
status: Confirmed → Invalid
Changed in gitg (Ubuntu):
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Timo Kluck (tkluck) wrote :

I've marked this as Invalid for all packages that are not directly related to the AppMenu.

That is not to say that is is not a confirmed bug and that it shouldn't be fixed! Thank you, Jonathan, for taking the time to give steps to reproduce.

But it is clear what the underlying bug is, and it is in the AppMenu and not in any of the other packages. Therefore, it is only the AppMenu developers that could possibly fix this. I have tried to look into it myself, but it was a bit too intricate for me to mess with.

I'll try contacting people who may be able to actually do something. In the mean time, it's probably no use to file this bug against any other packages further up in the stack.

Changed in inkscape (Ubuntu):
status: Triaged → Invalid

Jonathan,
I am so sorry for not replying back to you. I was wrapped up in a project
for weeks now and we just finished.
Seems your research and working the bug confirmed my thoughts it was unity
only and not Gnome etc.
I will next time not supply a bug unless I know I can answer you back. But
looks like in time it will be fixed.

Kindly,
Bruce

On Sun, Jan 29, 2012 at 3:58 PM, Jonathan Thomas
<email address hidden>wrote:

> ** Also affects: openshot
> Importance: Undecided
> Status: New
>
> ** Changed in: openshot
> Status: New => Confirmed
>
> ** Changed in: openshot
> Importance: Undecided => High
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (923458).
> https://bugs.launchpad.net/bugs/752674
>
> Title:
> GtkRecentChooserMenu always selects first entry
>
> Status in Application menu module for GTK+:
> New
> Status in The Application Menu:
> New
> Status in Inkscape: A Vector Drawing Tool:
> Confirmed
> Status in OpenShot Video Editor:
> Confirmed
> Status in Unity:
> Invalid
> Status in “gitg” package in Ubuntu:
> Confirmed
> Status in “inkscape” package in Ubuntu:
> Triaged
> Status in “unity” package in Ubuntu:
> Invalid
>
> Bug description:
> A GtkRecentChooserMenu is a submenu with recently used documents. It
> is used in Anjuta and I also use it in my own code (a patch to
> Xournal:
>
> http://sourceforge.net/tracker/?func=detail&aid=3249971&group_id=163434&atid=827735
> ).
> It is probably being used by many more applications.
>
> When using the global menu, it is always the first entry that is
> opened, no matter which one you click. Looking at the source,
> GtkRecentChooserMenu uses gtk_menu_get_active to select the item. I'm
> guessing that the active item is not updated when using the global
> menu. It probably should be.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/appmenu-gtk/+bug/752674/+subscriptions
>

metjush (7800gtxtop) wrote :

Happens in 11.10 and 12.04 Beta 1 and 2. Using Unity only, so cannot deny or prove that it does not happen in Gnome.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-08-16
no longer affects: unity
no longer affects: unity (Ubuntu)

Originally filed over a year ago now. When is this GTK+ bug getting fixed?

I am still struggling with this bug.

Omer Akram (om26er) on 2012-09-06
no longer affects: appmenu-gtk
Albert Astals Cid (aacid) wrote :

Having a look

Changed in indicator-appmenu:
assignee: nobody → Albert Astals Cid (aacid)
status: Confirmed → Won't Fix
status: Won't Fix → In Progress
Albert Astals Cid (aacid) wrote :

Set to dbusmenu instead of indicator-appmenu since it's where the proposed patch fixes the issue

Changed in indicator-appmenu:
status: In Progress → Invalid
assignee: Albert Astals Cid (aacid) → nobody
Changed in dbusmenu:
assignee: nobody → Albert Astals Cid (aacid)
status: New → In Progress
Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Invalid
Changed in dbusmenu:
importance: Undecided → Medium
Changed in dbusmenu:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdbusmenu (Ubuntu):
status: New → Confirmed

I can confirm this behaviour still appears with the latest Inkscape trunk on Precise which reports itself as...
Inkscape 0.48+devel r (Oct 31 2012)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 12.10.3daily13.02.01-0ubuntu1

---------------
libdbusmenu (12.10.3daily13.02.01-0ubuntu1) raring; urgency=low

  [ Mathieu Trudel-Lapierre ]
  * debian/control:
    - Reorganize Build-Depends for clarity.
    - Update style to match other indicator stack packages.
    - Drop Build-Depends on cdbs.
    - Bump debhelper Build-Depends to (>= 9).
    - Update Vcs-Bzr, Vcs-Browser and add a notice to uploaders.
    - Remove outdated Breaks:.
    - Add dbus-test-runner to Build-Depends.
    - Add xvfb to Build-Depends.
  * debian/rules:
    - Convert to dh9; some variables where kept but renamed to brevity.
    - Override dh_autoreconf to make sure it calls autogen.sh, and doesn't run
      configure.
    - Clean up unnecessary files we don't want to install, so that dh_install
      can complete.
    - Override dh_auto_test to make sure they can be run for both the gtk2 and
      gtk3 flavors.
    - Run dh_auto_test through xvfb-run.
  * debian/compat: bump to compat level 9.
  * debian/libdbusmenu-gtk-doc.install: add the glib-server-nomenu.c example.
  * debian/libdbusmenu-tools.install: install dbusmenu-* binaries from the
    multiarch triplet rather than usr/lib/libdbusmenu.
  * Update main sgml documentation files to remove the xml includes we don't
    generate anymore. (LP: #1102468)
  * Drop deprecated calls to g_type_init(). (LP: #1102471)

  [ Didier Roche ]
  * Automatic snapshot from revision 435 (bootstrap):
    - Confirm that icon_name is non-NULL before passing it to
      gtk_icon_theme_has_icon(). (LP: #1082516)
    - Do not reuse menu items if their type is different (LP: #1071321)
    - Fixes interaction with GtkRecentChooserMenu (LP: #752674)

  [ Mathieu Trudel-Lapierre ]
  * libdbusmenu uses deprecated calls to g_type_init() (LP: #1102471)
  * libdbusmenu fails to build due to missing xml documentation include
    files (LP: #1102468)

  [ Chris Coulson ]
  * Leaks GVariant's in multiple places (LP: #1104136)
  * Leak in method call handlers for calls that don't require a reply
    (LP: #1103050)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 440
 -- Automatic PS uploader <email address hidden> Fri, 01 Feb 2013 02:01:01 +0000

Changed in libdbusmenu (Ubuntu):
status: Confirmed → Fix Released
Changed in libdbusmenu:
assignee: Albert Astals Cid (aacid) → nobody

Any chance of a backport to 12.04?

This is still a pretty major bug for the LTS build - affects a number programs I use every day very intensively - Inkscape, Gnoduino.

Alternatively a decent workaround?

Calorus (calorus) wrote :

Still present in 12.04, can't find backports, any suggestions for solutions?

Many thanks,

J

Charles Kerr (charlesk) wrote :

I don't know if this merits a backport to Precise.

In the meantime, you can get 2.77 for Precise from https://launchpad.net/~transmissionbt/+archive/ppa?field.series_filter=precise

Charles Kerr (charlesk) wrote :

Excuse me, that previous comment was meant for a different ticket :)

linsnux (sidtj) wrote :

What about 12.04 users????

Tom (tom-lorinthe) wrote :

Still present in Inkscape on Ubuntu 12.04 ... this should work on a LTS...

jimjutte (jimjutte) wrote :

Request for OS and environment information:

OS Ubuntu 13.10
Notebook: HP Probook 4416s
Memory 2GB
Processor AMD Athlon II Dual-Core M340 x 2
Graphics Gallium 0.4 on AMD RV710
OS type - 32 bit

Verision of Inkscape - 0.48.4 r9939

Hope that helps

Olivier Girard (eolinwen) wrote :

This bug seems to come from Ubuntu/Unity. For sample, you are not affected when you are using Linux Mint. Anyway, for the next big version (a bug correction 1.4.4 will be out soon) we are going to switch from GTK to Qt. So you shouldn' t have it again.

This bug is resurfaced in 13.10.

OS: Ubuntu 13.10 64bit
Application: Gitg 0.2.7

Zlatan Vasović (zlatan.) wrote :

Also on 13.04 at many programs.

2013/10/23 Atsawin Chaowanakritsanakul <email address hidden>

> This bug is resurfaced in 13.10.
>
> OS: Ubuntu 13.10 64bit
> Application: Gitg 0.2.7
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1194425).
> https://bugs.launchpad.net/bugs/752674
>
> Title:
> GtkRecentChooserMenu always selects first entry
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/indicator-appmenu/+bug/752674/+subscriptions
>

--
Zlatan Vasović - *ZDroid*

ScislaC (scislac) wrote :

Atsawin: Apparently a new module is being used which is why the regression took place. See my report at https://bugs.launchpad.net/unity-gtk-module/+bug/1243974

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.