wingide shows only "options" menu

Reported by Sergey Klimov on 2010-09-22
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Wishlist
Unassigned
indicator-appmenu (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: indicator-appmenu

wingide shows only "options" menu

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: indicator-appmenu 0.0.11-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.32-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Sep 22 15:54:11 2018
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100803.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=ru_UA.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-appmenu

Sergey Klimov (nbdarvin) wrote :
Omer Akram (om26er) wrote :

Just installed wingide and I dont think its gtk or QT app so i'd be tempted to mark this bug as wont fix.

it is PyGTK app

2010/9/22 Omer Akram <email address hidden>

> Just installed wingide and I dont think its gtk or QT app so i'd be
> tempted to mark this bug as wont fix.
>
> --
> wingide shows only "options" menu
> https://bugs.launchpad.net/bugs/645199
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “indicator-appmenu” package in Ubuntu: New
>
> Bug description:
> Binary package hint: indicator-appmenu
>
> wingide shows only "options" menu
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: indicator-appmenu 0.0.11-0ubuntu3
> ProcVersionSignature: Ubuntu 2.6.35-22.32-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Sat Sep 22 15:54:11 2018
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64
> (20100803.1)
> ProcEnviron:
> PATH=(custom, user)
> LANG=ru_UA.UTF-8
> SHELL=/bin/bash
> SourcePackage: indicator-appmenu
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-appmenu/+bug/645199/+subscribe
>

Omer Akram (om26er) wrote :

oops it seems I installed wingware ;)

Sergey Klimov (nbdarvin) wrote :

i think it is wing ide
http://www.wingware.com/

2010/9/22 Omer Akram <email address hidden>

> oops it seems I installed wingware ;)
>
> ** Attachment added: "Screenshot-5.png"
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-appmenu/+bug/645199/+attachment/1622992/+files/Screenshot-5.png
>
> --
> wingide shows only "options" menu
> https://bugs.launchpad.net/bugs/645199
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “indicator-appmenu” package in Ubuntu: New
>
> Bug description:
> Binary package hint: indicator-appmenu
>
> wingide shows only "options" menu
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: indicator-appmenu 0.0.11-0ubuntu3
> ProcVersionSignature: Ubuntu 2.6.35-22.32-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Sat Sep 22 15:54:11 2018
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64
> (20100803.1)
> ProcEnviron:
> PATH=(custom, user)
> LANG=ru_UA.UTF-8
> SHELL=/bin/bash
> SourcePackage: indicator-appmenu
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-appmenu/+bug/645199/+subscribe
>

Sebastien Bacher (seb128) wrote :

thank you for your bug report, where did you get wingide? it doesn't seem to be in ubuntu

Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sergey Klimov (nbdarvin) wrote :

http://www.wingware.com/

2010/11/4 Sebastien Bacher <email address hidden>

> thank you for your bug report, where did you get wingide? it doesn't
> seem to be in ubuntu
>
> ** Changed in: indicator-appmenu (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: indicator-appmenu (Ubuntu)
> Status: New => Incomplete
>
> --
> wingide shows only "options" menu
> https://bugs.launchpad.net/bugs/645199
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “indicator-appmenu” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: indicator-appmenu
>
> wingide shows only "options" menu
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: indicator-appmenu 0.0.11-0ubuntu3
> ProcVersionSignature: Ubuntu 2.6.35-22.32-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Sat Sep 22 15:54:11 2018
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64
> (20100803.1)
> ProcEnviron:
> PATH=(custom, user)
> LANG=ru_UA.UTF-8
> SHELL=/bin/bash
> SourcePackage: indicator-appmenu
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-appmenu/+bug/645199/+subscribe
>

Changed in indicator-appmenu (Ubuntu):
status: Incomplete → Invalid
status: Invalid → New
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in natty?

Changed in indicator-appmenu (Ubuntu):
status: New → Incomplete
Changed in indicator-appmenu:
status: New → Incomplete

In the current version of Natty only a File menu shows up, containing only Close.

dbusmenu-dumper gives:
(dbusmenu-dumper:1896): GLib-GIO-CRITICAL **: g_dbus_proxy_call_sync: assertion `parameters == NULL || g_variant_is_of_type (parameters, G_VARIANT_TYPE_TUPLE)' failed

(dbusmenu-dumper:1896): GLib-CRITICAL **: `so' is not a valid GVariant format string

(dbusmenu-dumper:1896): GLib-CRITICAL **: g_variant_get: assertion `valid_format_string (format_string, TRUE, value)' failed
Segmentation fault (core dumped)

This is with WingIDE 4.0 beta 6.

dbusmenu-dumper on WingIDE 3.2 gives almost the same output:
(dbusmenu-dumper:2127): GLib-GIO-CRITICAL **: g_dbus_proxy_call_sync: assertion `parameters == NULL || g_variant_is_of_type (parameters, G_VARIANT_TYPE_TUPLE)' failed

(dbusmenu-dumper:2127): GLib-CRITICAL **: `so' is not a valid GVariant format string

(dbusmenu-dumper:2127): GLib-CRITICAL **: g_variant_get: assertion `valid_format_string (format_string, TRUE, value)' failed
Segmentation fault (core dumped)

Ted Gould (ted) wrote :

Thanks for responding. Since WingIDE is a proprietary application that seems to be based on it's own toolkit, I don't know that it'll work with the appmenu. There is documentation available if the WingIDE folks would like to implement support. If you're a paying user that finds this to be an issue I'd recommend you talk to their support about it to see if they'd consider it.

Changed in indicator-appmenu:
importance: Undecided → Wishlist
status: Incomplete → Confirmed
Changed in indicator-appmenu (Ubuntu):
status: Incomplete → Confirmed
importance: Low → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers