change theme path while application is running

Bug #607831 reported by Riccardo 'c10ud' on 2010-07-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Application Indicators
Fix Released
Undecided
Unassigned
indicator-application (Ubuntu)
Wishlist
Unassigned

Bug Description

i'd like to change the theme path for the indicator *after* the object initialization (users requested it)

i started some work towards this goal as seen here
https://code.launchpad.net/~c10ud/indicator-application/runtime-themepath-change
but unfortunately i can't get this to work (this is a quick try). if someone could take a look and implement it properly it would be nice.

thanks

Related branches

Riccardo 'c10ud' (c10ud) wrote :

tested with revision 147 in my branch (after pulling sense's) and it works as expected!!

Changed in indicator-application:
status: New → Fix Committed
Sense Egbert Hofstede (sense) wrote :

Setting to Triaged since there is an upstream task available.
A merge request was filed against lp:indicator-application

Changed in indicator-application:
status: Fix Committed → Confirmed
Changed in indicator-application (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Ted Gould (ted) on 2010-08-05
Changed in indicator-application:
status: Confirmed → Fix Committed
milestone: none → 0.2.4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 0.2.4-0ubuntu1

---------------
indicator-application (0.2.4-0ubuntu1) maverick; urgency=low

  * New upstream release.
    * Add in ordering IDs
    * Adding label support into the library
    * Adding label support into the indicator
    * Breaking the ABI in order to get more space in the class
      structure.
    * Allow the icon theme path to be changed dynamically (LP: #607831)
  * debian/control: Moving libappindicator0 to libappindicator1
  * debian/rules: Moving libappindicator0 to libappindicator1
 -- Ted Gould <email address hidden> Thu, 12 Aug 2010 13:57:17 -0500

Changed in indicator-application (Ubuntu):
status: Triaged → Fix Released
Ted Gould (ted) on 2010-08-19
Changed in indicator-application:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers