indicator-application-service crashed with signal 5 in g_type_create_instance()

Bug #1197788 reported by denissius on 2013-07-04
348
This bug affects 60 people
Affects Status Importance Assigned to Milestone
Application Indicators
Fix Committed
High
Unassigned
indicator-application (Ubuntu)
High
Unassigned
Saucy
High
Unassigned

Bug Description

[Impact]
Any users who starts indicator-application with an inaccessible dbus session bus.

[Test case]
Try to start indicator-application-service as a different user than the user currently connected (i.e. sudo -u toto /usr/lib/*/indicator-application-service )
Observe that it does not crash and rather stops gracefully.

[Regression potential]
The service could fail to successfully start even when the bus should be available, in which case it should normally get respawned automatically.

---

indicator-application-service crashed with signal 5 in g_type_create_instance()

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: indicator-application 12.10.1daily13.01.25-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-25.17-lowlatency 3.8.13
Uname: Linux 3.8.0-25-lowlatency i686
ApportVersion: 2.10.2-0ubuntu3
Architecture: i386
Date: Thu Jul 4 16:16:42 2013
ExecutablePath: /usr/lib/i386-linux-gnu/indicator-application-service
MarkForUpload: True
ProcCmdline: /usr/lib/i386-linux-gnu/indicator-application-service
Signal: 5
SourcePackage: indicator-application
StacktraceTop:
 ?? ()
 g_type_create_instance () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_object_newv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: indicator-application-service crashed with signal 5 in g_type_create_instance()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

Related branches

denissius (denissius) wrote :

StacktraceTop:
 application_service_watcher_init (self=0x8a5dcb8) at application-service-watcher.c:161
 g_type_create_instance (type=145135096) at /build/buildd/glib2.0-2.37.3/./gobject/gtype.c:1868
 g_object_new_internal (class=class@entry=0x8a69668, params=params@entry=0x0, n_params=n_params@entry=0) at /build/buildd/glib2.0-2.37.3/./gobject/gobject.c:1743
 g_object_newv (object_type=object_type@entry=145135096, n_parameters=n_parameters@entry=0, parameters=parameters@entry=0x0) at /build/buildd/glib2.0-2.37.3/./gobject/gobject.c:1887
 g_object_new (object_type=145135096, first_property_name=first_property_name@entry=0x0) at /build/buildd/glib2.0-2.37.3/./gobject/gobject.c:1553

Changed in indicator-application (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-application (Ubuntu):
status: New → Confirmed
information type: Private → Public
Sebastien Bacher (seb128) wrote :
Changed in indicator-application:
importance: Undecided → High
Changed in indicator-application (Ubuntu):
importance: Medium → High
Alex Balmus (alx-balmus) wrote :

I do not know how to reproduce this exactly.
I logged out then tried to log-in again.
The login screen was behaving as if the password was being checked and it stayed that way for a few minutes.
I logged in into tty2 and sudo shutdown now
When the system restarted and I logged in again this error showed up.

Charles Kerr (charlesk) on 2013-10-24
Changed in indicator-application:
assignee: nobody → Charles Kerr (charlesk)
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-application at revision None, scheduled for release in indicator-application, milestone Unknown

Changed in indicator-application:
status: In Progress → Fix Committed
Changed in indicator-application (Ubuntu):
status: Confirmed → Fix Committed
Changed in indicator-application:
assignee: Charles Kerr (charlesk) → nobody
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-application/13.10 at revision 241, scheduled for release in indicator-application, milestone Unknown

description: updated
Changed in indicator-application (Ubuntu Saucy):
status: New → Triaged
importance: Undecided → High

Hello denissius, or anyone else affected,

Accepted indicator-application into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/indicator-application/12.10.1+13.10.20131107-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-application (Ubuntu Saucy):
status: Triaged → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

The proposed package fixes this bug. Using the command in the testcase indicator-application-service does not crash but stops gracefully.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 12.10.1+13.10.20131107-0ubuntu1

---------------
indicator-application (12.10.1+13.10.20131107-0ubuntu1) saucy; urgency=low

  [ Charles Kerr ]
  * When we can't get a handle to the system bus, exit gracefully
    instead of crashing. (LP: #1197788)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 241
 -- Ubuntu daily release <email address hidden> Thu, 07 Nov 2013 17:55:46 +0000

Changed in indicator-application (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for indicator-application has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 12.10.1+14.04.20131125-0ubuntu1

---------------
indicator-application (12.10.1+14.04.20131125-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * When we can't get a handle to the system bus, exit gracefully
    instead of crashing. (LP: #1197788)

  [ Ted Gould ]
  * Switch indicator application over to having an upstart job for
    managing the service. Also make it emit it's own event for when
    application indicators should be started so we can clean up the boot
    sequence. (LP: #1185565)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 242
 -- Ubuntu daily release <email address hidden> Mon, 25 Nov 2013 03:55:09 +0000

Changed in indicator-application (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.