Port to gnome-panel 3 and gtk 3

Reported by Devil505 on 2011-02-24
286
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Indicator Applet
Undecided
Ted Gould
Baltix
Undecided
Unassigned
indicator-applet (Debian)
Fix Released
Unknown
indicator-applet (Frugalware Linux)
New
Undecided
Unassigned
indicator-applet (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

could you make indicator-applet compatible with gnome-panel 3.0 at least ?
Thanks

Related branches

lp:~jconti/indicator-applet/gnome3
Merged into lp:indicator-applet/0.5 at revision 392
Lanoxx (community): Approve (code review and test) on 2012-02-08
Ted Gould: Approve on 2012-02-07
Dmitry Shachnev: Pending requested 2012-02-07
Marco Trevisan (Treviño): Pending requested 2012-02-07
Lanoxx (community): Approve (code review and test) on 2012-02-03
Ted Gould: Approve on 2011-11-28
Marco Trevisan (Treviño): Approve on 2011-11-26
Dmitry Shachnev (community): Approve on 2011-11-01
Devil505 (devil505) wrote :
Devil505 (devil505) on 2011-04-16
description: updated
Jeremy Bicha (jbicha) on 2011-08-04
tags: added: regression-release
Changed in indicator-applet (Ubuntu):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

Many people still prefer to use classic panels instead of Unity, so we really need indicators support for Panel 3.

Indicator-applet is already ported to DBus API (see bug 671477), so the only thing that is needed to be done is building with Gtk3.
Also, GtkHBox and GtkVBox are now deprecated, and GtkBox (http://developer.gnome.org/gtk3/3.1/GtkBox.html) should be used instead.

tags: added: gnome3-gtk3
Changed in indicator-applet:
status: New → Confirmed
summary: - port to gnome-panel 3
+ Port to gnome-panel 3 and gtk 3
affects: frugalware → indicator-applet (Frugalware Linux)
Tobias Wolf (towolf) wrote :

There is the Feature Freeze coming up.

Does fixing this, let me call it, regression count against Feature Freeze? If yes, please go ahead and migrate ASAP.

Jeremy Bicha (jbicha) wrote :

No, bugs can be fixed at any time before release.

Russ Dill (russ-dill) wrote :

I'm really confused. I'm using gnome-classic on oneiric. I don't get any audio or power indicator and I don't know to get one. I understand that the indicator applets aren't updated yet, but why are the default gnome ones not working?

Tobias Wolf (towolf) wrote :

Dmitry, do you feel capable of doing this?

Ted wrote me this weeks ago. I suppose he is really busy.

> In Oneiric classic session I have no indicators whatsoever. Is this due
> to indicator-applet package lagging behind a bit in porting efforts?
> Will I be able to use gnome-panel with indicators like appmenu in
> Oneiric still?

In general, we're not trying to drop it but it's not a priority. In
Oneiric the gnome-panel API changes slightly and the indicator-applet
needs to be migrated. I hope to get to fixing it, but I'm not 100% sure
if I will.

                --Ted

I want to do this, but I'm on holidays now and the only Internet
connection here is my phone, so most probably I won't be able to do
this until September. Even if it will be too late, I can use a PPA.

Aleve Sicofante (sicofante) wrote :

I don't quite understand this.

In 11.04, I can use Gnome 2 "Classic" and get indicators in the panel.

Isn't Unity in Oneiric just using indicator-applet under GTK3? Or is Unity under Gnome 3 using a different panel from the Gnome 3 fallback mode? Aren't indicators being maintained for other distros? Do these distros force their users into Gnome Shell, not allowing them to use indicators in fallback mode?

Sorry for the many questions. I'm trying to understand why indicators wouldn't work in Gnome 3 fallback panels.

Dmitry Shachnev (mitya57) wrote :

> Or is Unity under Gnome 3 using a different panel from the Gnome 3 fallback mode?
Yes, it is. Unity uses its own panel.

> Aren't indicators being maintained for other distros?
Indicators are development of Ubuntu, but some other distros have them
packaged. However, they don't develop them.

Dmitry Shachnev (mitya57) wrote :

@Ted: If you already have the working code, can you please package it to a PPA to that we could test it?

Changed in indicator-applet:
status: Confirmed → In Progress
Tobias Wolf (towolf) wrote :

So, I’ve compiled Ted’s branch from source and had to move around the .panel-applet files because they were being put into the old directory. After that I could add the indicators to the panel but they only displayed "No indicators" and when running the indicators from the terminal they refused loading with "No watchers".

I guess this needs more work still?

Tobias Wolf (towolf) wrote :

So much for that. Bug 829491.

Changed in indicator-applet:
assignee: nobody → Ted Gould (ted)
Sebastien Bacher (seb128) wrote :

there is a test package to try in https://launchpad.net/~ted/+archive/indicator-applet-gtk3 for those who want to try it

Attila Hammer (hammera) wrote :

Hy,

Sebastien, I welcome try testing Ted doed test package with Oneiric in
gnome-fallback session, but I have got some questions:
I installed the indicator-applet and indicator-applet-complete packages
from Ted linked PPA, but the indicator related applets doesn't
presenting the Add the panel dialog.
How can possible add new indicator-applet with the list?

I using Oneiric GNOME Fallback session with Orca. Possible access the
new GTK3 indicator applet with a key combination? I think Natty
implemented Indicator applet is possible access if I use SUPER+S key
combination in GNOME Classic session.

Attila

Jeremy Bicha (jbicha) wrote :

I got a little bit closer by moving /usr/share/gnome-panel/applets/* to /usr/share/gnome-panel/4.0/applets/ but adding the indicators to the panel only results in a white-outlined rectangle that says No Indicators. Right-clicking on it shows the About window so at least that works...

Attila Hammer (hammera) wrote :

Jeremy, I see similar result when doed your steps.
If I press ENTER key with the Indicator applet, nothing happening.
If I using application key my keyboard, I see only the About menu item.

Attila

Jahrome (jahrome) wrote :

Same as Jeremy : No Indicators shows in the panel applet.

Filip Milivojevic (zekica) wrote :

Any news about this? I have the same issue as Jeremy.

Ted how about porting indicator-applet-appmenu and including it in your ppa?
 Does this need a separate bug report?

Changed in indicator-applet (Debian):
status: Unknown → New
Ted Gould (ted) wrote :

On Fri, 2011-10-14 at 20:09 +0000, Daniel Weinstein wrote:
> Ted how about porting indicator-applet-appmenu and including it in your ppa?
> Does this need a separate bug report?

Indicator applet builds all the different versions of it. So that
binary package is there as well. But, it seems from the reporters that
it doesn't work. I haven't had time to look into that.

Alex Cabal (acabal) wrote :

I'm unable to add indicators to the panel from the package in the PPA. There isn't an indicator applet shown in the 'add panel' dialog.

This would be great to have because while there is a notification area in gnome-fallback, it doesn't seem to be themed quite right. The icons are very close together and all different sizes, so they're hard to manipulate. Having the indicators back would put me back in a 99% Gnome-2-ish environment which would make me very happy.

Tobias Wolf (towolf) wrote :

On Di, 2011-10-18 at 21:39 +0000, Ted Gould wrote:
> On Fri, 2011-10-14 at 20:09 +0000, Daniel Weinstein wrote:
> > Ted how about porting indicator-applet-appmenu and including it in your ppa?
> > Does this need a separate bug report?
>
> Indicator applet builds all the different versions of it. So that
> binary package is there as well. But, it seems from the reporters that
> it doesn't work. I haven't had time to look into that.

This bug was filed 8 months ago.

Changed in indicator-applet (Debian):
status: New → Confirmed
György Balló (ballogy) wrote :

There is available an another GNOME 3 port: lp:~jconti/indicator-applet/gnome3

I'm using this branch on Arch Linux, and it works well. Indicat-appmenu works too. I think it's stable enough to make a release from this branch.

Dmitry Shachnev (mitya57) wrote :

@ György: Thanks!
Jason has also created a PPA (ppa:jconti/gnome3), the package is currently waiting to build.

There's a problem with positioning - it's actually a problem in indicator-session, I reported it as bug 881832 (with fix attached).

Chris Billington (cjbil1) wrote :

Thanks guys, it's working great! I'm able to build and add to the panel as normal. Didn't think I'd be saying this so soon, but I dare say that with an indicator applet, gnome-panel 3 is a viable option for those that want to use Ubuntu but aren't keen on Unity or Gnome Shell.

Attila Hammer (hammera) wrote :

This ppa awailable package is wonderful, if this is possible, please
awailable this version with oneric-updates or next Precise related
repository.
I added simple my system the ppa:jconti/gnome3 repository, and install
the indicator-applet-complete package.
After I added my top panel the applet, I access every indicators with
keyboard without any problem if I press Super+S keystroke. So, wonderful
this port.
I found some issues for A11y related when I using this applet with Orca
Screen Reader:
Some main categories not have textual descriptions, only have icons
without I think tooltips. This situation Orca Screen Reader says me only
the "menu" role name.
I think have similar issues with Unity related indicators.
In next version development A11Y related milestones have following text
part:
" * Making sure all indicators have accessible descriptions/labels.
  * Making sure any icons in indicator menus that need accessible
descriptions/labels"
I read this with following link:
https://blueprints.launchpad.net/ubuntu/+spec/desktop-p-accessibility-polish

Attila

Gall (agalakhov) wrote :

It works great, thanks! I had to fix paths to indicators and installation paths, please look at the attached patch.

The attachment "Fix paths for new libraries" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

I installed the ppa:jconti/gnome3 awailable indicator-applet-complete
package my Precise system without any problem, of course now I need
changed the distribution branch with Oneiric in the PPA sources list
file the /etc/apt/sources.list.d directory.
Officialy when will be land this GNOME3 ported indicator-applet related
packages in Precise?

Attila

Dmitry Shachnev (mitya57) wrote :

Fixed in indicator-applet 0.4.90. Package uploaded to precise, but I didn't test it yet, so keeping open for now.

Changed in indicator-applet:
status: In Progress → Fix Released
Dmitry Shachnev (mitya57) wrote :

This bug was fixed in package indicator-applet - 0.4.90-0ubuntu1

---------------
indicator-applet (0.4.90-0ubuntu1) precise; urgency=low

  [ Ted Gould ]
  * New upstream release.
    * Switch to work with GNOME3 Panel (LP: #829491)
  * debian/control: Adjusting depends to match new panel reality
  * debian/*install: Updating GNOME Panel applet install directory

  [ Ken VanDine ]
  * debian/control
    * dropped recommends for indicator-me
  * debian/rules
    * removed simple-patchsys.mk
 -- Ken VanDine <e-mail address hidden> Wed, 08 Feb 2012 10:45:27 -0500

Changed in indicator-applet (Ubuntu):
status: Confirmed → Fix Released
Alin Andrei (nilarimogard) wrote :

Hmm I think the package is waiting in the "new" queue. If you boot Precise, you won't find the package in the repositories... yet.

Bryce Harrington (bryce) wrote :

May have been waiting on a buildd. In any case it's available now. Just installed it, and it looks good.

Alin Andrei (nilarimogard) wrote :

Never mind, it works now.

Changed in indicator-applet (Debian):
status: Confirmed → Fix Released
Tomas Roos (ptomasroos) wrote :

It doesnt work with 24 hour format. Should it ?

Dmitry Shachnev (mitya57) wrote :

@Tomas Roos: indicator-datetime supports 24h format (of course) and it behaves the same way under Unity and Gnome Panel. Please report all bugs to "indicator-datetime" package.

hawthornso23 (hawthorn) wrote :

The port doesn't respect panel transparency which is an annoying papercut for those of us using gnome-fallback. The version ported by jconti DID manage to respect panel transparency.

Dmitry Shachnev (mitya57) wrote :

hawthornso23: This is a regression in Gtk 3.4, see
https://bugs.launchpad.net/gtk/+bug/966697.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.