Packaging omits inception.utils

Bug #1210180 reported by Andrew Forrest on 2013-08-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inception
Low
Andrew Forrest

Bug Description

The inception tool requires inception.utils to be present but does not include it in its distribution package.

Andrew Forrest (forrest-r) wrote :

Or use setuptools' find_packages() instead of a hard-coded list. See https://bugs.launchpad.net/inception/+bug/1210181 for why this reliance on a feature of setuptools is not "bad".

Changed in inception:
assignee: nobody → Andrew Forrest (forrest-r)
Changbin Liu (changbl) on 2013-08-28
Changed in inception:
importance: Undecided → Low
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/44121

Changed in inception:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/44121
Committed: http://github.com/stackforge/inception/commit/911969985faa66f591dd3680a20d93088b56e6a7
Submitter: Jenkins
Branch: master

commit 911969985faa66f591dd3680a20d93088b56e6a7
Author: Andrew Forrest <email address hidden>
Date: Wed Aug 28 11:18:12 2013 -0700

    Adds inception.utils to inception package.

    Previously inception.utils was overlooked for packaging.

    Note: the use of setuptools' "find_packages()" might appear to be
    a poor choice since this setup.py is written to fall back to using
    distutils which doesn't have a find_packages but in fact it cannot
    usefully fall back to distutils anyway (see bug #1210181) so it is
    not an issue.

    Change-Id: I31b2b5f3952df0b8ecd0bc59f9978cf0bb9f03e5
    Fixes: bug #1210180

Changed in inception:
status: In Progress → Fix Committed
Changbin Liu (changbl) on 2013-09-18
Changed in inception:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers