format does not detect too-many-arguments

Bug #176519 reported by Abdulaziz Ghuloum on 2007-12-15
6
Affects Status Importance Assigned to Milestone
Ikarus Scheme
Medium
Abdulaziz Ghuloum

Bug Description

I.e. should this raise an exception:
> (format "blah" 123)

Systems I tried which do detect too many arguments:
MzScheme
Petite Chez
SRFI-28: Basic Format Strings

Systems I tried which do not:
Larceny

Abdulaziz Ghuloum (aghuloum) wrote :

Yes it should.

Changed in ikarus:
assignee: nobody → aghuloum
importance: Undecided → Medium
status: New → Confirmed
Abdulaziz Ghuloum (aghuloum) wrote :

Fixed in revision 1247. I wonder if people have any problems with displaying unicode characters in their terminals?

> (format "blah" 123)
Unhandled exception
 Condition components:
   1. &error
   2. &who: format
   3. &message: "extra arguments given for format string ‶blah″"

Changed in ikarus:
status: Confirmed → Fix Committed
Abdulaziz Ghuloum (aghuloum) wrote :

BTW: larceny is not an example to be followed in terms of usability. For ikarus, we might still get a few of those but want to weed all of them out.

Larceny v0.95 "First Safety"
> (format (current-output-port) "foo ~s" )
foo

Error: car: () is not a pair.

(This is not a bug specific to larceny's format--it's present in almost every single primitive in larceny):
> (max 'foo)
Error: exact?: foo is not a number.
> (expt "hello" 13)
Error: zero?: hello is not a number.

Abdulaziz Ghuloum (aghuloum) wrote :

This bug report is about to be closed as the fix comitted
previously will be incorporated in the next 0.0.3 release of
Ikarus Scheme, scheduled for January 31, 2008. A release
candidate tarball is available for download from:
http://www.cs.indiana.edu/~aghuloum/ikarus/ikarus-0.0.3-rc1.tar.gz
Please do test it if you have the time and report any issues
you might encounter. Thank you very much for your support.
(Sorry for the duplicates; I'm updating every open bug.)

Changed in ikarus:
milestone: none → 0.0.3
Changed in ikarus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions