ikarus-0.0.2.tar.gz: cygwin: ikarus.boot not created

Bug #173467 reported by Jamie Raymond on 2007-12-02
2
Affects Status Importance Assigned to Milestone
Ikarus Scheme
High
Abdulaziz Ghuloum

Bug Description

"make install" fails because ikarus.boot is not created. Here is a relevant snip
during the make process. The execution of makefile.ss leaves no traces to
try to debug why it's not being created.

make[2]: Leaving directory `/home/raymond/ikarus-0.0.2/src'
Making all in scheme
make[2]: Entering directory `/home/raymond/ikarus-0.0.2/scheme'
../src/ikarus -b ./ikarus.boot.prebuilt --r6rs-script makefile.ss
make[2]: Leaving directory `/home/raymond/ikarus-0.0.2/scheme'
Making all in doc
make[2]: Entering directory `/home/raymond/ikarus-0.0.2/doc'
make[2]: Nothing to be done for `all'.

Michael D. Adams (mdmkolbe) wrote :

Are you sure your processor supports SSE2? I've see this sort of error in that case. It is caused by an illegal instruction exception from the CPU that doesn't get directly reported for some reason in Cygwin. Try running "../src/ikarus -b ./ikarus.boot.prebuilt --r6rs-script makefile.ss" as that will sometimes get the exception printed (sometimes).

That would explain it. I'm compiling on a P3-M.
-J

On Dec 2, 2007 10:34 AM, Michael D. Adams <email address hidden> wrote:
> Are you sure your processor supports SSE2? I've see this sort of error
> in that case. It is caused by an illegal instruction exception from the
> CPU that doesn't get directly reported for some reason in Cygwin. Try
> running "../src/ikarus -b ./ikarus.boot.prebuilt --r6rs-script
> makefile.ss" as that will sometimes get the exception printed
> (sometimes).
>
>
> --
> ikarus-0.0.2.tar.gz: cygwin: ikarus.boot not created
> https://bugs.launchpad.net/bugs/173467
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Michael D. Adams (mdmkolbe) wrote :

I'm on the fence bout this one, but it may be worth while to put a check in either configure or the startup of ikarus to verify that the CPU supports SSE2. This can be done by running the CPUID instruction and looking at the 26'th bit of edx. Putting it in configure has the advantage of only paying the cost once, but putting it in the ikarus startup has the advantage of working for binary distributions.

Abdulaziz Ghuloum (aghuloum) wrote :

> but it may be worth while to put a check in either configure or the startup of ikarus to verify that the CPU supports SSE2.

OK!

Changed in ikarus:
assignee: nobody → aghuloum
importance: Undecided → High
status: New → Confirmed
Abdulaziz Ghuloum (aghuloum) wrote :

Added runtime SSE2 check in revision 1176. It's only done once so runtime code is 0.

Changed in ikarus:
status: Confirmed → Fix Committed
Abdulaziz Ghuloum (aghuloum) wrote :

This bug report is about to be closed as the fix comitted
previously will be incorporated in the next 0.0.3 release of
Ikarus Scheme, scheduled for January 31, 2008. A release
candidate tarball is available for download from:
http://www.cs.indiana.edu/~aghuloum/ikarus/ikarus-0.0.3-rc1.tar.gz
Please do test it if you have the time and report any issues
you might encounter. Thank you very much for your support.
(Sorry for the duplicates; I'm updating every open bug.)

Changed in ikarus:
milestone: none → 0.0.3
Changed in ikarus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers