Odd huge memory jump when running this

Bug #163540 reported by Derick Eddington on 2007-11-18
2
Affects Status Importance Assigned to Milestone
Ikarus Scheme
High
Abdulaziz Ghuloum

Bug Description

When I run the below, memory use stays constant until it reaches 540000000, then its memory use skyrockets and uses all RAM and keeps going into swap, then I Ctr-C and the memory stays allocated, then I can do (collect) and memory drops back down to initial startup size.

My computer is:
Intel(R) Pentium(R) M processor 1.60GHz
MemTotal: 507736 kB
Ubuntu 7.04
Linux eep 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux

[d@eep:~]-> ikarus
Ikarus Scheme (Build 2007-11-18)
Copyright (c) 2006-2007 Abdulaziz Ghuloum

> (do ([i 0 (+ 1 i)])
      [(= i 1000000000)
       (display "done\n")]
      (when (= 0 (modulo i 10000000))
        (display i) (newline)))
0
10000000
20000000
...omitted...
540000000
550000000
Unhandled exception
 Condition components:
   1. &interrupted
   2. &message: "received an interrupt signal"
> (collect)

Abdulaziz Ghuloum (aghuloum) wrote :

I know exactly what's causing this. Will fix. Thanks.

Changed in ikarus:
assignee: nobody → aghuloum
importance: Undecided → High
status: New → Confirmed
Abdulaziz Ghuloum (aghuloum) wrote :

The following program, btw, does not exhibit the problem you mention (because it allocates something outside of the bignum arithmetic code).

(do ([i 0 (+ 1 i)]
     [t 0 (cons 0 0)])
     [(= i 1000000000)
      (display "done\n")]
    (when (= 0 (modulo i 10000000))
      (display i) (newline)))

Abdulaziz Ghuloum (aghuloum) wrote :

Fixed in revision 1076. You can get the latest revision from the master repository by doing
$ bzr checkout http://www.cs.indiana.edu/~aghuloum/ikarus.dev
Thanks for submitting the bug report.

Changed in ikarus:
status: Confirmed → Fix Committed

On Nov 18, 2007, at 10:42 AM, Abdulaziz Ghuloum wrote:

> $ bzr checkout http://www.cs.indiana.edu/~aghuloum/ikarus.dev

make that a "checkout --lightweight" if you don't want all 600MBs of
data.

Aziz,,,

Abdulaziz Ghuloum (aghuloum) wrote :

This bug report is about to be closed as the fix comitted previously
will be incorporated in the next 0.0.2 release of Ikarus Scheme,
scheduled for November 28, 2007.
A release candidate tarball is available for download from:
  http://www.cs.indiana.edu/~aghuloum/ikarus/ikarus-0.0.2-rc1.tar.gz
Please do test it if you have the time and report any issues you
might encounter. Thank you very much for your support. Aziz,,,
(Sorry for the duplicates; I'm updating every open bug.)

Changed in ikarus:
milestone: none → 0.0.2
Changed in ikarus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers