put-u8

Bug #163031 reported by Michael D. Adams on 2007-11-16
4
Affects Status Importance Assigned to Milestone
Ikarus Scheme
High
Abdulaziz Ghuloum

Bug Description

I was porting some code that used ikarus' write-byte to pure R6RS. The only equivalent function I found was put-u8, but that reports itself as not supported yet. For now I'm using (write-char (integer->char x)).

Abdulaziz Ghuloum (aghuloum) wrote :

Ikarus has a "write-byte" procedure that does the same thing. It will be renamed to put-u8. I suggest you use that now until I do the ranaming.

Changed in ikarus:
assignee: nobody → aghuloum
importance: Undecided → High
status: New → Confirmed
Abdulaziz Ghuloum (aghuloum) wrote :

Fixed in revision 1077. "write-byte" was not removed because its second argument is optional and defaults to the current-output-port, while put-u8 requires a second argument.

Changed in ikarus:
status: Confirmed → Fix Committed
Abdulaziz Ghuloum (aghuloum) wrote :

This bug report is about to be closed as the fix comitted previously
will be incorporated in the next 0.0.2 release of Ikarus Scheme,
scheduled for November 28, 2007.
A release candidate tarball is available for download from:
  http://www.cs.indiana.edu/~aghuloum/ikarus/ikarus-0.0.2-rc1.tar.gz
Please do test it if you have the time and report any issues you
might encounter. Thank you very much for your support. Aziz,,,
(Sorry for the duplicates; I'm updating every open bug.)

Changed in ikarus:
milestone: none → 0.0.2
Tom Gordon (tom-gordon) wrote :

In 0.0.2-rc1 put-u8 is now available and seems to work, but the order of its arguments is reversed, compared to the R6RS standard. It should be (put-u8 <port> <octet>).

Abdulaziz Ghuloum (aghuloum) wrote :

Thanks, put-char also exhibited the same thing. Now fixed in revision 1132.
I guess I got confused since write-char takes a char then a port, but put-char takes a port then a char!

Abdulaziz Ghuloum (aghuloum) wrote :

I would blame this on Michael since he's the one who asked for put-u8 :-)

Changed in ikarus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers