community dendrogram plotting error

Reported by Andrew Edelman on 2011-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
igraph
Fix Released
High
Gábor Csárdi

Bug Description

When plotting a dendrogram from the edge.betweenness.community function I get the following error (R version 0.6):

> ebc <- edge.betweenness.community(g)
> dend <- as.dendrogram(ebc)
> plot(dend)
Error in text.default(X, Y, nodeText, xpd = TRUE, srt = srt, adj = adj, :
  zero length 'labels'

This appears to be due to the ordering of the leaves beginning at 0 instead of 1.

Changed in igraph:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Gábor Csárdi (gabor.csardi)
Gábor Csárdi (gabor.csardi) wrote :

This works fine with the 0.6 version now.

Changed in igraph:
status: Confirmed → Fix Released

The development of igraph has moved to github, so please do not comment on this bug here. You are of course welcome to comment on github, here:
https://github.com/igraph/igraph/issues/89

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers