Many APKs, tools and games, do not start or work as intended

Bug #988211 reported by Patrik Klinger
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IglooCommunity
Confirmed
Low
Unassigned
Linaro Android
Won't Fix
Undecided
Unassigned

Bug Description

During generics validation and test activities it has been noticed that many APKs after being installed does not start or work as intended.

*Steps*
1. Flash the 2012.04 Android distribution to you hardware. A Snowball A9500 has been used during these validation activities.
2. Install the following APKS to you device using ADB.
 a. Asphalt (Game)
 b. Fruit ninja Free (Game)
 c. Helidroid 3D (Game)
 d. Reckless Racing (Game)
 e. Google Earth (Tool)
 f. Youtube (Tools)
3. Try to execute each one of these APKs.

*Results*

*Asphalt*
NOK. Starts but crashes on load during gameloft advert screen.

*Fruit ninja Free*

NOK. Crashes with message “Unfortunately, Fruit Ninja Free has stopped.”
Log message; “[ 1933.046447] Mali<2>: Memory Engine Allocate: Partial allocation on Mali SDRAM, resorting to Linux kernel memory“

*Helidroid 3D*
NOK. Error message is displayed “Sorry, but you have not the good version of Opengl (Minimum required:1.1). Sound works.

*Reckless Racing*
NOK. Crashes with message “Unfortunately, Reckless Racing has stopped.”

*Youtube*
NOK. Starts OK. Error message “There was a problem starting up. Please check your network connection and system time”

Changed in igloocommunity:
assignee: nobody → Sunil Kamath (sunil-kamath)
status: New → Confirmed
Changed in igloocommunity:
milestone: none → 2012.06
Revision history for this message
Amit Pundir (pundiramit) wrote :

Some applications use Android OpenGL ES APIs instead of standard (Khronos) OpenGL ES APIs to query the OpenGL ES version(s) supported by the target. This may be true for *Helidroid 3D*.

Try running following command from Android shell before starting Helidroid:

# setprop ro.opengles.version=65536

FYI:
For OpenGL ES 2.0, set:
ro.opengles.version=131072

For OpenGL ES 1.1, set:
ro.opengles.version=65536

For OpenGL ES 1.0, set:
ro.opengles.version=65535

Changed in igloocommunity:
milestone: 2012.06 → 2012.07
Changed in igloocommunity:
milestone: 2012.07 → 2012.08
tags: added: snowball-linaro
Changed in igloocommunity:
importance: Critical → Medium
Changed in igloocommunity:
assignee: Sunil Kamath (sunil-kamath) → nobody
importance: Medium → Low
milestone: 2012.08 → none
Revision history for this message
vishal (vishalbhoj) wrote :

snowball is no more supported.

Changed in linaro-android:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers