IglooCommunity Launchpad Project

USB OTG not properly functioning

Reported by Oliver Fogden on 2012-03-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
IglooCommunity
High
supriya karanth

Bug Description

Description:
==========
 - Snowball is unable to use a USB device until it is unplugged, and plugged in again.
 - Snowball is unable to use several usb devices, including webcam

Reproducible:
===========
Yes (5/5 times)

Steps:
==========
1. Plug in USB device
2. Bootup DUT

Hardware:
==========
Snowball: V10
HDMI Out to TV - via HDMI cable
USB-Serial Logging
USB Device via OTG

Changed in igloocommunity:
importance: Undecided → High
Changed in igloocommunity:
assignee: nobody → supriya karanth (supriya-karanth)
Changed in igloocommunity:
milestone: none → 2012.04
Oliver Fogden (ofog) wrote :

"Snowball is unable to use a USB device until it is unplugged, and plugged in again" is seemingly fixed in the 02.12 ubuntu release.

Webcam bug is still present. See https://bugs.launchpad.net/igloocommunity/+bug/969231

Changed in igloocommunity:
status: New → Confirmed
Anmar Oueja (anmar) on 2012-04-09
Changed in igloocommunity:
status: Confirmed → In Progress
Jayeeta Bandyopadhyay (jayeeta) wrote :

Supriya can you pls update the status?

This needs to be tested with the stable-android-ux500-3.3-1 which has fixes for USB link status issues.

Sunil Kamath (sunil-kamath) wrote :

Supriya,
We understand that patch with current kernel is not stable, hence you are waiting for 3.3-1 kernel to fix it properly.
But please attach current patch here for reference.

Changed in igloocommunity:
milestone: 2012.04 → 2012.05
Anmar Oueja (anmar) wrote :

Supriya: Pleas attach the patch to this bug.

This bug is related to connect and boot problems in snowball and not to the SW workaround for providing vbus externally. The SW patch will be directly attached here http://igloocommunity.org/support/Work-around_for_USB-Host_issue

Anmar Oueja (anmar) wrote :

To be tested with stable-android-ux500-3.3-1 tomorrow

This needs the init script change from

#965181 next IK 3.3: Change in init scripts for latest ST-E USB driver support

Working after changes made in 965181

Changed in igloocommunity:
status: In Progress → Fix Released
Anmar Oueja (anmar) on 2012-05-22
Changed in igloocommunity:
status: Fix Released → Fix Committed
Changed in igloocommunity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers