android: kernel 3.3 doesn't come out of hibernation

Bug #949367 reported by Mathieu Poirier on 2012-03-07
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IglooCommunity
High
NaveenKumar Gaddipati

Bug Description

Board: v11(sdk)
Build: https://android-build.linaro.org/builds/~linaro-android/snowball-ics-gcc46-igloo-stable-blob/#build=192

On android the 3.3 kernel can't be taken out of hibernation by either pressing the blue botton or providing mouse input. The serial console is also unresponsive. No ouput can be captured.

description: updated
Changed in igloocommunity:
assignee: Thomas Espersson (espersson) → Jayeeta Bandyopadhyay (jayeeta)
importance: Undecided → High
Changed in igloocommunity:
milestone: none → 2012.03
Changed in igloocommunity:
assignee: Jayeeta Bandyopadhyay (jayeeta) → NaveenKumar Gaddipati (naveen-gaddipati)

We are able to reporduce the issue with the latest integration kernel.

Changed in igloocommunity:
status: New → Confirmed

Using the patch sent for Pl011 driver.Log as follows
[ 1775.125976] request_suspend_state: sleep (0->3) at 465708636946 (2000-01-23 20:4
4:52.297472508 UTC)
[ 1775.809844] PM: Syncing filesystems ... done.
[ 1775.816162] Freezing user space processes ... (elapsed 0.02 seconds) done.
[ 1775.850219] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
[ 1775.955200] PM: suspend of devices complete after 83.892 msecs
[ 1775.961120] suspend_set_state: ab8500-ext-supply3: No configuration
[ 1775.967407] suspend_set_state: ab8500-ext-supply2: No configuration
[ 1775.973693] suspend_set_state: ab8500-ext-supply1: No configuration
[ 1775.981201] PM: late suspend of devices complete after 1.159 msecs
[ 1775.991210] Disabling non-boot CPUs ...
[ 1776.006103] CPU1: shutdown
[ 1776.006103] CPU1: shutdown
[ 2364.769653] wakeup wake lock: event1-1670
[ 2364.778259] PM: early resume of devices complete after 0.976 msecs
[ 2364.884277] dpm_run_callback(): platform_pm_resume+0x0/0x60 returns -5
[ 2364.890808] PM: Device smsc911x.0 failed to resume: error -5
[ 2364.927062] PM: resume of devices complete after 141.475 msecs
[ 2364.933227] Restarting tasks ...
[ 2364.948120] request_suspend_state: wakeup (3->0) at 466774292270 (2000-01-23 20:54:42.023116415 U
TC)
[ 2364.966491] done.
[ 2364.981201] suspend: exit suspend, ret = 0 (2000-01-23 20:54:42.056170893 UTC)
[ 2364.989624] Enabling non-boot CPUs ...
[ 2365.022003] abx500-acc-det ab8500-acc-det.0: Accessory: HEADPHONE
[ 2365.044067] CPU1: Booted secondary processor
[ 2365.044128] CPU1: Unknown IPI message 0x1
[ 2365.044189] CPU1 is up

Changed in igloocommunity:
status: Confirmed → In Progress

This is an woraround to fix without allowing the system togo into sleep.
We need to implement proper sudpend and resume functionality for all the drivers

Changed in igloocommunity:
status: In Progress → Fix Committed
Anmar Oueja (anmar) wrote :

Naveen: Can you please file a bug to capture the requirements of the real fix.

Changed in igloocommunity:
milestone: 2012.03 → 2012.04.alpha-1

The patch was integrated in alpha release.We are not able to reproduce the issue using the ubuntu 3.3 release with the patch given for alpha release

Changed in igloocommunity:
milestone: 2012.04.alpha-1 → 2012.04

On Android release:
https://android-build.linaro.org/builds/~linaro-android/snowball-ics-gcc46-igloo-stable-blob-12.04-release/#build=6

I do not see device going into suspend mode.
Logs never show: "request_suspend_state" , "Freezing user space processes"
Also,
After display timeout -> display does not dims/or turns OFF.

I think we prevented suspend altogether. Sunil will know more about this.

Sunil Kamath (sunil-kamath) wrote :

Yes, currently Suspend/Resume is disabled. This is because some of the dependency from drivers that need to be solved.

we have issue ongoing for this:
https://bugs.launchpad.net/igloocommunity/+bug/974123
https://bugs.launchpad.net/igloocommunity/+bug/980649

Changed in igloocommunity:
status: Fix Committed → Fix Released
Amit Khare (amit-khare) wrote :

snowball never goes into suspend mode even after waiting 3-4 minutes.
https://android-build.linaro.org/builds/~linaro-android/snowball-jb-gcc47-igloo-stable-blob/#build=36

Amit Khare (amit-khare) wrote :

Observed with snowball android JB build.
https://android-build.linaro.org/builds/~linaro-android/snowball-jb-gcc47-igloo-stable-blob/#build=54

Changed Display settings to 15 sec. Snowball board never goes to suspend mode even after waiting for 10 mins.

Amit Khare (amit-khare) wrote :

Observed with snowball android JB build.
https://android-build.linaro.org/builds/~linaro-android/snowball-jb-gcc47-igloo-stable-blob/#build=58

Changed Display settings to 15 sec. Snowball board never goes to suspend mode even after waiting for 10 mins.

Amit Khare (amit-khare) wrote :

also Observed with Snowball JB Android 12.09 release build
https://android-build.linaro.org/builds/~linaro-android/snowball-jb-gcc47-igloo-stable-blob-12.09-release/#build=5

Changed Display settings to 15 sec. Snowball board never goes to suspend mode even after waiting for 10 mins.

Amit Khare (amit-khare) wrote :

Observed with Snowball JB Android build
https://android-build.linaro.org/builds/~linaro-android/snowball-jb-gcc47-igloo-stable-blob/#build=79

kernel version - 3.4.0+
Changed Display settings to 15 sec. Snowball board never goes to suspend mode even after waiting for 10 mins.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers