IglooCommunity Launchpad Project

IK 3.3 - Audio doesn't work

Reported by Anmar Oueja on 2012-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IglooCommunity
Critical
Ramesh Chandrasekaran

Bug Description

This is a regression.

Error: "ux500_ab8500_power_control_inc: ERROR: Setting master-clock to SYSCLK failed (ret = -22)"

First analysis:
This is due to a bad ASoC initialization, ux500_ab8500_machine_codec_init() is not called during ASoC probing after u8500_soc_init() call.

tags: added: kernel multimedia

This is the Igloo Kernel issue. So need to be fixed by kernel team

Anmar Oueja (anmar) on 2012-03-02
tags: removed: multimedia
Changed in igloocommunity:
assignee: Thomas Espersson (espersson) → NaveenKumar Gaddipati (naveen-gaddipati)
milestone: none → 2012.03
Anmar Oueja (anmar) on 2012-03-05
Changed in igloocommunity:
importance: Undecided → Critical

From the kalle Analysis, issue is because of SOC configuration is not enabled.
Is the issue present on Android ICS or Ubuntu image?
If it is in android, Raghavendra has modified the kernel 3.0 which makes audio up.

This issue is present on all 3.3 Igloo Kernels, an Ubuntu image is enough
to test it with alsa-utils.
The problem is in kernel alsa driver.

BR,
Philippe

On 7 March 2012 11:33, NaveenKumar Gaddipati <
<email address hidden>> wrote:

> >From the kalle Analysis, issue is because of SOC configuration is not
> enabled.
> Is the issue present on Android ICS or Ubuntu image?
> If it is in android, Raghavendra has modified the kernel 3.0 which makes
> audio up.
>
> --
> You received this bug notification because you are a member of
> IglooCommunity Maintainers, which is subscribed to IglooCommunity.
> https://bugs.launchpad.net/bugs/942815
>
> Title:
> IK 3.3 - Audio doesn't work
>
> Status in IglooCommunity Launchpad Project:
> New
>
> Bug description:
> This is a regression.
>
> Error: "ux500_ab8500_power_control_inc: ERROR: Setting master-clock to
> SYSCLK failed (ret = -22)"
>
> First analysis:
> This is due to a bad ASoC initialization,
> ux500_ab8500_machine_codec_init() is not called during ASoC probing after
> u8500_soc_init() call.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/igloocommunity/+bug/942815/+subscriptions
>

Anmar Oueja (anmar) wrote :

Jayeeta to assign to an alternative individual

Changed in igloocommunity:
assignee: NaveenKumar Gaddipati (naveen-gaddipati) → Ramesh Chandrasekaran (ramesh-chandrasekaran)
Thomas Espersson (espersson) wrote :

Comments from Audio expert:
- check that CONFIG_SND_SOC_UX500_AB8500 is set

The kernel config, CONFIG_STM_MSP_SPI is unset in the kernel configs. Since i believe, we are using MSP interfaces to the AB8500 for audio , i think this needs to be enabled. When, enabled, i could see, the ALSA devices, detecting the sound card. Able to invoke alsamixer without any error, where i can set master clock to sysclk options without error. aplay(alsaplay doesn't give any errors) while invoked to play wav files. But still couldn't hear any audio from the board... Do we have any working old versions of GLK or Ubuntu where we have audio working other than android ? Is there any vendor specific audio codec binaries required on ubuntu for the audio to work ? I am giving a try on android, but due to some other bugs, we could not boot the android successfully, with our latest 3.3 kernel...(but the bootlogs says, the audio codecs are intialized fine).

The kernel config CONFIG_STM_MSP_SPI, needs to be enabled to fix this issue, since this initializes the MSP interface and all audio related codecs. Once done, ALSA driver, detects the sound card as kernel boots up and in the rootfs prompt invoke aplay with a wav file, as shown below

aplay -D hw:0,1 xyz.wav for testing.

Lookout for a patch soon !

Changed in igloocommunity:
status: New → In Progress
Anmar Oueja (anmar) wrote :

Great work Ramesh :-)

Thomas Espersson (espersson) wrote :

Ramesh, is the patch available yet?

Patch is submitted & reviewed successfully. Will be included in the next release.

Changed in igloocommunity:
status: In Progress → Fix Committed
Changed in igloocommunity:
milestone: 2012.03 → 2012.04.alpha-1
Anmar Oueja (anmar) on 2012-03-29
Changed in igloocommunity:
status: Fix Committed → In Progress
Anmar Oueja (anmar) wrote :

I tagged it as "in progress" as I assume you moved it to the 2012.04.Alpha-1 because audio is still broken.

The alsamixer settings needs to be,

  Digital Interface DA2 slot map --> must be changed from slot8 to slot 11.
  Headset left --> must be changed from disabled to enabled.
  Headset right --> must be changed from disabled to enabled.

All the below gain value must be set to reasonable (volume) to hear the sound.

Headset Digital Gain
Headset Gain
Headset Master Gain

Changing this in alsamixer settings will make the audio work.

In the latest ubuntu sd image ( 29th march) --> has Digital interface DA2 slot map set to slot 11 by default, what code change or patch made it to different slot 8 ? (or is it the case only with test setup)

Will recheck the default settings at fresh bootup and will update here.

Burnt the 29th march, sd ubuntu image. By default, the "Headset Left" & "Headset right" is disabled". By using alsamixer, setting, both the parameters to enabled state, the audio works.

To store the settings permanents, The following command needs to be executed,

alsactl store --> stores the alsa settings persistently, so that the settings are persistent at every boot.

Modified the audio driver code, so by default, the Headset left and Headset right options are enabled. No user space settings are needed to enable audio. Patch is submitted for review.

Changed in igloocommunity:
status: In Progress → Fix Committed
Changed in igloocommunity:
milestone: 2012.04.alpha-1 → 2012.03-1
Kalle Vahlman (kvahlman) wrote :

Fix included in 2012.03.1 release with hwpack_linaro-lt-snowball_20120404-0_armel_supported.tar.gz

Changed in igloocommunity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers