Graphics fail if l-m-c created image is flashed onto some MMC cards

Bug #919246 reported by Lee Jones on 2012-01-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IglooCommunity
Low
Lee Jones
Linaro Image Tools
Won't Fix
Low
Unassigned

Bug Description

Tested working:
    SanDisk 4GB HC Class 2
    SanDisk 4GB HC Class 4

Tested broken:
    Kingston 8GB HC Class 4
    Kingston 16GB HC Class 4

$ linaro-media-create -v
    linaro-media-create: 2011.12

sudo linaro-media-create --mmc /dev/sdc --dev snowball_sd --hwpack \
~/Downloads/hwpack_linaro-lt-snowball_20120116-0_armel_supported.tar.gz --binary \
~/Downloads/linaro-o-ubuntu-desktop-tar-20120116-0.tar.gz

Lee Jones (lag) on 2012-01-20
Changed in igloocommunity:
status: New → Confirmed
importance: Undecided → High
Lee Jones (lag) on 2012-01-20
description: updated
Mattias Backman (mabac) wrote :

Could you give an example of how it fails so we know what to look for when reproducing the error? I seem to be unable to reproduce it, might be because I only have Sandisk cards.

Mattias Backman (mabac) wrote :

<lag> mabac: I haven't seen any images that work on all cards
<lag> mabac: The problem goes away if you build the image on a working card, then dd it on to a non-working card
<lag> mabac: It also goes away if you use the --image-size option

Mattias Backman (mabac) wrote :

I'll try to reproduce this on my V11 snowball and 16GB mmc.
There is a workaround; using --image-file works.

Changed in linaro-image-tools:
assignee: nobody → Mattias Backman (mabac)
importance: Undecided → Low
status: New → Triaged
Changed in linaro-image-tools:
milestone: none → 2012.02
Mattias Backman (mabac) wrote :

Trying with a 32 GB Kingston cl4 card:

partial l-m-c output:
Sleeping for 1 second(s) to wait for the partition to settle
  start: (c,h,s) expected (0,3,16) found (0,1,32)
  end: (c,h,s) expected (1023,3,16) found (25,127,31)
  start: (c,h,s) expected (1023,3,16) found (26,0,1)
  end: (c,h,s) expected (1023,3,16) found (1023,127,32)

I only get garbage characters on tty and it does not seem to boot.

Mattias Backman (mabac) wrote :

Ignore the l-m-c messages above, I get them with a Sandisk card too. It seems I can't boot my board with a Sandisk 16 GB either, I just get garbage. I'll try to do a full reflash of emmc later just to see if I can get it to boot at all. This is on my V11 btw.

Mattias Backman (mabac) wrote :

I see intermittent boot failures on the Panda too, where booting the desktop image fails on some cards, but every other boot or so work with the same image on the same card. I have discussed this with mpoirier who believes cl 10 cards should be used to boot our images. Lee is going to test using cl 10 cards and see if the problem goes away.

Setting to invalid awaiting those tests since I can't see how l-i-t can handle timing problems caused by some batches of mmc cards.

Changed in linaro-image-tools:
assignee: Mattias Backman (mabac) → nobody
milestone: 2012.02 → none
status: Triaged → Invalid
Changed in igloocommunity:
importance: High → Low
Anmar Oueja (anmar) on 2012-02-28
Changed in igloocommunity:
assignee: nobody → Lee Jones (lag)
James Tunnicliffe (dooferlad) wrote :

I have two PandaBoards. One will boot our images, the other won't most of the time, but will boot the PandaBoard test image. The problem seems to be that the older, non-working board can not find any partitions past the boot partition, no matter what card I try. The SD card reader pins look fine and booting the same card on the newer board works fine. Our images used to work on the older board but I can't find a combination of card, image and tools that will recreate a working Linaro set up.

lag: can you test the non-working cards with the pandaboard test image? http://pandaboard.org/node/13531/ has the details.

Lee Jones (lag) wrote :

Also see related, but not the same:

https://bugs.launchpad.net/igloocommunity/+bug/940339

Changed in linaro-image-tools:
assignee: nobody → Mattias Backman (mabac)
status: Invalid → Confirmed
Mattias Backman (mabac) on 2012-04-11
Changed in linaro-image-tools:
assignee: Mattias Backman (mabac) → nobody
Milo Casagrande (milo) wrote :

Due to the age of this issue, we are acknowledging that this issue will likely not be fixed, is no longer applicable, or was already fixed by an indirect change. If this issue is still important, please add details and reopen the issue for linaro-image-tools.

Changed in linaro-image-tools:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers