Snowball needs HDMIservice

Bug #898650 reported by Patrik Ryd on 2011-12-01
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
IglooCommunity
Medium
vathsala
Linaro Android
Won't Fix
Medium
Unassigned

Bug Description

Description:
------------
Testing that 11.12 staging snowball boots. The screen is blank if a DVI monitor is used.

Snowball needs git://igloocommunity.org/git/android/platform/vendor/st-ericsson/multimedia/linux/HDMIservice.git

There is a workaround for using DVI monitor. Do "echo 2 > /sys/devices/av8100_hdmi.0/hdmisdtvswitch" after the framebuffer has been created.

Reproducible:
------------
Yes, 5/5

Impact:
------
Must use a hdmi screen or use the work around above.

Steps:
------
Boot the snowball.

Expected Behavior:
Log looks ok, but screen is black (if using dvi)

Hardware:
---------
Snowball V11
HPL2151 ws monitor
HDMI to DVI cable

Software:
---------
https://android-build.linaro.org/builds/~linaro-android/staging-snowball-11.12-release/#build=4

Logs:
------
no log attached

Patrik Ryd (patrik-ryd) on 2011-12-19
description: updated

I am weary of adding userspace services to deal with something that should be done in the kernel. Benjamin Gaignard wrote a cool patch recently that does just that. It was rejected internally (specifically because of the userspace service) but I'm hoping of adding it in our kernel as soon as I get the time.

I have attached Benjamin's patch.

Anmar Oueja (anmar) on 2012-01-05
no longer affects: linaro-landing-team-ste
Changed in igloocommunity:
status: New → Confirmed
Anmar Oueja (anmar) wrote :

The TI LT has a similar issue (Bug: 894073) Not sure if it applies here.

Unfortunately the patch isn't working on landing-snowball with accelerated graphics.

Lee Jones (lag) wrote :

This isn't a bug. It's a design decision.

I have spoken to ST-Ericsson. Apparently the Graphics Team have no intention on redesigning this concept.

Changed in linaro-android:
status: New → Invalid
Changed in igloocommunity:
status: Confirmed → Invalid
Lee Jones (lag) wrote :

Ah, it appears I misread this bug. I was under the impression you wanted to get rid of hdmiservice and handle the logic in the kernel. This will not happen without a redesign of the subsystem.

For clarification Snowball Android _does_ require hdmiservice to be installed to obtain full functionality.

Changed in igloocommunity:
status: Invalid → Confirmed
Changed in linaro-android:
status: Invalid → Confirmed
Joe Burmeister (joe-burmeister) wrote :

I've updated Benjamin Gaignard so it can be used with the current "linaro_android_4.0.3" branch of "git://android.git.linaro.org/platform/manifest.git". Seams to work fine. Modified patch attached.

Zach Pfeffer (pfefferz) on 2012-03-21
Changed in linaro-android:
importance: Undecided → Medium
assignee: nobody → Mathieu Poirier (mathieu.poirier)

Joe, pls find me on IRC. I have applied your work to stable 3.2 but I get the following on the console. The UI starts but sortly after everything goes black.

[ 17.292114] av8100_hdmi av8100_hdmi.3: av8100_conf_w FAIL
[ 17.492004] av8100_hdmi av8100_hdmi.3: av8100_conf_w FAIL
[ 17.691955] av8100_hdmi av8100_hdmi.3: av8100_conf_w FAIL
[ 17.884307] av8100_hdmi av8100_hdmi.3: av8100_conf_w FAIL
[ 18.079254] av8100_hdmi av8100_hdmi.3: av8100_conf_w FAIL
[ 18.262115] av8100_hdmi av8100_hdmi.3: av8100_conf_w FAIL
[ 18.452056] av8100_hdmi av8100_hdmi.3: av8100_conf_w FAIL
[ 18.651031] av8100_hdmi av8100_hdmi.3: av8100_conf_w FAIL
[ 18.848175] av8100_hdmi av8100_hdmi.3: av8100_conf_w FAIL

Changed in igloocommunity:
importance: Undecided → High
assignee: nobody → Mathieu Poirier (mathieu.poirier)
milestone: none → 2012.04
Joe Burmeister (joe-burmeister) wrote :

Here's the build script I'm using with 0001-av8100-add-auto-detection-of-output-hacked.patch
It lives along side the patch. It's a slightly modified version of the now build script, but nothing that should make any difference.

Joe Burmeister (joe-burmeister) wrote :

I did manage to reproduce the problem Mathieu Poirier was having (and we spoke about it on IRC, he knew the patches author Benjamin Gaignard and was going to speak to him).
For me the problem seams to be in waking the screen, it all worked, until the screen went to sleep and I woke it up.

But I've just had something quite interesting in a build without the patch (using "echo 2 > /sys/devices/av8100_hdmi.3/hdmisdtvswitch" method):

root@android:/ # echo on > /sys/power/state
[ 202.332397] request_suspend_state: wakeup (3->0) at 202320265064 (2000-02-11 20:03:22.472873921 UTC)
root@android:/ # [ 203.401123] av8100_hdmi av8100_hdmi.3: av8100_download_firmware failed
[ 203.401123] detected fb_set_par error, error code: -14

I wonder if there is a general problem with waking up the av8100?
Anyway, thought I probably should share this information in case it is useful.

Changed in igloocommunity:
importance: High → Medium

I had to use "echo 2 > /sys/devices/av8100_hdmi.3/hdmisdtvswitch" to get it to work ...

Anmar Oueja (anmar) on 2012-04-16
Changed in igloocommunity:
milestone: 2012.04 → 2012.05

I started the HDMIservices that came with the release of MM. Things run well when the I2C bus is behaving but when reading the EDID fails the whole graphic stack crumbles. I will continue my investigation.

Changed in igloocommunity:
assignee: Mathieu Poirier (mathieu.poirier) → vathsala (vathsala-nagaraju)
Changed in igloocommunity:
milestone: 2012.05 → 2012.06
Changed in igloocommunity:
milestone: 2012.06 → 2012.07
Steven Walter (stevenrwalter) wrote :

To add a potentially interesting data point, I found that an HDMI-capable monitor connected with a HDMI-to-DVI cable works without intervention. However, in my experience a DVI-only monitor will never come up unless hdmisdtvswitch is manually changed; instead the monitor stays in "Standby Mode".

Changed in igloocommunity:
milestone: 2012.07 → none
Fathi Boudra (fboudra) on 2013-06-07
Changed in linaro-android:
assignee: Mathieu Poirier (mathieu.poirier) → nobody
vishal (vishalbhoj) wrote :

snowball no more supported.

Changed in linaro-android:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers