Enable wifi on lenovo g40 30 using linux's ideapad module

Bug #1450946 reported by Philippe Coval on 2015-05-01
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ideapad-laptop
Undecided
Ike Panhc

Bug Description

I noticed that lenovo g40 30 wifi is disabled by default on Ubuntu 15.04 and cant be enabled without removing module...

I made a simple kernel patch based on the yoga fixes and it works like charm...

So I plan to commit this upstream and report progress in this bugtracker.

If it's slow to be merged mentors are welcome...

More info to be shared at :

http://rzr.online.fr/q/ideapad

Does the patch fix bluetooth too?

Philippe Coval (rzr) wrote :

I am unsure since It's GUI is not listing devices but the adapter seems to be on :

Can you suggest a better test plan than that one :

    hcitool dev
    Devices:
        hci0 XX:XX:XX:XX:XX
    hidd --search || hcitool scan # shows nothing?

#3 That's exactly what happen to me. Btw if i plug e bluetooth interface (the ones with usb adapter) it works, so i don't think it's some kind of GUI bug.

Pilot6 (hanipouspilot) wrote :

I made a ppa for this module with G50-30 fix.

It can be installed by

sudo add-apt-repository ppa:hanipouspilot/ideapad-laptop
sudo apt-get update
sudo apt-get install ideapad-laptop-dkms

Pilot6 (hanipouspilot) wrote :

I can add G40-30 as well.

Philippe Coval (rzr) wrote :

That would be nice until patch is released ...

It has just been "queued"

https://lkml.org/lkml/2015/5/3/89

Is there any place to track progress now ?

Please free to bug me if it needs to be backported

I am now investigating on bluetooth support ...

Thanks for feedbak

Pilot6 (hanipouspilot) wrote :

Philippe,

It will be merged int0 4.1, but you did not add "Cc: <email address hidden>".
It means it won't get into Ubuntu stable kernels. You can reply to your mail and ask Darren to add stable.

I resent a patch regarding G50-30. You can see it there too.
https://lkml.org/lkml/2015/5/3/160

First time I sent it in February. But the problem is that Darren never answers my mails.
It looks like sam spam filter gets them out. I send patches to other lists with no problems.

If this is the case again, will you send my patch there too, since he sees your mails.

Philippe Coval (rzr) wrote :

Minor suggestion can you sort models alphabitically (or rebase on mine too) ...

Note I have bluetooth working fine now \o/

Is there anything more to check ? I will update my notes for community

Regards

Pilot6 (hanipouspilot) wrote :

Well, I can sort them, after yours applies to linux-next. I will just do another patch.
But I have problems in connecting Darren. You can send another sorting patch.
But there are not too many models yet, so it does not matter at all. Sorting can be done anytime later.

Philippe Coval (rzr) wrote :

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tag/?id=v4.1-rc3 is released

https://wiki.ubuntu.com/Kernel/MainlineBuilds should come next ... I'll double check if BT are missing

I can then push @Pilot6 change to list rebased on current head it if helps ok ?

Pilot6 (hanipouspilot) wrote :

I added your patch to my ppa for current users. And it would be helpful if you rebase mine too and push it.

Ike Panhc (ikepanhc) on 2015-05-18
Changed in ideapad-laptop:
status: New → Confirmed
assignee: nobody → Ike Panhc (ikepanhc)
Shlomi (shlomomatichin) wrote :

This also happens on Lenovo Yoga 700. Relevent dmidecode lines to add to the drivers:

System Information
    Manufacturer: LENOVO
    Product Name: 80QD
    Version: Lenovo YOGA 700-14ISK

Wouldn't it make more sense for this list to be dynamic, to also include future machines?

Ike Panhc (ikepanhc) wrote :

@shlomomatichin,

I do not have a better idea then add one by one into list. Perhaps use a module parameter or force all yoga system has no hardware switch.

In the mean time, can you show the result of `cat /sys/class/dmi/id/modalias` please?

Changed in ideapad-laptop:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers