i8kmon does not automatically control fan speed

Bug #1104842 reported by amoccia
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
i8kutils
Low
vitorafsr

Bug Description

When automatically controlling the fan speed, i8kmon executes the following command:

/usr/bin/i8kfan 1 2

This is incorrect as the usage of this command requires a 'fan' argument like so:

/usr/bin/i8kfan fan 1 2

Without the 'fan' argument, the fan speed will not be changed. The lack of this additional argument may be attributed to the i8kfan man page which incorrectly states the following:

       Invoking i8kctl as i8kfan is the same as invoking the program with the
       fan option:

              $ i8kctl fan 1 2
              1 2

              $ i8kfan 1 2
              1 2

However, checking the usage of the i8kfan command clearly states the 'fan' argument is required:

$ i8kfan --help
Usage: i8kfan [-v] [fan [<l> <r>] | speed | version | bios | id | temp | ac | fn]

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: i8kutils 1.33
ProcVersionSignature: Ubuntu 3.5.0-22.34-generic 3.5.7.2
Uname: Linux 3.5.0-22-generic x86_64
ApportVersion: 2.6.1-0ubuntu9
Architecture: amd64
Date: Fri Jan 25 02:36:42 2013
InstallationDate: Installed on 2013-01-21 (4 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: i8kutils
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.default.i8kbuttons: 2013-01-21T00:02:10.514767
mtime.conffile..etc.default.i8kmon: 2013-01-25T01:39:17.962000

Related branches

Revision history for this message
amoccia (amoccia) wrote :
Revision history for this message
vitorafsr (vitorafsr) wrote :

I think the problem is not syntax but that i8kmon needs the module 'i8k' to be loaded into kernel before properly function. Could you post the command below here?

# cat /proc/i8k

Revision history for this message
amoccia (amoccia) wrote :

The i8k module appears to be loaded:

# cat /proc/i8k
1.0 A07 417FJV1 44 -22 0 -22 0 -1 -22

vitorafsr (vitorafsr)
affects: i8kutils (Ubuntu) → i8kutils
Revision history for this message
vitorafsr (vitorafsr) wrote :

Ok. So the kernel module is loaded and, I supose, i8kmon is active.

I agree there is a text inconsistency in 'i8kfan --help', but besides that the i8kmon utility functions properly for many years in different systems.

This 'usage' does not affect the behavior of i8kmon. And I'd like to ask if you in fact have a problem in i8kmon controlling the fan ,or this is just a problem with the 'i8kfan --help'?

Revision history for this message
amoccia (amoccia) wrote :

i8kmon would not control the fan on my system initially. I had to modify it to add the missing "fan" before it would function properly. I'm at a loss as to why others do not have similar issues. All I can say is that on my system, the "fan" was required.

vitorafsr (vitorafsr)
Changed in i8kutils:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → vitorafsr (vitorafsr)
vitorafsr (vitorafsr)
Changed in i8kutils:
status: Triaged → In Progress
vitorafsr (vitorafsr)
Changed in i8kutils:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers