Class _associated error in 4.1 when viewing report

Bug #893973 reported by josephat mathayo on 2011-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
I2CE
Undecided
Unassigned

Bug Description

mathayo@Limi:~$ sudo /var/lib/iHRIS/lib/4.1.1/I2CE/tools/apache_tail.php 0
[sudo] password for mathayo:
[Wed Nov 23 14:36:00 2011] [error] [client ::1]
 Refered by : http://localhost/manage-eastern/index.php/CustomReports/view/reportViews
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.1.1/I2CE/modules/Pages/lib/I2CE_Wrangler.php:198)
       I2CE_Wrangler->getPage (/var/lib/iHRIS/lib/4.1.1/I2CE/modules/Pages/lib/I2CE_Wrangler.php:74)
       I2CE_Wrangler->wrangle (/var/lib/iHRIS/cssc_zonal_deploy/sites/eastern/pages/index.php:60)
 Cannot find a class associated to the requested page show for the module CustomReports
[Wed Nov 23 14:36:00 2011] [error] [client ::1]
 Refered by : http://localhost/manage-eastern/index.php/CustomReports/view/reportViews
 I2CE: I2CE->raiseError (/var/lib/iHRIS/lib/4.1.1/I2CE/modules/Pages/lib/I2CE_Wrangler.php:77)
       I2CE_Wrangler->wrangle (/var/lib/iHRIS/cssc_zonal_deploy/sites/eastern/pages/index.php:60)
 Unable to create page from path (/CustomReports/show/search_people)

Carl Leitner (litlfred) wrote :

Was it working before? If so, can you try restarting apache and memcache and see if that resolves the problem?

If you are updating from the command line (php index.php --update=1) you need to always restart apache/memcache when you are done.

Carl Leitner (litlfred) on 2013-08-21
Changed in i2ce:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers