ubuntu 16.04

Bug #1595008 reported by Roger Lawhorn on 2016-06-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
I-Nex
Undecided
Unassigned

Bug Description

no package available for ubuntu 16.04 (linux mint 18).
can someone make one?
thanks.

Lauri Ojansivu (xet7) wrote :

+1

I had to to build I-nex myself on Linux Mint 18, because package was not available yet, this way:

sudo add-apt-repository ppa:i-nex-development-team/libcpuid11

sudo add-apt-repository ppa:gambas-team/gambas3

sudo apt-get update

sudo apt-get install gambas3 build-essential dh-autoreconf debhelper devscripts python python-all python-dev python-all-dev pkg-config dpkg-dev libcpuid11-dev lsb-release libprocps4-dev libx11-dev libxext-dev libgl1-mesa-dev libglu1-mesa-dev gambas3-dev gambas3-gb-image gambas3-gb-qt4 gambas3-gb-form gambas3-gb-desktop gambas3-gb-form-stock imagemagick git

git clone https://github.com/eloaders/I-Nex.git

cd I-Nex/

fakeroot debian/rules build

fakeroot debian/rules binary

cd ..

sudo dpkg -i i-nex_7.4.0.1_amd64.deb

Roger Lawhorn (rll-m) wrote :

This is my procedure for mint 18:

We need the gambas3 PPA for Mint 17. The copy of gambas3 from the Mint 18 repos will not work with i-nex.
Open a terminal and copy and paste each line:
>sudo add-apt-repository ppa:gambas-team/gambas3
>sudo apt update

We will need to download an ubuntu 14.10 deb file to install i-nex. The official i-nex PPA does not support Mint 18, yet.
Download one of these installers:
64bit installer: https://launchpad.net/i-nex/trunk/7.4.0/+download/i-nex_7.4.0-0%7Ebzr855%7E20140813%7Eubuntu14.10.1_amd64.deb
32bit installer: https://launchpad.net/i-nex/trunk/7.4.0/+download/i-nex_7.4.0-0%7Ebzr855%7E20140813%7Eubuntu14.10.1_i386.deb

I-nex fix:

The post install script for i-nex may fail with an error. I would not normally provide a fix for a such a problem, but this error is coming from a post install script and causes the entire OS to give off errors everytime a new piece of software is installed which is totally unacceptable. The script doesn't do anything but tell their website one more copy has been installed. This fix does not prevent the script from running or modify what it does. It simply returns an exit status of ZERO which means everything went well so that Linux will stop complaining.

Open the post install script with a text editor and add the "exit 0" line to the end of the script.
Open a terminal and copy and paste:
>sudo nano /var/lib/dpkg/info/i-nex.postinst

#!/bin/bash if which curl >/dev/null; then
                                                                    curl --silent https://i-nex.linux.pl/?downloadcount=1 > /dev/null 1>&1
fi
exit 0

CTRL-o and then ENTER to save. CTRL-x to exit NANO.

And then the following to make the error go away:
>sudo apt-get install -f

Lauri Ojansivu (xet7) wrote :

I also added this as GitHub issue:
https://github.com/eloaders/I-Nex/issues/19

Because there seems to be issues at both places.

eloaders (eloaders) wrote :
Changed in i-nex:
status: New → Fix Released
Roger Lawhorn (rll-m) wrote :

ok, the issue is gone.
The standard PPA works with mint 18 now.
The copy of gambas3 from the mint 18 repo works fine with i-nex.
You can close this issue.

Lauri Ojansivu (xet7) wrote :

Roger,
I closed GitHub issue.

I did not find how to close this Launchpad issue, probably you can, because you added it here.

Roger Lawhorn (rll-m) wrote :

I see no way to close.
I have turned off email alerts for this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers